1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRK54G DISCONNECTION - Why they don´t fix it ?

Discussion in 'Cisco/Linksys Wireless Routers' started by Unpluged, Mar 30, 2006.

  1. Unpluged

    Unpluged LI Guru Member

    Hello guys,

    I have this model WRK54G dropping internet connection all the time
    when using Video stream ( drops and freezes router ),
    Ftp. Ex: Getright with 2 or more segments ( in this case it only drops but not freezes router).

    I´ve been researching about this problem and found that I´m not the only lucky guy
    with this problem. :cry:
    Others peoples contacted Linksys support already, but
    unfortunately with no practical solution or firmware upgrade.
    And yes, I have tried a lot of configurations changes.
    And yes, I have made tests with another routers and they worked fine.
    And yes, I´ve been talking with people experiencing the same problems
    So I think the problem is reeeally with the Linksys.
    My questions are:
    1.) If the Linksys people already know about it, why they did nothing about
    it until now? . The last firmware update is date from 2003!! ( 1.58.03)

    2) Why they keep updating only the WRT54G? They forgot about the WRK54g ?

    3) Is there someone has a truly answer or idea how to fix this annoying problem ?
    Or I have to buy (again) another router and forget about the day
    I thought Linksys was a renamed brand and never recommend it again to anyone.

    I´ll really appreciate it if someone has something to say about this.

    Thanks in advance.
    Unplugged.- A really frustrated unplugged guy. :sadbye:
  2. Toxic

    Toxic Administrator Staff Member

    unfortunately the WRK54G has very little support as it was not in the same league as the WRT54G/GS. firmware updates are brought out when jo public starts to complain, and since the fatc the WRT54G has more sales, means more complaints, and thus more firmware updates.

    when you say the inetrnet connection drops, is this from the WRK54G to your Cablemodem/ADSL Modem? or the wirless drops from your laptop to the WRK54G?
  3. Unpluged

    Unpluged LI Guru Member

    Hello Toxic,

    unfortunately the WRK54G has very little support as it was not in the same league as the WRT54G/GS.

    Yep...and for my sadness I have to agree with you. :(

    firmware updates are brought out when jo public starts to complain, and since the fatc the WRT54G has more sales, means more complaints, and thus more firmware updates.

    Again, you´re right. That´s why I trying to make them know about this. And I hope other customers do the same.

    when you say the inetrnet connection drops, is this from the WRK54G to your Cablemodem/ADSL Modem? or the wirless drops from your laptop to the WRK54G?

    Is from WRK54G To my ADSL modem. I even tried to turn off the Wireless without success. As I mentioned before, I did many tests
    as I could, trying to enclose the problem, but the results was always the same.
  4. kingvj

    kingvj Network Guru Member

    the router u have is a wrk54gv1.1. the beta 1.58.00 is supposed to fix the issue. check out with linksys chatsupport and they'll send it to u. do not forget to post ur feedback on the same as that firmware is known to resolve the issue of frequent d/c.

    btw, there is no such beta for wrk54gv1 (f/w 1.55.02) and u've gotta learn to live with it unless linksys does something 'bout it.
  5. sreevas

    sreevas Network Guru Member


    hai pls log in to the routers web interface using the and reduce the MTU to 1400 and im sure it will fix the issue try it and mail me the result to sreevas.v@gmail.com
  6. alinefx

    alinefx Guest

    Where can you change the MTU to 1400? On the status page, it shows 1500 but no where to change that value...

    Any idea where we can get 1.58.00 without an annoying call to a Call center?
  7. lfrls

    lfrls Guest

    i have 1.58.03

    i have 1.58.03. Is this a good version? because problems continue. vpn problems. wireless problems. if i connect to router with a ethernet cable everithing goes ok. i tried every conbination of parameters. my last is mtu 1400 but i think this will not solve.

  8. beast2k

    beast2k LI Guru Member

    I have this same router (wrk54g) with the 1.58.03 firmware and its a mess, this is the last linksys product i will purchase or recomend.
  9. mattila

    mattila LI Guru Member

    hi all!
    WRK54G 1.58.03. The problem is the same. Router hangs every now and then. Email sent to linksys. If I don't receive an answer I will bring it back to the shop. I won't buy another linksys product ever.
    If somebody has that 1.58.00 firmware please send it to me! But I'm not sure that I can "downgrade" the router to that one. It worth to try.
  10. beast2k

    beast2k LI Guru Member

    I droped my mtu setting from the default 1500 to 1300 and it has not gone down since. I got up this mornig and it was still connected, it has never in recient memory been up for more than an hour. I think this fixed the trouble for me, or at least improved it somewhat, even if it went down once a day I could live with unpluging and pluging it back in only once every 24 hours. I'll keep you updated and let you know the results after a few days.
  11. mattila

    mattila LI Guru Member

    thank you beast2k!
    i will give it a try
  12. mattila

    mattila LI Guru Member

    It did not work for me. Even with lower MTU setting the router hangs after 40-60 minutes. I am gonna bring it back tomorrow, and buy a new non-linksys one.
  13. mattila

    mattila LI Guru Member

    now it works somehow

    After a lot of different configurations, now it seems to work. I have to admit that the settings were strange before: i have two routers and both of them were in the same ip domain as the PCs. And they were connected through lan ports, this means the wan port of the secondary linksys was empty. :) Everything worked well, but the linksys hanged regurarly. After consultating with one of my friends, who is a professional, I have changed the settings and there was no disconnect since.
  14. rspalding

    rspalding Guest

    Linksys WRT54GS Disconnect problem

    I contacted a tech guy at Linksys.....He is one of the designers and told me to chage the following settings to correct this problem. I did it and have not had a disconnect since.
    Goto...Wireless-Advanced Wireless Settings

    Authentication Type: Auto
    Basic Rate: Default
    Transmission Rate: Auto
    CTS Protection Mode: Disable
    Frame Burst: Enable
    Beacon Interval: 50
    DTIM Interval: 1
    Fragmentation Threshold: 2304
    RTS Threshold: 2304
    AP Isolation : Off
    Secure Easy Setup: Enable

    Hope this helps....Rick S:)
  15. mattila

    mattila LI Guru Member

    the end of the story

    Well... That is the end of the story of my WRK54G. After I posted that it works now, it really worked for approx. 20 hours. After that the DHCP stopped working properly, sometimes the router did not want to assign an address to a new PC. But 10 minutes later it worked again, without any changes. And if I did not want to wait 10 minutes, a router restart was always a solution as well. So I don't want to understand the behavior of this device anymore. I have got rid of it, got my money back, and I have ordered my new router (D-LINK) already.
  16. beast2k

    beast2k LI Guru Member

    Here it is about 2 or 3 weeks later and it goes down ALOT less often but still goes down 1 or 2 times a day which is alot more managable than every few min or so. All in all I don't think I will be buying linksys again it seems the quality is gone from the product(s) and with no firmware update that tells me they don't really care as long as they get your money. If they were to release a fix for this my opinion could change however, but untill then...
  17. trout_fishin

    trout_fishin Guest

    wrk54g finally working (sort of)

    Edited - I thought changing the settings on my laptop's wireless card did some magic. I did have two glorious days of near solid performance. Then the horrid hiccups started again. I bought a new router now. WRTSL54GS, so far so good. What a relief! My network works!

    Changes on my wireless card seemed to be the magic. Oh, and moving the router away from the modem. (Is that crazy?)

    This router is junk, and I still may try to get a replacement from Linksys, but it is tolerable now. I now have pauses of about 10 sec every 30-60min hour instead of the frustrating previous condition: 60sec or more every 20 min or so, sometimes requiring powering off the router!

    I changed the MTU on the router, lowered the beacon interval, lowered the Fragmentation and RTS threshhold to 2304 and

    Turned off Afterburner
    Changed the Fragmentation and RTS? threshhold to 2304

    I could be more detailed, I know. I'll check the whole list of settings if someone else is interested.
  18. Neal-UK

    Neal-UK LI Guru Member

    Mine does this all the time, it's realplayer that it tends to do it.
  19. Rectorb

    Rectorb LI Guru Member

    I have the firmware for this problem...

    It's a Beta, but it works.

    Email me at Tylercorbin@gmail.com
  20. colino

    colino LI Guru Member

  21. colino

    colino LI Guru Member

    My internet connection has been dropping approximately once a day.

    I have tried loading the above firmware and it appears to work I will report back later to tell you if it has resolved my problem.
  22. colino

    colino LI Guru Member

    Yes 1.58 cures my problem!
  23. SHO NUT

    SHO NUT LI Guru Member

Share This Page