1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wrong Firmware!

Discussion in 'HyperWRT Firmware' started by n0rcal, Mar 25, 2006.

  1. n0rcal

    n0rcal LI Guru Member

    Argh! I flashed WRTSL54GS instead of WRT54GS what can i do to go back? I have tried flashing with the right firmware, but still fails. If anyone has any ideas please let me know. otherwise I guess its to best buy I go. DOH!
     
  2. Toxic

    Toxic Administrator Staff Member

  3. shimir4u

    shimir4u Guest

    Hi

    IF you have download the firmware then you can visit on the linksys web site and download the latest firmware on yur router , and if yu need the old firmware then also you can visit on the web site of FTP://ftp.linksys.com and download the latest firmware on yur router

    regard s
    shimir srivastava
     
  4. n0rcal

    n0rcal LI Guru Member

    doh, nothing seems to work...i dont know what to do...i mean the router works and all but its all wrong
     
  5. jgutz20

    jgutz20 Network Guru Member

    are you trying to flash with a tftp program?
     
  6. n0rcal

    n0rcal LI Guru Member

    nope, is that my problem? if so can u hit me with a link that would work with my router
     
  7. Toxic

    Toxic Administrator Staff Member

    can you ping 192.168.1.1 ?
     
  8. n0rcal

    n0rcal LI Guru Member

    yeah i mean the router works, but only for a short amount of time. then it starts to fuck up the port forwards and disconnect the wireless. i then have to reset it. im just wondering how it accepted the firmware in the first place. and if you can flash the wrong firmware i dont see why you can flash the right one? is there a command i can change in the bin file?
     
  9. Toxic

    Toxic Administrator Staff Member

    what version of WRT54GS do you have?

    Known serial numbers (first 4 characters) vs versions / Chipsets:

    CGN0 = WRT54GS v1.0 / ADM6996L Chipset / CPU 200Mhz
    CGN1 = WRT54GS v1.0 / ADM6996L Chipset / CPU 200Mhz
    CGN2 = WRT54GS v1.1 / BCM5325EKQM Chipset / CPU 200Mhz
    CGN3 = WRT54GS v2.0 / BCM5325EKQM Chipset / CPU 200Mhz
    CGN4 = WRT54GS v2.1 / BCM5325EKQM Chipset / CPU 200Mhz
    CGN5 = WRT54GS v3.0 / BCM5352E Chipset / CPU 200Mhz
    CGN6 = WRT54GS v4.0 / BCM5352E Chipset / CPU 200Mhz
    CGN7 = WRT54GS v5.0 / BCM5352E Chipset / CPU 200Mhz
     
  10. n0rcal

    n0rcal LI Guru Member

    CGN4 = WRT54GS v2.1 / BCM5325EKQM Chipset / CPU 200Mhz
     
  11. Toxic

    Toxic Administrator Staff Member

    ok this should possibly work like so:

    you'll need the ddwrt generic firmware

    here

    and the TFTP utility

    you'll need to set you IP address manually to
    IP: 192.168.1.2
    subnet: 255.255.255.0
    gateway: 192.168.1.1

    then get the tftp ready (selecting 192.168.1.1 and password admin and selcting the generic bin file) to flash the WRT54GS, then power down the WRT54GS and then power it up again. as soon as the WRT54GS starts, click on the upgrade button, then should force the generic code to the router. if it works then you can reflash with the correct firmware.

    hope this helps.
     
  12. n0rcal

    n0rcal LI Guru Member

    i couldnt get it to upload? maybe i am missing a step? or maybe im doing something wrong?
     
  13. Toxic

    Toxic Administrator Staff Member

    did you add the password in the in the TFTP utility?

    can you ping the router?
     
  14. n0rcal

    n0rcal LI Guru Member

    Does the router have to have the pass set to ADMIN or do I use the one I changed it to? Because I have been using the one I changed it to.

    Does the computer have to be 192.168.1.2? I have mine set to 192.168.1.105
     
  15. Toxic

    Toxic Administrator Staff Member

    depends on whether or not you reset the router. if you reset then the password goes back to admin (all lowercase)

    tbh why not try both passwords?
     
  16. ShiveAhoy

    ShiveAhoy Network Guru Member

    I did the same thing, it was easy to fix. have the dos window open with the tftp ready to put the thibor14 binary to the router, open browser and go to admin screen, hit reboot... then switch back to dos window, hit enter to start the upload... voila.

    the key is, the router has to be booting to be able to successfully upload the binary.. otherwise you get a timeout error.
     

Share This Page