1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54G - 7.3km Link - Very Poor Download Speeds

Discussion in 'Cisco/Linksys Wireless Routers' started by Ryder-JHB, Sep 8, 2005.

  1. Ryder-JHB

    Ryder-JHB Network Guru Member

    Hi People,

    I am currently part of a Wireless Mesh community in South Africa. We currently have a network of 13 nodes. All of these nodes run WRT54G's with Freifunk / OLSR Firmware.

    This past weekend, I setup a link which is 7.3km in length. There is a WRT54G (V2.2) running Freifunk Firmware (OpenWRT) and a 24dbi Parabolic Grid at each end.

    Our signal strengh is good - RSSI 60, Noise 90 and our pings our fine - 2ms, 3ms etc.

    However, when running the "never ending download" test from the router's status page, the speeds never get above 20kb a second.

    I have two other links from my house, 1 is 4km and 1 is 3.7km and on both of these, I experience download speeds (on lan, not internet) of around 1.7mbit a second...

    I have tried the obvious stuff - re-aligning antennas, changing channels, decreasing rates, etc but nothing seems to help

    Is there anyone out there that may have come across something similiar and would know how I could go about fixing it?
     
  2. bobo71

    bobo71 Guest

    This is ok!

    The WRT have no "Long Distance Mode".

    Lancom Routers supportet this ...

    I have a distance of 4000m und have 200KByte/sec(5MBit).

    Cu...

    P.S. Sorry for my bad english i m from german.
     
  3. Ryder-JHB

    Ryder-JHB Network Guru Member

    The WRT54G can support this range, and longer. I have a friend who runs a 18km link and a 14km link and everything is fine and fast.

    I have duplicated his configuration but must be missing some setting somewhere.
     
  4. avax

    avax Network Guru Member

    people, lover the output strenght on the wrt but use an amplifiler between your router and antenna on both places and it will work. i have a link with 4 hops on a lenght of 13km and when i perform an internal download i get 4,2mbps


    PS sorry for my english I am from Bosnia and Hercegovina :)
     
  5. estqwerty

    estqwerty Network Guru Member

    I have the same problem ~1km
    signal ~75 noise is low
    ~100k
    hardware ver 2.2
    openwrt
    Bulgaria
     
  6. Toxic

    Toxic Administrator Staff Member

    Try this if your firmware supports it.

    wl shortslot_override 0

    it may give you some speed gains but not much. also make sure frameburst is enabled.
     

Share This Page