1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54G + Alchemy Final 1.0 + DHCP + Comcast

Discussion in 'Sveasoft Firmware' started by hfam95, Jul 1, 2005.

  1. hfam95

    hfam95 Network Guru Member

    If I have my WRT54G connected to my cable modem PCX2200 I cannot get a dhcp lease.

    I have tried several things with no luck. MAC cloning does not work. I put the linksys firmware and it works correctly.

    I need alchemy becasue I like the WDS function. Can anyone help me get DHCP working on this box.

    Thanks
     
  2. dotinfo

    dotinfo Network Guru Member

    Disable STP under administration->management... I used to have the same problem. You might want to do a reset to factory defaults, then disable stp, then let your cable modem sync up before you power on your router. Hope this helps..
     
  3. redrock

    redrock Network Guru Member

    STP?
     
  4. dotinfo

    dotinfo Network Guru Member

    STP is spanning tree protocol. It is a routing protocol that "supposedly" comcast and some other cable companies don't support. When I was having problems with alchemy and talisman in the past it was on by default. I disabled it and still couldn't get an ip address, but after another power cycle of the modem, then the router I could get an ip.

    So login to your router. There should be an option under administration -> management called STP. or Spanning Tree Protocol. Disable it and save settings. Turn of your cable modem. Then turn off your router. Then turn your cable modem back on. Wait about 60 - 90 seconds. Plug your router back in. You should have an ip. Hope this helps.
     
  5. redrock

    redrock Network Guru Member

    I'm running Alchemy 1.0 Final, just like the thread starter and there is not a STP option under administration on this version. Mine will eventually get an IP after enough power cycles of the cable modem and/or WRT54.

    [​IMG]
     
  6. redrock

    redrock Network Guru Member

    Looks like it can be disabled using "brctl stp br0 disable" through SSH or telnet. Dunno if this is a set disable or if it reverts on power cycle, though.
     
  7. dotinfo

    dotinfo Network Guru Member

    Try disabling "routing" . In your options. I think it will fix it. let me know if it does.
     
  8. redrock

    redrock Network Guru Member

    The routing option is enabled on mine, but it doesn't apply as I'm running mine as a gateway. But the above command line seems to have worked, I can release and renew the address from within the web interface, without having to power cycle repeatedly to get an address.
     

Share This Page