1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54g Dropping Connection/Slow Ping

Discussion in 'Cisco/Linksys Wireless Routers' started by MrGuilt, Mar 4, 2008.

  1. MrGuilt

    MrGuilt Guest

    Hi!

    We have a 3.5 year old version 2 WRT54G, running firmware 2.02.7. Over he last several weeks, I have noticed degraded WiFi performance, along occasions where my WiFi devices don't connect as quickly. Nothing I could firmly put my finger on, but definitely something was up.

    Last night, it disconnected for a good bit, and took a power cycle of the device to get it back. Along with this, I've noticed long ping times. When pages aren't loading, I might ping the router, and get dropped packets, then a long ping time (over 300 ms).

    I let the ping run, and it stabilized to about 1 ms for two-three pings, then one in excess of 1500 ms, then one about half that, then repeat (every fourth ping being high).

    This behavior does not exist when plugged in via wire. At least one device has been regularly taken to other WiFi sites during this period, and has no trouble.

    As I mentioned, this device is over three years old (we got it the weekend before my daughter was born), and never had a problem.

    My next step is to update the firmware to current (4-dot-something). I hadn't done so (don't buy trouble (I'm used to Microsoft patches)). What other troubleshooting steps should I take. How can I tell if my device is just plain broke?

    thanks,
    Charles
     

Share This Page