1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54G Emule success stories?

Discussion in 'Cisco/Linksys Wireless Routers' started by halion, Apr 21, 2005.


WRT54G and Emule(forwarded, high id)

  1. Works like a charm!

  2. #@%$^ing linksys pice of #$%

    0 vote(s)
  1. halion

    halion Network Guru Member

    I have recently purchased a WRT54G after an old d-link died on me. I then updated the firmware to the latest version (3.03.6)

    I am trying to run emule. I am forwarding two ports, one tcp, the other udp to my computer's static IP address. I can connect to both of the networks that emule uses fine (with high id).

    However, once emule seems to start gathering sources (5-10 minutes) and downloading, my WRT54G router dies. It becomes unpingable and is only fixed by cycling power. Sometimes, power cycling doesnt help, and the router must be completly reset. When I run emule without port forwarding, I have no problems... But I also have an extremely gimped emule.

    I have a problem with this. Other people have problems with this.

    After some research online, I believe I may know what is going on. The WRT54G seems to have a limit on the number of incoming connections that can be mapped across a port forwarding rule. And when my emule wants 150 connections, the router has a hard crash. This may or may not be correct, since I have tried reducing the max number of connections to 25, and totally disabling the UDP port and KAD network (This, little boys and girls means very little downloading) and still have problems.

    I realize that this problem has to do with the router itself. Emule, as it has always been in the past, is configured correctly. I have no firewalls running on my computer (that's what the router is for).

    What I want to know is, has anyone been able to run emule with port forwarding with any success using the WRT54G? Is mine just broken?

    If not, what routers can handle emule's port forwarding load?
    And what kind of cash can I get back for returing this POS?
  2. jagboy

    jagboy Network Guru Member

    are you doing this form a wireles or fomr the wired
  3. halion

    halion Network Guru Member

  4. jagboy

    jagboy Network Guru Member

    then the wrt54gv3 and v2.2 has a flaw in the ethernet chip and reboots under heavy load. so in other words i dont think that there is a sloution for this
  5. halion

    halion Network Guru Member

    Mine specificly, or in general?

    Should I replace it with the same model, or forsake linksys forever?
  6. jagboy

    jagboy Network Guru Member

    just in general i most wrt54gv3 and wrt54gv2.2 have this problem. you should replace it with a wrt54gv2 in my opinon. dont forsake linksys they are a great company linksys just needs to learn that "if it aint broke then dont fix it".

  7. jagboy

    jagboy Network Guru Member

  8. halion

    halion Network Guru Member

    I have installed the HyperWRT 2.0 firmware. And used startup script:

    echo "600 1800 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts

    I still have problems.

    However, the router does not need power cycling. Instead it just drops the PPoE connection.

    Slightly more useful... But still incredibly useless.

    Dear Linksys,
    I hate you and your products suck.
    -Ex Customer
  9. shygrouch

    shygrouch Network Guru Member

    i used to have this problem too, first with a Microsoft MN700 router, and then with the Linksys WRT54G V2.2. Finally I found a fix that worked for me. I tried the Linksys Beta Firmware V4.00.7 Low Clocked, and it hasn't locked up since. I then tried the official Alchemy firmware V1.0 , overclocked the cpu manually to 216, and still working great. I added some heatsinks and 2 small cpu fans to keep the router from overheating.

Share This Page