1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54G, LAN led still lit and not blinking

Discussion in 'Cisco/Linksys Wireless Routers' started by martyrod75, Nov 21, 2008.

  1. martyrod75

    martyrod75 Addicted to LI Member

    The WRT54G v5 unit came from a friend, the status is Power Blinking and LAN and INTERNET led are on/still lit (not blinking even when LAN cable from a computer is connected, the computer tells that the Local Area Connection is disconnected). Do I need to use JTAG on this one?
     
  2. CaNsA

    CaNsA Network Guru Member

    Check ur cable is not a crossover cable,

    also do a 30/30/30 reset on it.

    then try the ping during startup method, if u get a reply then u can tftp and fix it :D
     
  3. martyrod75

    martyrod75 Addicted to LI Member

    nope, my LAN cable is not crossover and i am using my modem's LAN cable
    i'll give your suggestions a try

    UPDATE:
    I did a 30/30/30 reset and its still no use it does not respond at all, the power led still blinks while the LAN led are lit without any LAN cables connected. Already tried shorting 15 & 16 pin and its still not responding.
     
  4. martyrod75

    martyrod75 Addicted to LI Member

    I am now trying to use JTAG and use HairyDairyMaid debrick utility.

    This is what I have right now:
    Code:
    ====================================
    WRT54G/GS EJTAG Debrick Utility v4.8
    ====================================
    
    Probing bus ... Done
    
    Instruction Length set to 8
    
    CPU Chip ID: 00000101001101010010000101111111 (0535217F)
    *** Found a Broadcom BCM5352 Rev 1 CPU chip ***
    
        - EJTAG IMPCODE ....... : 00000000100000000000100100000100 (00800904)
        - EJTAG Version ....... : 1 or 2.0
        - EJTAG DMA Support ... : Yes
    
    Issuing Processor / Peripheral Reset ... Done
    Enabling Memory Writes ...
    It stays at Enabling Memory Writes for more than 10 minutes, it does not proceed to the next.

    Hope some one can help me with this.

    UPDATE:
    I have successfully flash the CFE, using this commands (in order):
    -erase:nvram /noemw
    -erase:kernel /noemw
    -flash:cfe /noemw

    Downloaded the CFE.bin from http://www.dd-wrt.com/dd-wrtv3/dd-wrt/downloads.html at others/wrt54gv5 flashing section and flashed the CFE using the "-flash:cfe /noemw" parameter. The LAN led are no longer lit or still and my Local Area Connection now says it is connected when I connect my LAN cable, only problem now is power led still blinks and cannot ping the router to 192.168.1.1, my Local Area Connection is configured as;

    IP address: 192.168.1.3
    Subnet: 255.255.255.0
    Default gateway: 192.168.1.1 (optional, i tried to remove this and return it again many times)

    Still no response from the ping commands.
     
  5. martyrod75

    martyrod75 Addicted to LI Member

    Any help here, please?
     
  6. irootsk

    irootsk Addicted to LI Member

    hi marty.
    Check this. It's pulled out from my litlle debricking HowTo for WRT54GL v1.1 :)
    Basicly it's same process. Here is my package for unbricking

    Also you have to download original Linksys firmware for your router and rename it to code.bin
    Also parameter /fs:05 shouldn't be good for your router. You should use correct one according your flash chip.

    *************************************************
    If all the Ethernet LEDs stay lit then you need to reload the cfe and nvram then erase the kernel.

    WRT54G -flash:nvram /noreset /fs:05 - command used to restore nvram
    WRT54G -flash:cfe /noreset /fs:05 - command used to restore CFE


    WRT54G -erase:kernel /noreset /fs:05 - command used to erase kernel

    It will show erasing all the pages up to about 90. I found that sometimes the Jtag utility might hang somewhere in the middle
    and momentarily disconnecting the power might help but you should re-run the command.
    You can hit Ctrl-C to stop the utility and run it again.

    After the erasing procedure is done type this command to tftp the good firmware back on the unit.

    tftp -i 192.168.1.1 put code.bin

    The LAN LED will rapidly flash for about 4 seconds while it's copying the file.
    Then the unit will reboot about 2 minutes later with the good firmware back in place.
    *************************************************
     
  7. martyrod75

    martyrod75 Addicted to LI Member

    I am using HairyDairyMaid WRT54G Debrick Utility v4.8 and I think your sample commands is not functioning with my HairyDairyMaid Utility.

    My router is WRT54G Hardware version 5.0 and not WRT54GL which is Linux capable router.
    If yours is /fs, I might try /fc on my utility version 4.8, result is Could not open NVRAM.BIN for reading using "WRT54G.exe -flash:nvram /noemw /noreset /fc:44". For "WRT54G.exe -flash:cfe /noemw /noreset /fc:44" can I use the CFE.bin from www.dd-wrt.com?
     
  8. irootsk

    irootsk Addicted to LI Member

    marty - have you manage to unbrick it?
    FYI - you can run Linux based firmware on your WRT54G v5. I've got second router same as your's which is running on DD-WRT firmware without any problem. :wink:
    you can use dd-wrt micro - it's only 1.7MB -check it with google
     
  9. cento50

    cento50 Serious Server Member

    done thak's i use all comand /noreset /nobreak in my WRT54GL 1.1 i need restore mac a this time i need restore my bakup cfe ? i have open my cfe bakup have my mac in..

    best regards
     

Share This Page