1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54G Port Forward Problem?

Discussion in 'Cisco/Linksys Wireless Routers' started by mwhite, May 3, 2005.

  1. mwhite

    mwhite Network Guru Member


    I am appear to be having a port forward problem. I have set up my WRT53G to port forward 80 to the apache webserver on my linux box however I can't access the site from outside my network. The look up and access happens fine from inside.

    The WRT is using latest version of the linksys firmware. Firewall is on but the only option that is checked is the ident option. It is set to use the Dynamic DNS option with DynDNS - the ip is correct.

    The network is arranged as follows;

    WRT54G (Gateway) - serves wireless machines around the house.

    WAP54G (Access Point Mode) - attaches a small network consisting of the Linux box and my XBOX to the wireless network.

    Everything works fine internally and all machines can connect to the outside world no problem at all. I just can't reach the webserver from outside.


  2. cromrell

    cromrell Network Guru Member

    tested w/o Dyn DNS?

    Have you tried testing w/ static IP (WRT54G gateway)?

    I am currently using Linksys firmware, and can fwd port 80 based on static ip address... to my exchange server for OWA (Outlook Web Access).

    This might help you isolate the problem with port forwarding or dydns.

  3. mwhite

    mwhite Network Guru Member

    I tried the ip address that resolves from DynDNS - didn't work either. I will check to see if the address has been updated properly when I get home.
  4. jagboy

    jagboy Network Guru Member

    go to he firewall tab and uncheck
    Block Anonymous Internet Requests
    this is optional...if the above does not work then try the suggestion below
    and change the remote mangament port to 5000 in the magment page.
    of course you should enable remote managment
  5. cromrell

    cromrell Network Guru Member

    Here are my settings:

    WRT54G v1 3.03.6 (linksys firmware)

    Security/Firewall Config:
    firewall protection: enabled
    Block Anonymous Internet Requests: check
    Filter Multicast: no check
    Filter Internet NAT: no check
    Filter IDENT: check

    Application/Port Forward config:
    Applicaition (web)
    start: 80
    end: 80
    Protocol: BOTH
    IP address: (static destination)
    Enabled: check
  6. cromrell

    cromrell Network Guru Member

    FYI: I am port following the following:
    Windows Terminal Server (port 3389)
    PC Anywhere (port 5631)
    general http (port 80)
    two ip based internet camera (ports 81 & 82)
  7. mwhite

    mwhite Network Guru Member

    OK, so I have configured the firewall as suggested and changed the remote config port. I also forwarded another port (10000) to another application on the linux box.

    The forward on port 10000 and the remote config both work fine. However the forward of port 80 for the apache webserver still does not work!

    Any ideas?
  8. Bartman69

    Bartman69 Guest

    Just curious, have you served a website using that isp before?
  9. mwhite

    mwhite Network Guru Member

    No - I will see if they are blocking port 80
  10. mwhite

    mwhite Network Guru Member

    Yep - it looks like my ISP blocks port 80!
  11. jagboy

    jagboy Network Guru Member

    look like your problem is soved right?

    btw what isp do you use
  12. mwhite

    mwhite Network Guru Member

Share This Page