1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54G Power LED flahing when reset and connected to WAN

Discussion in 'Cisco/Linksys Wireless Routers' started by Lazybones, Oct 30, 2004.

  1. Lazybones

    Lazybones Network Guru Member

    I have tested this with both the Sveasoft Satori Firmware and the latest Official Linksys Firmware. My WRT54G is a version 1.1 and brand new.

    My problem is that if the unit is reset and my cable modem is on / connected to the wan port the unit will continue to flash the power led and I will have no WAN connection.

    If I turn off / disconnect my cable modem while it is resetting then it will boot. If I then reconnet the cable modem I can get a connection.. The problem is that I will loose the WAN connection again over night.

    My cable modem is a Motorola SB5100, it works fine with my old BFSR41 and a linux box I was also running..

    Do I have a bad WRT54G, should I return it?
  2. Toxic

    Toxic Administrator Staff Member

    when you say reset is this a 30 second reset ?

    you need to press the reset button for 30 Seconds to reset all nvram setting to default.
  3. Lazybones

    Lazybones Network Guru Member

    Thats by holding the reset down for 30 s right? Then yes, I just tried it again..

    If I cycle the power on the unit while the cable modem is on it will blink the power light in the pattern (blink, blink,blink,pause,blink, blink,blink,pause...), but if I cycle the power with the cable modem off I get (blink, blink,blink,pause,blink, blink,blink,pause then some rapid blinking and finally a solid power light. If I then connect or turn on the cable modem every thing appears to work, at least for several hours or until the power is cycled.

    Edit: the linksys support site only solution for a blinking power LED is to reload the firmware which I already have done. I did a 30s reset after each time I flashed it.
  4. Toxic

    Toxic Administrator Staff Member

    can you try and clone the mac address. some ISPs need the mac address to be cloned.

    try that and tell me what happens. failing this try lowering the MTU setting by 8 each time.
  5. Lazybones

    Lazybones Network Guru Member

    Mac address does not mater with my ISP..

    I called linksys support and they couldn't figure it out and told me to exchange the unit... Went to the store, got a new unit, its also a v1.1

    Started it while connected to the modem, WORKED !!! firmware v1.42.1

    Upgraded to 3.01.3, problem returned.

    Back flashed to 1.42.1 downloaded from linksys. Problem continues!!!!

    Maybe I am not resetting the unit correctly or it was just chance that it worked the first time..

    Tried playing with the MTU, went all the way down to 1000 still didn't work..

    I am not sure where the problem would be.. It seems to be a firmware issue but going back to the older version does not seem to fix the problem.
  6. Toxic

    Toxic Administrator Staff Member

    restting the router is done by pressing reset button for 30 Seconds. then allowing the router to reset/reboot itself.

    then try the follwing once the router is reset.

    Shut down the computer.
    Unplug the router’s power cable.
    Unplug the Broadband modem’s power cable.
    Wait for 30 seconds.
    Plug in the Broadband modem’s power cable and wait for its lights to stop blinking.
    Plug in the router's power cable once the modem’s lights stop blinking.
    Finally, start up the computer and test the Internet connection.
  7. Lazybones

    Lazybones Network Guru Member

    - Router fails to start IE blinking Power even with PC not connected

    - Power on router then power on modem - WORKS
    - Power on modem then power on router - Fails 99% of the time.. I have had it work 2 twice in my testing, always fails if I retest.

    From the firmware read me file
    The first line indicates that the wireless driver has been updated, would that be a permanent change? Or just part of the normal flashing?

    This release also indicates that it cannot downgrade to previous versions, but this WAS the version linked for download directly on the linksys site for a version 1.1 router, and support didn't think it was a problem
  8. Lazybones

    Lazybones Network Guru Member

    I was doing some searching for information on the latest firmware when I found this Quote

    The thing that I noticed was that the boot loader has been changed, and it is during the boot process that most of my problems occur.

    Is it possible that there is a Bug in the linksys boot loader? If so is it really not possible to replace it with an older version?

    Edit: I think I am just going to return this unit tomorrow and get a WRT54GS, its more money but after searching all over the place I have noticed that the G units only get about 50% positive reviews where the GS is about 72%. Are these units that much of a crap shoot?

    The funny thing is that all I really want at the moment is a robust router with QOS because my house hold is full of Gamers and P2P users.. My old BEFSR41 has no QOS and doesn't seem to handle the heavy load all that well. Might have to build my self a Linux router box gain.

    Edit: Picked up a GS, no issue with the default Firmware, upgraded directly to Satori 4.0 GS and everything seems to work great!!!!

    If it where not for the fact I could mod the unit with extra features, I would not have bothered with another linksys unit. The linksys phone support doesn't have a clue when it comes to any question that is not already in their database of answers.

Share This Page