1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

wrt54g(ppoe)--wl--wrt54g--xbmc(kai) with hyperwrt?

Discussion in 'HyperWRT Firmware' started by bischen, Mar 12, 2005.

  1. bischen

    bischen Network Guru Member


    i´ve allready done alot of search and alot of tests but i can´t get it work. I even can´t telenet to my second router. Putty allways tells me Network error:connection timed out - so I think it will never work.

    My config:

    Router 1 WRT54GV2.2:
    No WEP/WAP yet
    DHCP disabled
    wl lazywds 0
    wl wds 00:12:17:D4:83:19 (Mac of router2)
    internet runnin perfect on pc connected by wire

    Router 2 WRT54GV2.2:
    No WEP/WAP yet
    DHCP disabled
    wl lazywds 0
    wl wds 00:12:17:D4:83:1C (MAC of 1st Router)
    wget http://www.myrealwebspace.de/bilder/kaid -O /tmp/kaid
    wget http://www.myrealwebspace.de/bilder/kaid.conf -O /tmp/kaid.cnf
    chmod +x /tmp/kaid
    /tmp/kaid -d

    But I think the main problem is that I cant even connect or ping my 2nd router.

    Please help

  2. bischen

    bischen Network Guru Member


    No Help needed anymore. Got it runnin. Kai on Xbox, Weather in XBMC, Music and other files stream from PC. Perfect. After about 25 hours of workin on that.


  3. dellsweig

    dellsweig Network Guru Member

    Have you tried DDWRT with KAI built in??
  4. bischen

    bischen Network Guru Member

    What is this dd thingi?
  5. bischen

    bischen Network Guru Member

    OMG is that a new firmware?
    Ive done it by uploading it to my webspace and gettin it at routerstartup from the www.
    A working firmware would be great. btw I can´t get kaistation to work because of a large distance between the 2 routers - so I have to have the 50 mW setting.

    Thanks for the hint!

  6. dellsweig

    dellsweig Network Guru Member

    I have been using this for a few weeks now - It works pretty good. Very stable. I have it running on both 2.2 and 2.0 hardware. I have a pair in WDS configuration and one as Wireless Bridge


    I love the sysinfo web page - make sure you enable info page on the administration page
  7. bischen

    bischen Network Guru Member

    Hi Dellsweig,

    thank you for the link will try it soon. Do you know if I can adjust the transmit power? By the way i love dd thingis (.)(.) (hope my gf don´t read this).

  8. dellsweig

    dellsweig Network Guru Member

    Look under wireless->advanced settings

    Did the kaid stuff work ok??
  9. bischen

    bischen Network Guru Member

    I don´t know. There are so many options to check but I don´t find a option for kai. I think i am not pro enuff to do every option wright. So I don´t have a wireless link to my xbox-router.

  10. dellsweig

    dellsweig Network Guru Member

    Look under the administration tab - scroll way down
  11. bischen

    bischen Network Guru Member

    Will have a look. Do I need the lazywl mode?
  12. dellsweig

    dellsweig Network Guru Member

    Lazywds allows other WDS nodes to associate with your main WDS router without having to know their MAC address. If you know the WIRELESS interface MAC address of both routers, turn off lazywds and use the MAC addresses
  13. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    It is written by BrainSlayer who is a forum member of the teamxlink.co.uk forums for Kai. Posts indicate it is stable but only as of Alchemy 5a source. I have listed below info from the change log to show what has been fixed as of Alchemy pre7a:

    Added DNS and DHCP server restart timer
    Added loop protect for SSL
    Improved client mode detection
    Misc fixes and enhancements

    Alchemy-60rc6a additions from Alchemy-6.0rc6

    Modified libpcap to work with pppd for filter operations
    Modified pppd to work with our custom libpcap
    Fixed active filter for on-demand PPPoE (untested)
    Added iptables string match
    Improved site survey internal error checking
    Fixed static IP bug

    Alchemy-60rc6 additions from Alchemy-6.0rc5a

    Critical fix for HTTPS daemon
    Critical fix for DHCP daemon
    Critical fix for WDS
    Critical fix for OSPF
    Qos and iptables enhancements
    Fix for IRC, time, string iptables matching
    Fix for webserver crash with QoS disabled
    PPPoE filter mode added, fix for timer resets
  14. bischen

    bischen Network Guru Member

    I can´t get no wl connection. Connectet via string to first router I have full Iternetaccess and access on Pc (con to router1) on xbox. But kai doesn´t run. These many options are confusing me.
    wireless - AP or Client or ADHOC?
    WDS LAN or P2P and what to type in after MAC-Adress?
    And Administration - Management OMG.

    I think this fw is great for pros. But for me I think it is frustrating. :(

  15. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    Maybe you should try a different firmware then if you only really want it the Kai. Most of the firmwares support the extra features the HyperWRT has. If you want fool proof Kai support go to get their custom firmware which is Linksys source with the Kai engine added to the firmware. teamxlink.co.uk Or as posted earlier in this thread, you could use DD-WRT but it won't be supported be Sveasoft and possibly missing the other bug fixes as I posted earlier. Please note to get Kai to run you need an account with teamxlink.co.uk anyway or else the Engine can't run properly which is to be add to the conf file.
  16. bischen

    bischen Network Guru Member

    Disman_ca i´ve allready done alot kai´in but allways directly wired to the Pc without any routers. And I like it very much. The problem allways was, that the PC is in a room in the cellar and I wanted to play in my livingroom.

    I have had it running allready with hyperwrt - but it is very unstable. Thats why I tried the recommended ddwrt. But there was no way to get it to connect wl. I think the kaistation firmware would do a good job maybe but I can´t raise the transmitpower and my livingroom is in the 2nd floor and I have connection-problems. Now I have reinstalled the hyperwrt with my startup-script and everything is OK again. (Besides the unstable Kai).

    But maybe there will be a resolution that works for me in the future. (Hyperwrt with Kai!!!).

    So - many thanks for your help.


    Btw If I loose I can turn of the Xbox and blame it on the bad connection ;)

Share This Page