1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54G rev 1.1 bricked HARD

Discussion in 'Cisco/Linksys Wireless Routers' started by Crashmaxed, May 18, 2005.

  1. Crashmaxed

    Crashmaxed Network Guru Member

    I have a WRT54G rev 1.1 that I bricked by trying out talisman firmware. Previously I had it successfuly running off of Sveasoft Alchemy pre7a. Now I can't do anything to it at all. On startup the power light constantly blinks and the only other light that is on is the lan connection light for the port that my computer is hooked up to. The DMZ and WLAN lights never fire at all. As opposed to most rev 1.1 routers mine doesn't use the intel flash chip. It uses an AMD AM29LV320D chip. Although it comes in the same sized package and the pins are located at the same points, the wiring is totally different. Hence, the pin 15-16 short doesn't work. I have also tried the pin 16 and wireless ground short but that doesn't work as well. Most likely has to due with the fact that this is not an intel flash chip. The specs for the AMD chip are at AMD AM29LV320D Specs. On startup the router does the 4-5 second boot_wait flag. What's funny though is that it constantly repeats. It will reply to the pings at this time and after the 4-5s is up it resets and starts over. I have tried to tftp an image to it but I haven't had any luck with it working. The tftp transfer says succesful but the router has remained bricked. Is there any specific firmware that i should try to tftp? Also, is there a specific name that the .bin file should be named? Any other suggestions that I should try to unbrick it? Any help would be appreciated. Thank you.
     
  2. davidsonf

    davidsonf Network Guru Member

    Apparently the WRT54G can be sensitive to which firmware
    was previously loaded, so not just any known to work bin
    file will be successful for recovery. I don't know if that actually varies, or if it's just that some of the bin files will always load. I've been using a satori binary to recover from various openwrt and ddwrt failures. The file's name is not
    significant. The file size may have something to do with it, as the one I've been successful with is only 2.7Mb in size.
     
  3. Crashmaxed

    Crashmaxed Network Guru Member

    I know the firmware size is a limiting factor. 3.0MB is the bigest firmware you can try to recover with. However, I unfortunately permanently bricked it last night. I guess the flash rom finally decided to eat it and fried itself. Oh well....I'll just get a new 54G sometime soon.
     
  4. davidsonf

    davidsonf Network Guru Member

    Have you tried the business with shorting pins 15 and 16,
    and done it multiple times?

    I've had at least two occassions where it took 2 or 3 attempts before the upload would take. One of them would start, and then tftp would bomb claiming that it didn't have a valid passwork! I tried it a couple times and was convinced I'd really done it this time, and tried it one more time and it worked. (The first time it took more than 1 try I figured I'd just not gotten the right two pins shorted and did it again. But that time I'm sure it wasn't that because the transfer did start.)
     

Share This Page