1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

wrt54G unbrick or RMA ?

Discussion in 'Cisco/Linksys Wireless Routers' started by gibman, May 4, 2005.

  1. gibman

    gibman Network Guru Member

    Hi all!

    I have been running my 2.2 WRT54G on sveasoft 1.0 final firmware ever since it came out (2 weeks).

    Now suddenly internet connection dies on me all of a sudden.
    (I have been cursed by a lot of lockups previously.)
    Fine I power cycle the router, no ping replies.
    Then I reset it for 30s - 60s, still no replies.
    My laptop wont connect to WLAN.

    In other words the router has stopped working :(

    When I power cycle the router I can observe the following things;
    1) Power blinks for approx. 5 secs. Then it becomes steady/constant.
    So when it has booted the power LED is always on, no blinking here.
    2) LAN port flashes according to LAN traffic on my network.
    3) Sometimes the WLAN LED lights up for 2-3 sec. then it will turn off.
    4) Sometimes the WLAN LED doesnt even light up at all.
    5) DMZ LED makes a quick and faint blink (1 blink). You have to observe this to really see it, because it is happening so fast.

    What do I do ?

    RMA the thing and hope that they can't detect foul play (sveasoft firmware)
    Break my warranty seal and try and unbrick the bricked router ?

    I did try that linksys trick with 10 mbit half duplex, this didnt do the trick for me.

    I have searched this forum and the this http://forum.bsr-clan.de forum info about unbricking procedures. I know all about them so far.

    Although, if I were to proceed with the jtag cable method I am in a bit of trouble b/c I don't have linux, so I can't compile that WRT54G.c file.
    Any hope for a windows user like me ?

    Regards Gibman.
  2. Guyfromhe

    Guyfromhe Network Guru Member

    somene posted linksys saying installing 3rd party f/w won't void the warantee you could check with them yourself...
    i'd RMA it if you can...
  3. windsurfer

    windsurfer Network Guru Member

    I would connect to one of the LAN ports rather than the WAN port.

    Make sure your laptop is in the 192.168.1.X sub domain. You can use ipconfig to figure this out.

    Open a DOS box and ping -i Now reset the router with a long reset and see if the pings ever go from bad to good. If so you can still tftp in new software.

    Get a good version of the code and use tftp to put it back in.

    Here is a comment that I found on the net that helped me a lot.

    Matt. Davies
    Thanks to everyone.

    I set my IP address on the hardwired system to

    Pinged using -t and reset the WRT54G which allowed me to
    see that it received pings for a few seconds as it booted up. Due to
    Boot_wait being enabled.

    I then opened a new command window and set up the following
    instruction ready to press :

    tftp -i put c:\code.bin

    Where c:\code.bin was a renamed firmware that i had previously

    I reset the WRT54G and then ran across the room to my system and
    waited for pings to be received....and hit return to send my tftp

    Success! The bin uploaded successfully...hooray!


  4. jagboy

    jagboy Network Guru Member

  5. Guyfromhe

    Guyfromhe Network Guru Member

    Voiding the warentee on a brand new router is pointless...
  6. jagboy

    jagboy Network Guru Member

    or you could just return it or exchange it
  7. Guyfromhe

    Guyfromhe Network Guru Member

    thats what I was saying
  8. jagboy

    jagboy Network Guru Member

    or you could learn how to debrick, and slap the warenty sticker back on if the debrcik guide does not work :D
  9. Guyfromhe

    Guyfromhe Network Guru Member

    then you need to crack out the hairdryer
  10. jagboy

    jagboy Network Guru Member

    i should have thought of that
  11. gibman

    gibman Network Guru Member

    @Windsurfer: I tried the tftp trick to no avail :/
    @Jagboy: I did see that guide, thanks.

    The ping replies are just so damn absent no matter what I come up with.

    It looks difficult to safely remove the warranty sticker and then reapply it afterwards without it looking tampered with.

    Hairdryer ? Is this for real, hehe ?

    I do think I have to pop the lid on this one to fix it myself.

    It troubles me that my power LED isn't blinking like every other bricked router is.
    Also its a bit weird that my router just went dead wihtout me doing anything special to it, like doing a bad flash etc.

    If it is a hardware failure then I can't unbrick the bugger.
    It's hard to tell whatever the case is.

    Now my box is alive again :)
    All I did this time was to let it rest for 2 hours (not that I think this did it)
    The unit was powered off, LAN1 port was connected ot PC. I then pressed and held the reset button for 10 sec or so, while doing this I powered the unit on. After 10 secs more I released the reset button. My router was now pingable, but http was not answering anymore.
    I then used the linksys auto upgr. util and all is good again.

    Hope this can help other in similar situations.

  12. Guyfromhe

    Guyfromhe Network Guru Member

    could be hardware fail thats why i'd RMA rather than pulling it apart...
    the hairdryer trick has been used on warantee stickers on xboxes when modding them it takes alot of time and patience but it can work it's easy to screw up though I wouldn't recomend it
  13. s4czech

    s4czech Network Guru Member

  14. Guyfromhe

    Guyfromhe Network Guru Member

    remove chip? are you talking about the minipci card? theres nothing you can remove from a 2.2 without soldering... are you sure thats not a 1.0?
  15. jagboy

    jagboy Network Guru Member

    you could remove a small metal cover shown below but that is it on the wrt54gv2.2 that you can remove on the board. btw that big green thing is a heatsink and the ruber bands are holding it down. that is my small modd

Share This Page