WRT54G v2.2 + DD-WRT 23SP2 = frequent connection loss (lan) + random resets!?

Discussion in 'DD-WRT Firmware' started by wesmoc, May 7, 2008.

  1. wesmoc

    wesmoc Network Guru Member

    I posted something similar to the DD-WRT forums, but I hadn't heard anything there.. so, I thought I would try here. I searched through the forums and saw some hints, but nothing that made me think "yeah, that's the solution!" I did come across something similar in this posting http://www.linksysinfo.org/forums/showthread.php?t=33758 but I wasn't sure if the problem there was what I was experiencing (although it does sound close).

    This article I found (http://roachfiend.com/archives/2006/01/02/if-you-happen-to-have-a-linksys-wrt54g-wireless-router/ - it seems kind of old, but still) on line might work, too, since I didn't find that until just now.. I was wondering if the advice there might do the trick...

    Also, I tried v23.. I'm wondering if v24R7 would be a better one to try.

    History
    I've had a v2.2 WRT54G for several years now, and it has been running $veasoft Alchemy pretty much since the first month that I got the router (needed more than the stock IP forwarding fields that the linksys firmware supplied). I watched the dd-wrt development, and even tried (nearly bricked the router) installing it very early on.

    Upgrade
    I decided it was time to install newer firmware for the better features and performance. So, last night, I figured I would go about this in baby steps. I downloaded both dd-wrt and the latest $veasoft firmware and a copy of my original Alchemy firmware, and put all of those on a laptop with a current backup copy of the Alchemy settings.

    I then ran the update to $veasoft, and reset the router to the defaults. That's when the problems happened.

    It sorta took the reset, but I had to hard reset the unit. And from there, it wouldn't take any changes. After many attempts to replace the firmware & etc, I thought I was sunk. What finally worked was to upgrade the firmware to dd-wrt *wirelessly* (wired resulted in a page with "the parameters you supplied are invalid. please try again") and I reset the router.

    Problems
    So.. now I have dd-wrt on the router. I configured it all up, and after a few minutes I started seeing notifications that the ip_conntrack was dropping packets (I enabled syslogd to log to my main server) and the router became un-ping-able.

    I reset the router and after a few minutes, the same thing happened. I reset it again and managed to get in to the web interface to see that the default # of IP connections was at 512, and I was already pushing >400. So, I up'ed the number to the max (4096?) and reset the router.

    From there, things seemed a bit more stable, but after 30 minutes, I noticed that I couldn't get to hosts outside of my network. I checked the router (it took a while to get in to the interface) and saw that the # of connections was > 3000.

    Now, I did see that google was crawling a couple of the websites I host, but I couldn't really explain why the IP connection were up so high.

    I had QOS enabled, port forwarding for about 14 services, wireless enabled with simple WEP PSK, SNMP enabled (but I couldn't walk the snmp tree), ssh, ntp, and the dhcp server was disabled (I run the dhcp server on another machine). I've got a static IP address, and all of that was configured.

    I ended up backing down to the firmware I started with and restoring my settings. I'd rather be running dd-wrt, but I don't know why it couldn't handle things nor do I know where to start looking. The load average on the wrt54g w/ dd-wrt was less than 0.8...[/u]
     
  2. alcalina

    alcalina Guest

    * try to change the clock to 216 or underclock
    * put less connections and tcp/udp times look for the tweaks with torrents ( about 1048 connections or less udp 120 and tcp about 300)
    * take off QOS ( a lot of processor usage)
    * take off one antenna
    * put a cooler
    * try the version v24

    and for last ( my problem) check your ISP I dunno but my ISP sometimes stop of work ( too many connections from me) and the router go down too
    I tried with another and worked fine, so I have to stay with this problem
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice