1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54G V2.2 disconnect from internet

Discussion in 'Cisco/Linksys Wireless Routers' started by helios, Apr 23, 2005.

  1. helios

    helios Network Guru Member

    I have nightmare with my Linksys WRT54G V2.2 router. It disconnects from internet hundreds times a day. I have tried different version of firmware (including using HyperWRT). anyone can help me?
    I am losing patient to linksys....
  2. helios

    helios Network Guru Member

    actually I got a firmware ver4.00.5 which the vendor said linksys released it yesterday for solving the disconnect problem.
    and I tried at home, it drops internet connections every 5 mins, even worse then before.... I have to restore back to ver3
    very disappointed!!!
  3. Partizan

    Partizan Network Guru Member

    Having the same problem, look at this thread.

    Regards, Partizan
  4. pharma

    pharma Network Guru Member


    If you are using HyperWRT, try to see if the following helps:

    HillJack states:

    Adding the following line to the router startup script solved my problem:

    echo "600 1800 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts

    The important part of that line is the 1800 - this is the default TCP timeout for the WRT. My understanding is that Linksys, by default, has set the TCP timeout for established connections through the WRT as 5 days - so your WRT is tracking connections (even dead ones) for 5 days, and with P2P running, you'll get ALOT of connections, which slows the WRT to a crawl. Turning that down to 30 minutes has solved all my problems! All hail HyperWRT

    My entire startup script is...

    echo 4096 > /proc/sys/net/ipv4/ip_conntrack_max
    echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts
    echo 1 > /proc/sys/net/ipv4/icmp_ignore_bogus_error_responses
    echo 512 > /proc/sys/net/ipv4/neigh/default/gc_thresh1
    echo 2048 > /proc/sys/net/ipv4/neigh/default/gc_thresh2
    echo 4096 > /proc/sys/net/ipv4/neigh/default/gc_thresh3
    echo "600 1800 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts

    Both my WRT 1.1 (the one P2P runs through) and 2.2 are currently running perfectly...

    7:17am up 17 days, 22:22, load average: 0.10, 0.06, 0.01
    7:17am up 4 days, 1:23, load average: 0.00, 0.00, 0.00

    Entire thread:


    Hope this helps ... seems it has resolved the disconnect issue some other people have had.


Share This Page