1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54G v2.2 frequently disconnects

Discussion in 'Cisco/Linksys Wireless Routers' started by jaykid23, May 27, 2005.

  1. jaykid23

    jaykid23 Guest

    Bare with me people, I don't know much about routers or linksys except that I am starting to hate both... I am having MAJOR problems with losing connectivity when using my router for P2P purposes.

    I have a WRT54G v2.2 w/ the most current firmware version of 3.03.6. Which has been 'reflased' and reset numerous times.

    The problem only comes up when I am needing the router for high throughput tasks. Whenever I use BitTorrent my laptop (WinXP) which is connected wirelessly will show in the system tray that the connection from the router has been lost. At this point 1 of 3 things happen. Either the connection will "reset" and my connection will come back 10-30 seconds later after it has reaquired a network address and stay connected from anywhere of a couple minutes to an hour. More frequently I will lose all connectivity even though my wireless conection icon in the system tray says its connected and the routers' WLAN light will either be solid green or black. Typically if it's not blinking I have lost all internet connectivity.

    Linksys tech support has thus far had me switch my MTU to manual and adjust that ranging from 1500 to 1000. I have also changed channels to 1, 3, 6, and 11 as well as changed my encryption from WEP 128bit to 64 then to no encryption at all, all without any success. Moreover, I have changed the beacon interveral to 50 and had the RTS and Fragmentation thresholds adjusted to what tech support suggested. Unfortunatly I do not have the values I filled into the latter two, I have lost the settings having since reset the router since that didnt help. I should also point out that I know this is not an issue with my ISP because I never have this issue when I am directly connected to the modem and bypass the router. Moreover, there are 3 other wireless networks within range of my laptop one of which is secure the other two and unsecured.

    I had a somewhat similar issue with the last linksys router I had and was told by linksys it was defective. They are now telling me the same thing with this one!! And wanting me to pay S&H for a replacement they are offering. I know its not my wireless card on my laptop since it works fine at a friends house who has a linksys router where I use bittorrent as well as having used it for at least a year while living somewhere else with a wireless router.

    Can anyone help me with this issue? I am at my wits end with linksys tech support and am starting to think that unless I want to use my internet for just casual browsing then I'm SOL. Thanks for any tips/ideas folks!
     
  2. ghlu

    ghlu Network Guru Member

    I had similar problems with p2p software causing frequent disconnects, even with wired connection. After using HyperWRT firmware with the script from the following thread here, my router has been stable since. Linksys also released a new firmware that seems to fix the problem with high-throughput.
     
  3. Partizan

    Partizan Network Guru Member

    You can try the new beta 4.00.7 firmware. Helped me!


    Regards, Partizan
     

Share This Page