1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[WRT54G v2.2] Loose Antenna

Discussion in 'Cisco/Linksys Wireless Routers' started by sartsj, Dec 1, 2006.

  1. sartsj

    sartsj Network Guru Member

    It might seem a weird problem, but an annoying one nonetheless..

    Before I say anything, I included a link to a picture I made of the situation. Which probably explains a lot.


    As you can see, the 'golden' pin is loose, I think it is supposed to be stuck in the 'antenna block' on the pcb which you can see on the right in the picture. I can stick the pin back into the block, and then push in the antenna spacer (the cylinder that is standing on the desk above the pin) or whatever it is called. But when I do this, the wireless signal it sends out decreases with 5dBm according to netstumbler.

    I know it is not critical to have 2 antennas, but since I have 2 antenna connections, I'm wonder if there's some way I can fix it. Maybe there's someone else who has experienced the same problem before?

    I hope someone can help me, if you read everything up to this point, I will already thank you for the patience :)
  2. ifican

    ifican Network Guru Member

    I have never had to disect any of my devices to that point so i dont know. But since its already apart take it one step further and unscrew the MB to look at how the other side is connected. You should then have your answer and if it needs to be soldered you can do so at that time.
  3. sartsj

    sartsj Network Guru Member

    Well, the antenna block is soldered stuck on the back side of the pcb obviously, but I don't really want to start soldering until I'm sure there's no other way. But thanks for your thoughts on the matter.

Share This Page