1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54G V2.2 WIRED Dropped Connections

Discussion in 'Cisco/Linksys Wireless Routers' started by HeadScratch, Aug 1, 2005.

  1. HeadScratch

    HeadScratch Network Guru Member

    Windows XP SP2.
    WRT54G V2.2

    Router working perfectly on WIRED and WIRELES connections for 6 months.

    Yesterday on the WIRED connection (WIRLESS not tested) the connection is dropped every minute or so, just Internet browsing no big file downloads.
    LED’s still indicate traffic. Recovery by power cycle or opening config page and click ‘Save Settings’. Router recovers for another minute or so, and then dropped connection again.

    Direct modem connection, everything works fine.
    Flashed to latest Firmware WRT54GV4[1].0_4.20.6_US_code,3.exe this did not help.

    Any ideas?
  2. HeadScratch

    HeadScratch Network Guru Member

    Found the answer to this: Simply right clicking the network (in XP) and selecting 'Repair' option, fixed this issue immediately. I was skeptical it was going to work, but it did. I was convinced it was a router issue because the wired internet disconnect only occurred when the router was in the network. Indecently I have a Dell and this hint came from the Dell site, not directly addressing router problems, but XP network issues.
  3. will792

    will792 Network Guru Member

    Repair in XP does ipconfig /release | ipconfig /renew .
  4. HeadScratch

    HeadScratch Network Guru Member

    Actually, repair does the following: Q289256

    . Dynamic Host Configuration Protocol (DHCP) lease is renewed (ipconfig /renew)
    . Address Resolution Protocol (ARP) cache is flushed (arp -d *)
    . Reload of the NetBIOS name cache (nbtstat -R)
    . NetBIOS name update is sent (nbtstat -RR)
    . Domain Name System (DNS) cache is flushed (ipconfig /flushdns)
    . DNS name registration (ipconfig /registerdns)
    . IEEE 802.1X Authentication Restart (WinXP SP1 or later)

    Using the modem directly everything worked, using the router, wired internet dicconnects occured. I also tried some of the above myself. But the combination seems to have fixed the issue.

Share This Page