1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54G V2 Bricked?

Discussion in 'Cisco/Linksys Wireless Routers' started by nreiter, Nov 8, 2011.

  1. nreiter

    nreiter Network Guru Member

    My very old WRT54GV2 router had 1.28 Tomato firmware on it, but in anticipation of DSL being installed tomorrow, I wanted to install DD-WRT so I could partition into 2 VLANs. The first step was to flash with the latest Linksys firmware, FW_WRT54G_4.21.4.000_20110712.bin, downloaded from the Linksys web site. The Tomato FAQ said nothing special was required, to just go to
    Administration/Upgrade, select the file and click the Upgrade button. This I did. When the router rebooted, the Power LED flashes rapidly, after a few seconds the WLAN and LAN
    s light, then go out, then the WLAN
    light comes back on. The Power LED continues to flash rapidly. If I connect a computer to a LAN port, the
    for the port lights, but the router does not respond to pings, they time out. I've tried the 30/30/30 hard reset, several time, with no change. Is this box truly bricked or is there some other procedure, other than pin shorting, that might restore it?
  2. Matt Bonner

    Matt Bonner Networkin' Nut Member

    Same thing. I have also tried the pin shorting and I can get the device to ping again but no admin web page comes up and when i upload the new firmware again using tftp, it stops pinging and the update process fails. I think the new firmware is no good. Anyone have an older firmware file for the WRT54G v2?

  3. nreiter

    nreiter Network Guru Member

    I have a WRT54G_v4.21.1_fw.zip file from 11/2006.
  4. Matt Bonner

    Matt Bonner Networkin' Nut Member

    nreiter, i would like to try that if you can upload it somewhere. I tried uploading some third party firmware in the meantime and while those flash successfully, the power light still blinks and i can't get an admin page.
  5. nreiter

    nreiter Network Guru Member

    Get it from here.
  6. nobugme

    nobugme Network Guru Registered

    nreiter, you are a life saver. The new 4.21.4 firmware ruined my Linksys WRT54G. Many people are having this problem.

    I reflashed with the image you've provided (after unzipping it) and now my router works once again. Thank you!

    Linksys does not provide the 4.21.1 firmware from their web site. I contacted support but they told me the firmware is no longer available. I believe your file may be the only file available anywhere on the internet.
  7. nreiter

    nreiter Network Guru Member

    Glad I could help. Hang on to that file!

    Now if I could only unbrick my router :(

Share This Page