1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54G V2 Flashing Power - help with revival

Discussion in 'Cisco/Linksys Wireless Routers' started by tekara, Sep 27, 2011.

  1. tekara

    tekara Networkin' Nut Member

    Hi All

    I’m in need of advice from seasoned veterans on de-bricking a Linksys WRT54G’s. Below is the full story on what I’ve done with my WRT54G V2.0, sadly I’ve probably not done myself any favours as I was a complete newbie to WRT’s prior to this attempt, in hindsight I didn’t perhaps do as much research before beginning as I should have.

    Can anyone offer any help with reviving this?

    Current State
    Router powers up with a quick flash from the LAN lights with the power light continually flashing, oddly it can only be pinged after is been powered down for a period of time. During the stage that is contactable via ping I have attempted on several occasions to upload the DD-WRT Mini firmware and Tomato 1.27 via the TFTP util and command line in Windows XP – sadly as yet nothing has brought it back to life. LAN currently set to 10Mbit Half Duplex while connected to the WRT.

    Background
    The router originally had the V2.0xxxx firmware, I attempted to update it to Tomato/MLPPP. After the update I experienced much the same issue as above with the power light flashing, I tried the 30/30/30 reset which didn’t seem to work, after a few more power cycles it eventually let me in. After having a look around I thought the job was done and relocated the router, after plugging it back in I had the same issue again of the flashing power light, again after another 30/30/30 and numerous power cycles I got back in to the router again. Following instructions I proceed to one of the menus to try clearing the NVRAM. After I did this the router failed to ever go back in to and sat there with the flashing power light, after conducting a couple of 30/30/30 resets and numerous power cycles in ended up with the DMZ light flashing. At this point I tried pinging and proceeded to use TFTP to try uploading the firmware, this time trying to go back to the stock Linksys, it failed due to being over the 3MB limit. After power cycling and giving it another go I went and tried the DD-WRT Mini, this time it seemed to take and after leaving it for a couple of minutes I power cycled this time the DMZ light had gone and I was left with the power flashing.

    Having got this far I thought there was nothing left but to JTAG, so built and interface cable and connected up, first off was to make a backup of the CFE. After doing this I proceeded to erase the NVRAM and started the router up again, now back to DMZ flashing. Again proceeded to flash, wait and reboot, still the same flashing power. Now starting to fear the worst I conducted a wholeflash wipe and re-uploaded the CFE which now more or less takes us up to its current state.
     

Share This Page