1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54G v3.01.3 20/Oct/2004

Discussion in 'Linksys Official Firmware' started by Toxic, Oct 20, 2004.

?

Firmware Functionality

  1. Works very well

    100.0%
  2. Works well but some issues

    0 vote(s)
    0.0%
  3. Works occassionally

    0 vote(s)
    0.0%
  4. Serious problems but some parts work

    0 vote(s)
    0.0%
  5. Firmware crashes device

    0 vote(s)
    0.0%
  1. Toxic

    Toxic Administrator Staff Member

    Last Firmware Version: 3.01.3

    Firmware 3.01.3
    - Updated wireless driver
    - Supports hardware version 2.2 (cannot downgrade to previous versions)
    - Resolves issue with VoIP adapters
    - Resolves issue with long domain names

    Firmware 2.04.4
    - Updated wireless driver
    - Updated certificate generation for https access
     
  2. MacWizard

    MacWizard Network Guru Member

    Uploaded and installed over latest HyperWRT. No problems. Did not reset to default so I imagine it kept my power settings...

    Appears faster...but could be wishful. Cable modem site test shows faster

    Starting download speed test:
    1044480 bytes in 1.535 seconds.
    Throughput was 5.444 Mbps.

    Starting upload speed test:
    1054720 bytes in 5.830 seconds.
    Throughput was 1.447 Mbps.


    Download usually below 5 Mps, upload normal.... (Could be cable variation too not the router....)

    :wink:
     
  3. arson420

    arson420 Network Guru Member

    Ever since upgrading to this firmware I am not able to get into remote administration mode. I did change my password and tried to set it to different ports. I also deleted temp internet files and cleard the SSL Slate. Anybody else with this issue?
     
  4. ChurchEAC

    ChurchEAC Network Guru Member

    After upgrading my WRT54G to the v3.01.3 Firmware I suffered from random connection drops after about 1.5 hours, both with Wireless and Cable clients. I also tried HyperWRT v2.02.b (which is excellent BTW) with the same result.

    Going back to the v2.04.4 Firmware (and also HyperWRT 1.4) fixed the problem, which leads me to believe that this is a bug in the V3 Linksys Firmware having to do with the Client Lease time. The default value for this (on the Setup - Basic Setup Page) is 0 which means one day. It seems this is being passed correctly to the DHCP Clients (check Status of the Network Connection) but is recorded incorrectly on the router itself (check status on the Status - Local Network - DHCP Clients Table Page) resulting in the router dropping the connection after about 1.5 hours.

    Setting the Client Lease Time to 1440 (in Minutes =1 day) didn't help, but changing it to 2880 (in Minutes = 2 days) helped me - no more disconnects after ~1.5 hours.
     
  5. massa

    massa Network Guru Member

    EU or US firmware ?

    Whats the diffence between EU and US firmware for WRT54G

    EU revision 2.02.7_ETSI_code.bin

    US revision 3.01.3_US_code.bin

    And does make a difference what I use ?
     
  6. cbrunnkvist

    cbrunnkvist Network Guru Member

    My newly bought WRT54G with v2.2 hardware (European version) ships with firmware v3.03.1, dated Oct. 18 2004.

    Yes, that's .03.1 and not .01.3. :? This version does not seem to downloadable from anywhere at the moment. What's going on here?!
     
  7. Toxic

    Toxic Administrator Staff Member

    Because your router is newer than the last official release there is "nothing wrong"
     
  8. jdepew

    jdepew Administrator Staff Member Member

    We've also found that quite frequenly EU routers ship with slightly different numbering of the latest firmware. Don't worry about it too much, you've got the latest.... speaking of, when I get home later I'll update the latest firmware threads....
     
  9. Lord_KiRon

    Lord_KiRon Network Guru Member

    1. Firmware constantly "looses" the ADSL modem ( on WRT54G v1.0 US) , after few good hours of work the modem led on router goes down and every attempt to hit "reconnect" button fails , does not even result in network activity led on modem (only "on" and "sync" leds are on) .

    Gets "fixed" by powerswitching the router (powerswitching modem does not help) for long time (shourt disconnection of power does not help) or reflashing SAME firmware again.

    After reverting to prev. version or when instaling HyperWRT (both b3 and b4) - works fine ...

    Modem: Alcatel SpeedTouch Home .
    connection type: PPPoE


    2. Also disabling " Wireless Access Web:" checkbox result in loosing ability to access administration page :( even from local LAN.
     
  10. crawdaddy

    crawdaddy Network Guru Member

    I experience random connection drops of my ppoe ADSL connection. I was chocking it up to my ISP Bellsouth, as I am in a hurricane affected area.
     

Share This Page