1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54G ver8 - trying to revive..

Discussion in 'Cisco/Linksys Wireless Routers' started by cloudsuck, May 6, 2008.

  1. cloudsuck

    cloudsuck Addicted to LI Member

    I somehow made this unit as dumb as me. I was doing the dd-wrt firmware change. The Linksys upgrade firmware browser page seemed to show proper progress, then went weird.

    At this point I can get repeated good ping response on 192.168.1.1, and have tried the TFTP firmware flash with the original Linksys BIN file for the WRT54G ver8. The TFTP thing takes only about 8 seconds to state successful, and I can alway successfully ping it as well, but I cannot successfully connect to it with IE at http://192.168.1.1

    The power LED seems to be off, but if you look very closely it is very dimly and continuously on.

    I also set the LAN speed to 10mb half (from auto)

    I did initiate the TFTP command at power up of the WRT54G.

    Suggestions please....

    Thanks
     
  2. cloudsuck

    cloudsuck Addicted to LI Member

  3. cloudsuck

    cloudsuck Addicted to LI Member

  4. mstombs

    mstombs Network Guru Member

    If you have a Linksys VxWorks Router, and have flashed the CFE to a Linux compatible bootloader then no surprise Linksys firmware will not reload. Have you tried tftp ing the correct dd-wrt micro firmware? Its possible the nvram is now corrupt and the only sure way formward is to use JTAG.
     
  5. cloudsuck

    cloudsuck Addicted to LI Member

    Grrreat sucess!!

    I went round in circles for hours on this.

    My mistake was trying to tftp WRT54G-v8_8.00.5_fw,0.bin. The tftp would report success; I could ping it, but there was never any response to http://192.168.1.1 in a browser after this.

    Read and read some more. Then waited a year, read some more.... I was getting ready to jtag it, but it would ping forever.

    I used tftp to flash dd-wrt.v24_micro_generic.bin (thanks mstombs!!) to it during the reboot phase after doing the hard reset. Waited for the reboot and that sweet dd-wrt web screen came up - WOOHOO!!

    Guess I got busy over the past year and only finally checked back here for a reply to my question.

    Too bad my first took so long to nail...
     

Share This Page