1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54GL and WPA/WPA2?

Discussion in 'Cisco/Linksys Wireless Routers' started by sllink, Jul 13, 2008.

  1. sllink

    sllink Addicted to LI Member

    I just got a WRT54GL with the v4.30.11 firmware. I configured it with WPA2-PSK and I couldn't connect to it. Then I configured it with WPA-PSK and I still couldn't connect to it. Only after I configured it with WEP could I connect to it.

    Is anyone able to use WPA-PSK or WPA2-PSK with the WRT54GL and v4.30.11 firmware? I am trying to figure out if this is a problem with the router or the computer. The computer I am using to connect to it is running 32-bit Vista and has a MSI PC60G wireless adapter.

    Oh, and I have noticed one annoying problem with the router - every time I change the wireless settings, it saves the settings, but then freezes. I can't ping it, and I have to power cycle it. (I am using another computer connected to it via a wired connection to configure it.)
     
  2. HennieM

    HennieM Network Guru Member

    Do 2 things for starters:
    1) Reset your router to defaults, and then reconfigure.
    2) Delete your wireless network on Vista, and reconfigure that.
     
  3. sllink

    sllink Addicted to LI Member

    Thanks for the reply, HennieM.

    I determined that the WRT54GL is not the problem. I was able to get an XP laptop and that was able to connect to the WRT54GL with WPA and also WPA2. So that means the problem is with Vista or the PC60G adapter.
     
  4. HennieM

    HennieM Network Guru Member

    Most likely.
    Have you deleted and re-configured your wireless network definitions on Vista?
     
  5. sllink

    sllink Addicted to LI Member

    Yeah I deleted and re-created it a few times and it just doesn't work.
     
  6. sllink

    sllink Addicted to LI Member

    I just tried it one more time, and it worked! Bizarre. Hmm, yesterday I had been uninstalling and re-installing different versions of the wireless adapter drivers, and something must have gotten corrupted, because after all that, WEP wouldn't work anymore. So I did a System Restore. That must have also fixed WPA2, because it is working now.
     

Share This Page