1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54GL and Xbox Live Connection Troubles (Tomato)

Discussion in 'Networking Issues' started by KingoftheCosmos, Aug 12, 2009.

  1. Hey there everyone. I've been having trouble lately getting my Xbox 360 to connect to Xbox Live through my WRT54GL(v1.1).

    My 360 has connected to Xbox Live in the past through this router. However, even when I get on I am disconnected after a short period of time. Usually this ends up being anywhere from 5-30 minutes. After I am disconnected, I turn the 360 off for a minute or two then turn it back on. When I turn it back on, the 360 will not connect to Xbox Live. The Network Test on the 360 gets all the way to the "Xbox Live" portion, then fails. When I click "More Info" there, it tells me "Your Xbox can connect to the Internet but not Xbox Live". It then instructs me to restart my router and modem, which I have done multiple times. It has worked maybe twice out of ten times. AND if it does work, I am disconnected from Xbox Live within minutes. After that, I checked my port forwarding settings to see if that could help. I checked the Xbox's IP and forwarded the ports to its IP in Tomato. I also tried putting my 360's IP on the DMZ. Even after doing that, I was still getting the same error.

    As for my setup, I am using a wired connection to my WRT54GL. The router is connected to a Scientific Atlanta DPC2100R2 cable modem I have leased from Time Warner Cable.

    I have talked to Time Warner Cable's support and followed their instructions about power cycling all my network hardware. That did not work so they told me to call Xbox's technical support. I then called Xbox Support and went through their connection wizard, power cycling the network equipment again and changing settings on the 360. I tried setting all the 360's connection settings to "Automatic", then I tried copying the settings from my Windows PC. Both times the 360 would connect to the Internet but not to Xbox Live.

    The only other settings I can think of that may be causing this are the DMZ and uPnP. I have both enabled. There had been issues with the WRT54G router and Live using uPnP, but they had been resolved last I checked. Also, I'd like to note that my computer plays just fine with the Internet. In fact, I am posting from the computer that is connected to the same router.

    If anyone would be able to help me with my problem, I'd really appreciate it. I'm willing to do just about anything to get on Xbox Live and download a whole backlog of things I'm missing. I recently bought a new hard drive and need to re-download all the content I had on the old one. With an intermittent connection, it's just not going to happen. Again, any help is much appreciated.
     

Share This Page