1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54GL - Bandwith problems

Discussion in 'Tomato Firmware' started by PhilE, Jun 30, 2012.

  1. PhilE

    PhilE Serious Server Member

    Hi,
    I recently setup my WRT54GL with the latest Tomato firmware. When I download a file it gives me the regular 20Mbit my Internet is capable of. As soon as the file is downloaded and it switches to the next one it gives me 1 Mbit like there was some sort of restriction on bandwith. Now: As soon as i disconnect and reconnect to the router it goes back up to 20 Mbit. So there has to be something fishy going on. What could the reconnect-fix be indicative of?

    Thanks, Philipp
     
  2. Toxic

    Toxic Administrator Staff Member

    What type of connection is this over ADSL/Cable/Fibre and what way are you connected to the router? Wired/Wifi. sorry but without some more infomation we would only be guessing.
     
  3. PhilE

    PhilE Serious Server Member

    Thanks for the reply. It's cable with Wifi. The router is only one wall away and the connection is great. It runs fine for a time and then, like someone flipped a switch, its slow. Right after the reconnect (just via windows right click disconnect - connect) it's back to normal. So I'd like to know what a reconnect does exactly, because therein seems to lie the problem.
     
  4. Porter

    Porter LI Guru Member

    What was your setup before you changed something?

    There are some providers who will give a download a boost for the fist 10MB or so before going back to regular speed. You don't happen to have such a contract?

    Do you get 20MBit consistently throughout a large file of say 700MB?

    Did you play around with the QoS-system?
     
  5. PhilE

    PhilE Serious Server Member

    It was happening before with the old setup as well, I installed tomato to try and fix it. The problem randomly appeared, the router was working well for 3 years before that. I havent enabled QoS. I should clarify that i'm not a novice but im no computer scientist either. I have tried many things to permanently fix this but it looks like only reconnecting does the trick for a short time which is really weird.
     
  6. BikeHelmet

    BikeHelmet Networkin' Nut Member

    Where are you located at?

    When your download comes in slow, could you try cancelling it and starting it again? In Canada I heard that some ISPs were having route issues to certain backbones. About every 4th connection would take a sub-optimal route and be limited to maybe 100-200KB/sec rather than 2.x MB/sec. Perhaps that's your issue?

    You're connected over Wireless G? It's unlikely Wireless G would deliver the full 20mbit. Wireless usually delivers about 1/3rd - 1/5th its theoretical bandwidth depending on signal strength. (54/3 = 18mbit, 54/5 = 10.8mbit)

    Have you timed the downloads to verify they're downloading at the speeds they claim to be? Many web browsers are not at all accurate with their download speeds.

    Have you tried running a Wireless Survey from Tomato to see if any other networks are nearby (causing interference), and then played with the wireless channel? Have you tried messing with the settings under Advanced / Wireless, such as Interference Mitigation?

    That's all I can think of. If none of those proves to be the issue... hmm... good luck! ;)
     
  7. Engineer

    Engineer Network Guru Member

    Do speed tests such as www.speedtest.net give you a full 20Mbps over the entire test?
     
  8. PhilE

    PhilE Serious Server Member

    Thanks for the replies guys. You are of course right, it doesnt give me 20 mbit but it comes close (1200 kb/s - 1500 kb/s). I have tested this with several websites and programs. Looks like my Tomato 1.28 doesnt have an option for interference mitigation? Is this only TomatoUSB that has it? Do you think this could fix it? I have a cordless phone near the router since this is where the phone station has to be.
     
  9. BikeHelmet

    BikeHelmet Networkin' Nut Member

    I have no idea if it'll fix it, but yes, it's in newer Tomato versions. It's definitely in Toastman's, and is probably also in TomatoUSB.

    [​IMG]
     
  10. PhilE

    PhilE Serious Server Member

    I should get a more advanced version my tomato doesnt have half the options you have there

    [​IMG]
     
  11. PhilE

    PhilE Serious Server Member

    Hm maybe the WRT54GL doesnt support this? Any other ideas?
     

Share This Page