1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54GL stock to Thibor 14

Discussion in 'HyperWRT Firmware' started by eq2675, Mar 8, 2006.

  1. eq2675

    eq2675 Network Guru Member

  2. NateHoy

    NateHoy Network Guru Member

    No. The "GL" is a re-branded "G", and the Linksys firmware loader does not allow firmware for the "GS" series to be loaded directly. Linksys doesn't want you to load the "wrong" firmware.

    Load Tofu 13c ( http://www.polarcloud.com/tofu/ ). This will give you a firmware loader that does not prevent "GS" codepatterns.

    Then you can load Thibor 14 (latest, **NOT** GSV4) build from there.

    The GSv4 build is **only** from stock firmware on the WRT54GS, because the GS v4 expects a different codepattern from the older GS models.

    Thibor may eventually get around to building a firmware that "fakes" the codepattern so it can be loaded from stock "G"/"GL" firmware. In the meantime: Stock -> Tofu -> Thibor is your best and easiest way.
     
  3. eq2675

    eq2675 Network Guru Member

    Thanks.

    I've got 2 GL's comming in this evening for resale. Just looking for a shorter path, but I'll go Stock -> Tofu -> Thibor
     
  4. opie100

    opie100 Network Guru Member

    Sorry, I figured out the question I raised.
     
  5. NateHoy

    NateHoy Network Guru Member

    Well, as long as it loaded, it really doesn't matter.

    The GSv4 has a different STOCK firmware loader that prevents Thibor from being loaded directly, so Thibor wrote a second version with a different codepattern so you could upgrade a GS v4 directly to Thibor.

    The ACTUAL FIRMWARE between "14 (latest)" and "14 for the GSV4" is absolutely, 100% identical. A bit or two has been changed in the HEADER to fool the WRT54GS V4 into allowing Thibor to be loaded, nothing more. The regular firmware version "(latest)" should work on WRT54GS V1-V3, and all WRT54G routers already running aftermarket firmware.

    So, technically, you would not need the GSV4 edition to upgrade from a previous Thibor (or Tofu) build. The firmware loader does not need to be "tricked" into loading the firmware, since the HyperWRT firmware loader simply does not care about the header.

    However, if you did in fact load it from the GSV4 build, and it loaded successfully, there is absolutely NO need to "reload the right version". Thibor 14 is Thibor 14. Only the header has been altered to allow the various STOCK firmware loaders to allow the firmware upgrade.
     
  6. Thibor

    Thibor Super Moderator Staff Member Member

    well said...finally someone get's it. i thought it was so simple. i don't understand the confusion it has created.
     
  7. MenaceInc

    MenaceInc Network Guru Member

    How about in the future version of Thibor? Is it going be a special version for GS V.4 ONLY?

    Thanks
     
  8. Thibor

    Thibor Super Moderator Staff Member Member

    huh???
    why would i do that? what about the other v1-v3 users?
     
  9. MenaceInc

    MenaceInc Network Guru Member

    Once I did Step 2), I can do step 1) from now on? I was confused with "upgrades from stock firmware.


    1) Thibor 14 (latest) or Thibor 15,16.......etc
    2) Thibor14 for the GSv4, Upgrades from stock firmware
     
  10. Thibor

    Thibor Super Moderator Staff Member Member

    this is the very very last time i am going to explain this as i am sick and bloody tired of repeating the same thing over and over again:

    THE GSV4 VERSION IS FOR UPDATING TO THIBOR FIRMWARE FROM THE STOCK LINKSYS FIRMWARE ONLY. IF YOU HAVE PREVIOUSLY UPGRADED YOU DON'T NEED THE V4 VERSION. THE V4 VERSION IS FOR FLASHING FROM STOCK FIRMWARE ONLY. THE V4 VERSION IS FOR UPGRADING WRT54GS-V4 ROUTERS USING ORIGINAL LINKSYS FIRMWARE. IF YOU HAVE UPGRADED TO DD-WRT, ALCHEMY, HYPERWRT OR ANY OTHER 3RD PARTY FW YOU USE THE NORMAL ONE. ONCE AGAIN FOR THOSE THAT DIDN'T GET IT THE FIRST 20 TIMES...THE V4 VERSION IS FOR STOCK UPGRADE ONLY
     
  11. bb3456

    bb3456 Network Guru Member

    Thibor, I just bought a WRT54GL online and have tried three different firmwares to upgrade it. Everytime I get "Upgrade are Failed" on the screen. I, for one, fully understand your confusion on this thread, and am understanding it completely. I have tried your GSV4 file and even it will not work. Tofu 13 will not. DD will not. I did get the unit to go back to 4.20, then to 4.30 again, but that is it.

    Has anybody experienced this, or have a solution. I am positive I am not selecting the wrong file or anything. I run IT and understand the procedures.

    TIA bb
     
  12. MenaceInc

    MenaceInc Network Guru Member

    To add to the confusion and frustration, I read about Linksys cut down the size of RAM/ROM (whatever) on GS V.4. GS V.4 sounds like a different beast. If I bought a V.3, I probably wouldn't ask this "dumb" question.

    Cheers
     
  13. Thibor

    Thibor Super Moderator Staff Member Member

    bb: if a firmware upgrade fails; you HAVE to reboot before trying again. for the record though, GL routers are to use tofu's firmware before moving over to mine. many people have experienced the same sort of symptoms you are describing, have a quick look using the search function. the main thing to remember is to reboot before trying again, and load the correct firmware(tofu)
    Menace: as has been said many times before; there is NO difference between my versions. Normal and v4 are completely identical in appearance and functionality. the only difference is the codepattern that the firmware looks for when upgrading or using tftp. this subject really has been beaten to death now, please let it rest. i think for the future though, my next versions and so on will not have a GSv4 version, i don't want the grief that trying to help has caused
     
  14. bb3456

    bb3456 Network Guru Member

    Thibor. It's too bad you have taken heat on this issue. We appreciate all you've done for us, or at least I do.

    BTW - You are the man.... I had to power down the unit before it would take an upgrade. I also held the reset button for 30 seconds, so that may have helped too. I battled that prob for way too long. I now have Tofu!!.

    BB
     
  15. galileo2000

    galileo2000 Network Guru Member

    OK, as I posted in another thread, original -> tofu 13c ->Thibor14 did not work for me.

    I had to do original->dd-wrt mini->Thibor 13c->Thibor14.

    I got "Timeout Error - upgrade failed" when trying to go from "legit" tofu 13c to Thibor14 on my brand new WRT54GL.

    All is well now. Huge 802.11g out there ( WDS) :D.
     

Share This Page