1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54GL v1.1 (Tomato 1.27) - Can't get outbound connections?

Discussion in 'Tomato Firmware' started by ransagy, May 17, 2010.

  1. ransagy

    ransagy Networkin' Nut Member

    Hi there,

    I've an odd quirk with my new setup and need some help.
    The setup is now as follows: A Linksys WRT54GL v1.1 router, flashed to Tomato 1.27 and ISP-supplied router-modem, ASUS AM604g, which is set to bridge mode, DHCP and NAT disabled.

    The Linksys is set up to dial my ISP's ADSL PPPoE connection and all DHCP, Static IPs and Port forwarding is also done on the linksys.

    This, however, has one odd issue that ive encountered - Port forwards don't seem to work reliably, and pretty much any application that check for an internet connection (assuming sends an outbound packet) fails to find one - For example, Pro Evo Soccer's Online mode, or Dragon Age: Origin's EA Account login.

    Another example would be IRC IDENT service (UDP/TCP port 113) that fails to get through even though its forwarded.

    I'd appreciate any help regarding this matter, just let me know which info you need more to help further. There are 2 PCs connected to the linksys, both by ethernet cable, both running Windows 7 Pro.
     
  2. rhester72

    rhester72 Network Guru Member

    A tcpdump capture of a failed forward (done on the router itself) would help quite a bit, as would a copy of your forwarding tables.

    Rodney
     
  3. ransagy

    ransagy Networkin' Nut Member

    [​IMG]

    Here are the tables, If i understood your request correctly.
    How do i go about getting the tcpdump capture? I tried searching around for info about it, But i can only find one old article that talks about uploading tcpdump to the router manually.

    EDIT: here's the iptables listing - http://pastebin.com/PatAAbSM
     
  4. ransagy

    ransagy Networkin' Nut Member

    Can anyone provide follow-up to this?

    Forgot to mention:

    1. Put a compatible tcpdump binary on a CIFS share on my machine.
    2. Configured the CIFS share on the router and ran tcpdump from there to monitor port 113.
    3. ran mIRC in its IDENT-ALWAYS-ON mode (which should always listen for IDENT/113 requests/responses)
    4. tried connecting to an IRC network in mIRC, no IDENT request got to the router - the dump was empty.
     

Share This Page