1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54GL v23 SP2 - Can't connect to Xbox 360

Discussion in 'DD-WRT Firmware' started by dzjepp, Mar 11, 2007.

  1. dzjepp

    dzjepp Guest

    I have the Xbox connected via wired. The router just doesn't seem to want to give out an IP. DSL /w router PPPoE. I have DHCP enabled, it works fine for my desktop computer and for my laptop via wireless. UPnP is also enabled and works fine on the computers. Nowhere in the DD-WRT control panel can I see any status signal of the Xbox connection, so it's not giving out the IP (right?) Well I'm not sure, and I don't know what other settings to check. I did try with the router firewall disabled, still the same thing.

    I have also tried manual settings on the Xbox like these:


    (These are the settings according to the Status -> Router tab in DD-WRT for WAN)

    IP 192.168.1.102 (100-101 is desktop and laptop)
    Subnet Mask 255.255.255.255
    Gateway 68.74.72.254
    DNS 168.94.156.1
    DNS2 2151.164.8.201

    Tried "Automatic" settings on Xbox as well.

    Would not work.

    I have also tried switching the Xbox to LAN settings:

    Subnet Mask 255.255.255.255/255.255.255.0
    Gateway 192.168.1.1
    DNS 192.168.1.1
    DNS2 192.168.1.1/0.0.0.0

    Same results, no go.

    I have tried plugging wire directly to DSL modem and it works fine, so I don't think the wire is the problem.

    It never gives out the IP. NAT is "open", UPnP enabled, DMZ enabled for the Xbox IP, router firewall on/off, etc. It's baffling me why it won't work and I'm beginning to think there might be some sort of bugs in DD-WRT v23 SP2 that is preventing me from getting this to work. :(
     
  2. cooljo555

    cooljo555 Guest

    I had the same problem with my router not assigning an ip using the Freeman 1.04 firmware on a WRT54G, to start i was using a hyper-wrt firmware 1.0.3 i think it was for years now and i decided to upgrade to maybe see better functionality, i tried the freeman 1.04 and i found that when i set it to Automatic Configuration i would get an ip no problem but under PPoE i would not, after this i just went with the newest stable release of Hyper-wrt 2.0 and it solved all my problems, hope this helps
     

Share This Page