1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54GS Drops the connection randomly

Discussion in 'Cisco/Linksys Wireless Routers' started by turbonow, Nov 14, 2006.

  1. turbonow

    turbonow Network Guru Member

    The deal: The router WRT54GS v2 suddenly began to drop my connection randomly. This was particulary annoying when i downloaded things and they stopped downloading in the middle. Nearly untolerable

    What i did: Hard reset, hard reset again, changed firmware, changed again to a beta of dd wrt v24. Changed again to v23. Still no luck
    Messed with settings, i even changed my ADSL modem twice to make SURE it wasn't it, ran without the router a week and it worked perfectly.

    What's left to do?:

    Ask you guy's, please.. Help me with this problem

    /turbonow
     
  2. HiBob

    HiBob Network Guru Member

    try a different firmware...I know it sounds stupid but I have heard these types of posts about ddwrt2* and for thibor15c.
    The only thing I can think of is trying tomato (from which I have *as of yet* not heard of this problem). you can also try thibor 14 if you wish I ran that for the longest time earlier this year. On the ddwrt side there is some posts in their forum saying that earlier versions from 2006 work without the wireless cutting out.

    btw. I assume you are not talking about wired cutting out (rather the wireless), are you? If so, I don't know since when your plugged into the modem it works fine.... :-|
     
  3. turbonow

    turbonow Network Guru Member

    It's both the wireless And the wired which is cutting out.
    The wireless totally dies in like 5 sec. So the Wireless drops connection, the wired one, you dont notice it dies, every service just stop working, MSN dies, Irc dies, Downoads stops...

    Hey, i tried HyperWRT i think.. Have to try i new firmware in that case.
     
  4. Toxic

    Toxic Administrator Staff Member

    So all connections, wireless and wired are dropped? you mention "downloads" what downloads are these? bittorrents? it sounds like your saturating the bandwidth to the extent the router cannot handle the amount of connections to the router (incomming connections)
     
  5. HiBob

    HiBob Network Guru Member

    ya

    exactly what toxic said, or the following: you are not setting your MTU value correctly in the router.....sometimes you have weird stuff happen if that isn't the correct value with DSL, because of how the packets are broken up or something along those lines...not exactly sure but you should phone your ISP and make sure you have the correct MTU setting, for instance with my DSL in Canada (teksavvy) it's 1452....I know some people sometimes get rejected from https sites and such if it isn't set correctly.

    hope this helps...
     
  6. turbonow

    turbonow Network Guru Member

    It doesn't matter What i do, if i only surf, only being on irc... No matter, it dies anyway.. And downloading i talk by FTP, i aint a poweruser of Bittorrent.

    It just completly drops the internet connection.
    Hibob: I runned on the same MTU settings since i got this router (1,5 years ago) and it has worked just... fine.

    I will try to exchange for the orginal firmware soon, see if that works.
     
  7. crawdaddy

    crawdaddy Network Guru Member

    I have had a similar problem with my DSL. first I was running the stock firmware and had this problem, and now dd-wrt v23sp2. The only solution I have found that seems to wkr for me it to limit the max speed of my downloads to something slightly less than the full capability of my download pipe. I have monitored my processor usage on the router while downloading, connections open, etc, and nothing points conclusivley as to why I keep losing the connection during intense FTP downloading sessions. Tody I just did the whole "finding the max MTU" using a similar thread I just found on the board today. Turns out for some reason the router was set to a manual MTU that was higher than what was possible according to those tests. I have since fixed the MTU, so I guess I should try another long downlod session again to see if it is fixed...
     
  8. Toxic

    Toxic Administrator Staff Member

    what mtu are you using at present. you should be using maximum of 1492 for ADSL.
     
  9. crawdaddy

    crawdaddy Network Guru Member

    I'm using the MTU of 1464. I followed the ping google.com -f -l 1464 method to find it.
     
  10. crawdaddy

    crawdaddy Network Guru Member

    as an update, I don't know if it's the MTU that did it, but my DSL connection hasn't dropped on me once and I've downloaded something like 8-12 gigs maxing out my download pipe. I'm thinking this may have fixed it....
     

Share This Page