WRT54GS Ethernet switch down to 10Mb/s with DD-wrt v23SP2

Discussion in 'DD-WRT Firmware' started by stefor, Feb 4, 2008.

  1. stefor

    stefor Network Guru Member

    Hi folks.
    I am using DD-wrt on my WRT54GS v1 for couple of years without any trouble.
    Last week I did upgrade it to DD-WRT V23 SP2 standard (stable release) and then I have just discovered by plugging a gigabit switch on the ethernet LAN connection of the router that it detects a 10Mb/s connection (instead of 100Mb/s). Then I have tried to connect a laptop which has an integrated gigabit network card and it detects also a 10Mb/s connection. I have tried all of the 4 ethernet ports of my router and all are in 10Mb/s even if if try to force speed to 100Mb/s on my laptop.

    I have tried also to find an option in DD-WRt interface but no way to find something that would fix my issue.

    I have upgraded then DD-WRT to V24 RC6.2 standard version and it is still the same problem.

    Is there somebody who has an idea about my issue ?

    That is amazing, my internet connection is faster than my LAN speed ! I would never thing that I could say that one day !
     
  2. stefor

    stefor Network Guru Member

    I have forgotten to say that I have tried with different type of cables : cat. 5e and cat. 6.
     
  3. HennieM

    HennieM Network Guru Member

    No guarantee that it would work, but I would do a hardware reset (the 30 second reset thing), followed by a software reset to defaults, and re-configuring.

    I have experienced wireless problems with RC6.2, so went back to RC5.
     
  4. stefor

    stefor Network Guru Member

    Ok I'll try this tonight.
    Thx for your answer
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice