1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54GS firmware failed update

Discussion in 'Cisco/Linksys Wireless Routers' started by DaSingh, Jul 24, 2006.

  1. DaSingh

    DaSingh Network Guru Member

    Tried updating my firmware using the .exe from http://www.linksys.com/servlet/Sate...315453&pagename=Linksys/Common/VisitorWrapper

    but it didnt complete and said to retry but no I get the following message
    "Cant find the Router.
    Please check the IP Address, and connection type (http) on router side are correct. Click ok and verify the information and try again."

    I tried to manually update the firmware but all I get is this:
    ž~+b£&í+Å’›`!"Bn¸¾QùSŒ—+…ÃDµ}Z·P5C•c‘™j¥ø©ÌÃýÃôñi™ø‘ÊgnN&ȦRŠÓ]rÃÊH3uk2eÓ'Ç„ŒÂV ãyðq¯X.¾)ŽÉÂI~ì⾨f!›T»(OM:*Æ2)šáù©Ãlü…N±È4 RW0Âf&`h·ý«Î»^ºcì Å“òΡÂËœt×ÃQã°àâ£#\~44N±L±ÑÃ{„…RíÀÜß—ŒT:â•g.ˆ ó1¯ Å¡Ãã[`B~Âá2i´uf´cî8>ºŸ˜>[ˆOL…ŒðE2-rv5E<Sø39^ËœXÀ*²8

    Can anyone help?
     
  2. Toxic

    Toxic Administrator Staff Member

    And you have the correct version of firmware? your WRT54GS is a v5 or v6 yes?
     
  3. DaSingh

    DaSingh Network Guru Member

    Yes its a v5.1
    SN: CGN8
     
  4. jgutz20

    jgutz20 Network Guru Member

    did you try the web interface as well as tftp?
     
  5. Toxic

    Toxic Administrator Staff Member

    what are you using, the autoupdater (exe) or the binary file?
     
  6. DaSingh

    DaSingh Network Guru Member

    First I used WRT54GSV5_V6_v1_50_8_US_code.exe to update but that failed... then I tried to use the web interface but I just getž~+b£&í+Œ›`!"Bn¸¾QùSŒÂ—+…ÝDµ}Z·P5C¬ïc‘™j¥ ø©ÌÍýÁôͱi™ø‘ÊgnN&ȦRŠÓ]rÏÊH3uk2eÓ'Ç„ŒÂV ãyðq¯X.¾)ŽÉÂI~ì⾨f!›T»(OM:*Æ2)šáù©Ðlü…N±È4 RW0Âf&`h·ý«Î»^ºcì œòјt×ÁQã°àТ£#\~4?Ÿ4N±L±ÑÁ{„…RíÀÜß—ŒT:â•g.ˆ ó1¯ šÁã[`B~Âá2i´uf´cî8>ºŸ˜>[ˆOL…ŒðE2-rv5E<Sø39^˜XÀ*²

    I can still login to the web interface and according to that the router is now running Firmware Version: v1.50.8 but its incomplete as the update stopped at about 40ish %
     
  7. Toxic

    Toxic Administrator Staff Member

    when you login to the routers setup pages, if it says firmware is 1.50.8 then i would not worry about it.
     
  8. DaSingh

    DaSingh Network Guru Member

    but its not complete, loads of the pages dont work logo etc is missing, text is bigger than normal etc...
     
  9. Toxic

    Toxic Administrator Staff Member

    Either try a reboot or power off, reset the router, or try to put the router into recovery flash mode (reset button for 10 seconds (I think)
     
  10. DaSingh

    DaSingh Network Guru Member

    Here is a screenshot:
    [​IMG]

    Already done a reboot on the router, I will try to do the recovery flash mode 2mw going to get some sleep.

    Thanks for the help
     
  11. Toxic

    Toxic Administrator Staff Member

    Clear the Web browser cache as well. delete all temporary internet files.
     
  12. DaSingh

    DaSingh Network Guru Member

    Just tried this everything has resetted to factory defaults but still the same but now I cant setup my wireless etc.
     
  13. jgutz20

    jgutz20 Network Guru Member

    when i get the missing text, i use firefox or ie.. restarting should also help like toxic said. also if u have another computer to connect to
     
  14. DaSingh

    DaSingh Network Guru Member

    Talking to linksys live support, apprantly the firmware I tried to upgrade with is for v5.0 not 5.1 and there isnt no firmware available for this as of yet.
     
  15. grumpylar

    grumpylar LI Guru Member

    DaSingh - I also had aborted flash problems while upgrading my Linksys WRT54GS V5 from firmware 1.50.5 to 1.50.8 earlier today. The exact same problems you described in this thread occured. I was part of the problem/fault because, like a bonehead, I was applying the upgrade from a wireless rather than wired connection. But even still, the procedure gave me no warning that it would interrupt the wireless connection before it was complete.

    First recovery that I tried was to perform multiple resets and reloads unsuccessfully. Then called Linksys support and after doing many diagnostic steps was told "sorry, but your only option is to return the router to your store of purchase". Then checked the Linksys and third-party forums and tried all that I could find - still no success. It responds and opens the basic configuration window but most of the othe window pages are garbled characters - including the wireless setup window and firmware upgrade window.

    Unless someone has another idea for reapplying firemware 1.50.8, it looks like I now own an expensive Linksys WRT54GS "brick".
     
  16. grumpylar

    grumpylar LI Guru Member

    DaSingh - I made one last ditch attempt and got firmware 1.50.8 to reload. Now all of the corrupted pages are okay again. You need to get the .bin file of the 1.50.8 upgrade that is inside of the .zip version of the file at Linksys. Place that file on a pc that is attached via a wired connection to port 1 of the WRT54GS V5 router. Turn on the router, then while pressing the reset button (and keep holding it in) remove the power cord from the router. Then in 10-15 seconds replace the power cord (still holding in on the reset button). Then release the reset button. Now when you access the router via your Web browser at 192.168.1.1 you get an emergency management screen. Us the browse button to locate the 1.50.8 .bin file and allow it to re-apply the firmware update. When it is done it will say update successfull. One last time press the reset button on the router (don't keep holding it this time) and remove and replace the power to the router.

    If your luck is the same as mine, you will now be able to access the regular management console at 192.168.1.1 in all of its complete glory!

    Good luck! I hope it works for you like it did for me!
     
  17. DaSingh

    DaSingh Network Guru Member

    Hi, I manage to fix it lastnight after doing the same thing... bit of a pain but got it working at the end. But apprantly there isnt a firmware update available for the v5.1 that is why it didnt work but I manage to use that same update again 100% fine after which is strange.

    Anyway its working fine now, glad your is too.
     
  18. TextEx2

    TextEx2 LI Guru Member

    the v5 and v5.1 use the same firmware tbh, as the v6 model also uses the same firmware.
     
  19. DaSingh

    DaSingh Network Guru Member

    Not accoriding to Linksys live support.
     
  20. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    AFAIK, the v5 and up all use vxworks for the OS. Its a matter of using the correct firmware corresponding to the hardware revision. It comes down to the code pattern in the firmware, which intent ally fails if it doesn't match. They usually do this because they have changed the hardware (chipsets) enough that it will not work on other versions anyway.
     
  21. TextEx2

    TextEx2 LI Guru Member

    Not too sure what the V7 uses at present, I know it has a different Hardware Chipset. Atheros and not Broadcom based.
     

Share This Page