1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

wrt54gs firmware help

Discussion in 'HyperWRT Firmware' started by shames, Dec 23, 2005.

  1. shames

    shames Network Guru Member

    Hi i'm pretty new to the whole firmware thing but was reading through the forums with great interest.
    i have a wrtg54gs v4 with the base firmware that came with it and was wondering what the best option available is to me if i wanted to upgrade firmware?
    i've seen some different answers such as ddr-wrt
    or hyperwrt thibor's latest release
    i've also seen it said that i have to flash it first iwth ddr-wrt mini and then use hyperwrt after?
    like i sai di'm fairly new and am pretty confused.
    if anyone can help with what is best firmware to use and how to properly do this i'd be greatly appreciative
    thanks for all the help!
  2. Thibor

    Thibor Super Moderator Staff Member Member

    having a GSv4 you have a bit to do. firstly download dd-wrt and flash the mini version onto your router, then put on Hyperwrt(my version). after that, factory reset it and you'll be good to go. you can do all this in the web interface and you'll be on hyperwrt within 10 minutes. there are guides to be found on www.Hyperwrt.org
  3. shames

    shames Network Guru Member

    wow thanks for the speedy reply
    just a few questions first
    so i have to flash it first using the dd-wrt latest beta mini generic(from what i've read??) also how to install ddr-wrt? what is tftp or is there an easier way?
    and hten the hyperwrt latest thibor version
    and only at this point do i factory resset? (does this mean in the web config utility or by holding restart button down?)
    is that all i ahve to do or are there more settings i have to change after?
  4. Thibor

    Thibor Super Moderator Staff Member Member

    do the upgrades via the web interface, use tftp only if you need to. you can reset to defaults in the web interface in Hyperwrt when you are done
  5. shames

    shames Network Guru Member

    Thibor i need HELP!
    i did what u said and upgraded to the ddrwrt 23 mini generic first
    and it went fine
    i then upgraded to ur thibor 11 firmware and it upgraded ok but after it finished the oruter went nuts
    all the lights are on and the power light is flashing and it doesn't seem to connect at all through the router even wired connection
    i tried long reset and it did nothing
    any help please???
    i'm dying here
  6. Thibor

    Thibor Super Moderator Staff Member Member

    now is the time for you to use tftp,
    1. assign yourself a static ip, ie
    2. copy the firmware to c: and rename it code.bin
    3. open a command box(cmd) and type this:
    cd c:\<enter>
    c: <enter> (this changes you to c drive)
    tftp -i put code.bin
    note the lack of enter on the last command,
    4. plug the router into the mains and then hit enter in the command box when the lights(lan led's) flash
    it may take lots of repeats before you get the timing just right, but it will eventually work, when it says upload completed in blah blah seconds just leave it for a minute or two and it will reboot on it's own.

    the above is assuming you can ping your router, if you can't, read the de-bricking guides that are all over these forums. i have bricked and de-bricked many many times and it's not a serious thing although it can seem it the first time it happens, try not to worry...it's quite straightforward for you to sort this out
  7. shames

    shames Network Guru Member

    i can't ping the router
    even with a wired ethernet connection in i can't seem to get any kind of connectivity to the router
    is there any way i can talk to u besides these forums to get a lil mor ehelp?
    maybe msn or e-mail?
  8. Thibor

    Thibor Super Moderator Staff Member Member

    shames: you have pm
  9. DallasFlier

    DallasFlier Network Guru Member

  10. shames

    shames Network Guru Member


    still can't debrick the router
    have tried everything
    her'es the full story:
    I have a wrt54gs v4 and tried to upgrade firmware as per instructions on the forums
    i long reset the route rwith the button onthe back.. success
    i got the ddr-wrt v23b1 mini generic and flashed it from web config ... success
    i loaded the hyper-wrt thibor11 firmware.. success
    i did another long reset from back button on the router.. success??
    after i plugged it back in all the lights flashed
    the power led wont' stop blinking and it couldn't connect at all to any wireless or wired connections
    i was able to make some progress using the 16 pin > earth trick and was finally able to ping the machine
    i set the settings to static ip in windows and tried tftping the firmware on to the route ragain and no luck
    i try the web config utility, no luck
    all i can do is ping the router through dos
    i tried the linksys tftp client and set it to 900 tries in hopes that it would fix the timing issue
    still does nothing
    the power led still blinks but only the wired lan led shows up now
    i am really stuck and would really appreciated some help
    thanks in advance
  11. pharma

    pharma Network Guru Member

    Not sure you are doing this, but when you tftp the firmware on the router, sometimes you have to wait a couple minutes until you see a response in the 'DOS' window. You need to be patient and not interupt the flash even though it seems to be done.

    Also, instead of flashing HyperWRT software try flashing the version that came with the router. It should be listed on the "flash chip" in the router.

  12. shames

    shames Network Guru Member


    hi thanks for the response
    i've tried the default stock firmware as well to tftp to
    and i always get a time out or a server code incorect when i try tftping thru dos
    can't seem to get timing right
    but i've tried every combination o fwhen to push enter
  13. shames

    shames Network Guru Member


    Ok all got it working, thanks
    finally was able to flash it back to linksys default fw

Share This Page