1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54GS -> High Throughput causes disconnect

Discussion in 'Cisco/Linksys Wireless Routers' started by zephyr325, Feb 7, 2005.

  1. jienn

    jienn Network Guru Member

    I might have a fix for some of you, it solved my problem at least.

    After a few days of email-talk with linksys i got a solution and tried it:

    First i downloaded this firmware:

    Then after install, i did a 30 sec hard reset.

    Then i setup all my IP info.

    Linksys support told me also to change 2 fields in wireless / advanced wireless settings:

    Fragmentation Threshold: 2304
    RTS Threshold: 2304

    Save settings. And try if you get the same problems. I didn't. I can download big files, and use torrents with many connections without router reboot.

    I haven't tried wireless yet, but i suspect this firmware/settings combination could fix some problems you are having. Good luck!
  2. NtegrA

    NtegrA Network Guru Member

    Just nitpicking but....

    it sounds like you did not have the same problem (although similar) as others in this thread. While you may have had a problem with large files and bittorrents, our problem is wireless specific at 54g (or slower for some).

    It's funny, you even mentioned making changes to wireless settings, yet you don't do wireless. (nitpicking again :wink: )

  3. parabol

    parabol Guest

    I having the problem as well - and trying to firgure a solution out, just bringing you my parteners in wain a brief on my feedback from linksys support around the globe.

    I've just revieved an email form linksys swedish support doing as "jienn" proposed in recent post. -- Still getting disconnect on large file tranfer from wifi -> lan.

    Also got a support mail from linsys dutch support saying the issue has been forwarde af will be resovled in next firmware update -

    linksys@mailca.custhelp.com tell me to:

    Wireless router setting

    1. Open the Internet Explorer and type and there’s nothing for the username and the password set to ‘admin’
    2. Go to Setup tab or wireless tab and look for the “mode†there will be option for B-only, G-only.
    3. Click Save setting.

    Wireless computer setting

    1. Open the Control Panel.
    2. Click network connection.
    3. Highlight wireless connection, right click and select properties.
    4. On the general tab, click on configure button and then click on advanced tab.
    5. On the properties part look for the wireless mode and select B-only or G-mode.
    6. You also configure the advance setting of the wireless adapter. Look for RTS and Fragmentation Thresholds and set the value of each threshold to 2304.
    7. Click Ok or apply all the way out.

    You may try to configure the advance wireless setting. Go to and type ‘admin’ for the password. Click the wireless tab and advance wireless sub tab, look for the transmission rate and set it to 54Mbps and you may try to set it to 11Mbps. The click save setting. In case you still have this problem try to update the firmare of the router you can download the firmware from this link http://www.linksys.com/download and then load this firmware to the router. WARNING: Make sure you use wired PC when you load the firmware and right the upgrade hold the reset button for 30 seconds before you try to connect to the router.

    Wich is really rubish support, obviusly cut'n'paste support --
    Like be there done that ---

  4. Maddogg0003

    Maddogg0003 Network Guru Member

    Ok, I have come to realize that this is a hardware/firmware problem. Do me a favor, when you go to copy a large file over wireless, ping the router with a constant ping. For those of you who don’t know how, go to start ... Run and type cmd. A command prompt will open. In the command prompt, type the router address (default but with a “ –t “. It should look like this ping –t . Once you have ping initialized, start copying files. What I witnessed is the router not responding then becoming unreachable after I hit a size in 25mb. This sures up this problem is not OS related.
  5. dstark93

    dstark93 Guest

    I have the same set of problems Wired connections work fine wireless doesn't. Changed all the settings linsys support told me to and it still doesn't work. Problem exists with wireless Macintosh laptops as well as Windows laptops. It exists with B cards and G cards. It does however get better if you use a B card and turn off WEP(strange), but that is not why I bought the router. I think I have had enough, time to return it and get something else.

    My 2 cents

    P.S. Can we say class action!!!
  6. Rainey

    Rainey Network Guru Member

    Finally some good new, thanks for letting use know what you found out. Glad to here Linksys is finally amitting there is a problem and that it will be addressed in the next firmware. I guess i can wait until then before i send this one back for the rebooting problem.

    When looking at my dell wireless utility link status, it show the packet recived and sent. It was clear that the packet are getting fragmented as i would recive twice as many as i would send. I tired to change the setting at the router but just guessed at the numbers.
  7. Golverken

    Golverken Network Guru Member

    WRT54GS transferring files

    Hello Everybody,

    I have also a WRT54GS european version.
    V1.1 of hardware on the label of the router.

    And Guess, I have also problems only when transferring files wireless!
    But some files go very well, also long amount of data, and other are impossible to send: "networkname is no longer available!"
    I have talked with linksys, but they didn't come with a sollution, I can change the device, but I think it will not solve the problem.

    Have anyone received a message from linksys they know about this problems and they will make a new firmware?
  8. Saber

    Saber Network Guru Member

    Another attempt from Linksys

    I just received a replacement unit from Linksys, another WRT54GS v1.1 and that unit also exhibited the same problem's I mentioned earlier in this thread. I have emailed this information to support and hopefully this will persuade them to accelerate their efforts and admit there is a problem with their wireless G hardware.
  9. Kalidor

    Kalidor Guest

    I've tried everything...

    I am a not so proud owner of a WRT54GS 1.1 since last Thursday and I am experiencing a problem which seems to be related to what many people in this thread described.

    I have a rather large home network (10 computer, 4 wired on a Gbit switch plugged into the router) 3 wireless desktops and 3 Dell Inspiron notebooks (all with the Dell 1350 miniPCI card - Broadcom chipset).

    I am using Samba as a PDC (with one of the wired computers as the server) with roaming profiles. One of the files transferred in a roaming profile is NTUSER.DAT. Loading profiles ALWAYS stops when this file is transferred in the sense that the network connection goes down for a brief moment, the windows clients spit out an error message. I've started experimenting with one profile in particular. NTUSER.DAT is 5.64 MB big and the transfer always stops when 40% of the file have been transferred, no matter what the actual wireless bitrate is. It just takes more or less time to reach that point, but it always stops right there without exception. I can reproduce this 100% of the time.

    Really funky is the fact that transferring a home video I captured and enhanced to put on a DVD, 3.5 GB all in all works just fine.

    Now I also tried all kinds of firmwares (hyperWRT, stock Linksys, latest Linksys, Sveasoft), wireless security and no security to no avail. I modified te advanced settings following suggestions here. And I just got off a Livesupport session with a Linksys rep. His suggestion was to get the router replaced.

    I had a similar problem with a D-Link 714P+ once (the router which got replaced with the WRT54GS and is SOLD already, argh) but there changing RTS and Fragmentation Threshold solved the problem, this doesn't work here.

    I don't know if it makes sense to return the router and get a replacement or get different equipment altogether.

    Well, I better go to bed. Maybe my 2cents here give some an idea on how to solve this problem.
  10. PhilSmith

    PhilSmith Network Guru Member

    My "work around" for WRT54G ver 2.2

    Just to give you guys an update on my situation. I got tired of trying all the different firmwares and configurations fixes. I was convinced that it was the hardware. D-link 524 routers were on sale near here so I bought and set one up in about 30mins.

    I copied several 700 meg image files from my desktop to my laptop through the unsecured wireless dlink connection without problems. This is just confirmation to myself that there is in fact a problem with the linksys router.

    I read about other probs with d-link but at this point I am happy with the new router. Now I have two wireless routers.

    I will let you know what other events develop regarding this situation if interested.

  11. wrt54gs

    wrt54gs Network Guru Member

    Me too.
    Router : WRT54G V2.2
    Firmware: HyperWRT v2.1b1

    Wireless card: DLink DWL-G520+ (Desktop)
    Dlink DWL-G650+ (Laptop)

    Both Signal is more than 70%. indicator: 54Mbps .

    Last night I tried to copy file (more than 400M) from Desktop to Laptop.
    after start , The speed was slower and slower , from 54Mbps to 24,18,11, and to 1mpbs, then Desktop lost connection , must reboot then can reconnected. Try many times but all failed.

    So today I tried to find root cause and found the Thread.

    I will try some setting tonight . If still can't work , I will exchange one or select another brand.
  12. Skully

    Skully Network Guru Member

    i used the default firmware, dd-wrt and hyper-wrt...same result.
    my WRT54G is rev. 2.2 EU.
    downloading files over wlan causes reboot of the router.
    yesterday i wanted to tansfer a 4 mb mp3 file and the router goes down.
  13. Maddogg0003

    Maddogg0003 Network Guru Member

    Have you guys tried pinging the router with a constant ping? I want to know if you get destination unreachable or hardware failure. I get both, destination unreachable and then hardware failure. This tells me that the router is rebooting every time.
  14. moi666

    moi666 Network Guru Member

    I can confirm that I experience the same msgs. However I didn't get to look at the router lights. Can you confirm that it did reboot?
  15. zwogbwog

    zwogbwog Guest

    I managed to resolve the problem with some help from a local distributor. He suggested disabling the internal firewall in the WRT54G. It worked beautifully after that. I have successfully transferred a 350MB file from 2 notebook pcs to a wired PC, on both B and G. I hope this would help. Good luck!

    Technical info: hardware v2 firmware v3.03.1
  16. NtegrA

    NtegrA Network Guru Member

    disable the firewall?

    That doesn't solve the problem. "NO FIREWALL?!?!" I don't think so.
  17. will792

    will792 Network Guru Member

    I happen to have two WRT54G routers, one is v.2.2 and one is 2.0. The only router that crashes on file transfers is 2.2. I used the same firmware for comparison, 3.03.6 and HyperWRT 2.0 with the same settings (64-bit WEP, B/G Mixed mode, SSID broadcast, MAC filter for wireless, MTU=1492 for router and all clients).

    I see that the router reboots by looking at time since last reboot in HyperWRT Status screen. The error "Network name is not available" just indicates that the router is hosed. Eventually (~10 seconds) it comes back to life, all clients get new IP addresses and everything looks normal but file transfer is aborted.

    Linksys offered to exchange 2.2 router but I know that the new one would have the same problem.

  18. jagboy

    jagboy Network Guru Member

    most of the time the router that they replace it with is usually a salvage one.

    that is some serious hardware problems i am glad i stuck with the WRT54G v2
  19. doppler

    doppler Network Guru Member

    i dont have linksys at my place,however if ur facing the problem of heavy data traffic disconnecting the w/l connection may be you would like to play with advanced w/l settings like reducing beacon,fragmentation threshold and RTS threshold
    see if that helps
  20. oleo

    oleo Network Guru Member


    I speculate that this is problem with UDP filtering or UDP packet drop. Witg the TCP connections this does not occur. Here is snippet from /proc/net/ip_conntrack

    tcp      6 431992 ESTABLISHED src= dst= sport=2153 dport=445 src= dst= sport=445 dport=2153 [ASSURED] use=1 mark=0
    udp      17 58 src= dst= sport=137 dport=137 [UNREPLIED] src= dst= sport=137 dport=137 use=1 mark=0 
    See that most disconnects are caused by DROPPED or UNREPLIED UDP packets!
    Interestingly, communicating with SMB protocol between Linux machines using SAMBA this disconnect issue does not occur. It seems that Unix SMB clone is working better than original over wireless!

    Maybe tweaking IP tables should resolve this problem. As suggested by disabling firewalling or such.
  21. Saber

    Saber Network Guru Member

    I don;t !@$% believe this!!!

    I recently signed up for Vonage and was connecting in the linksys router they sent me (RT31P2-VD). During the instructions in setting this up I performed a 30 second hard reset of both pieces of linksys hardware and both restarted just fine. I though, for the heck of it I would try my wireless again and now it works fine. I get no disconnects and throughput is exactly as you would expect. The REAL kicker is that the router is still set for all factory defaults. I changed the wireless router password, SID, and set port forwarding and wireless still worked correctly.

    What I noticed different now from before was the way that my wireless router went through its hard reset cycle. Before, when I started to press the reset button during the first 5 seconds the router's power button was steady blinking and all the other lights flickered and then every light went steady on for the rest of the 30 seconds except the power button which kept blinking. This time the first five seconds was the same but after another 10 seconds all the lights again flickered for nearly 10 seconds and then went solid. When I let go of the reset button the power button went solid and everything started to work.

    Now, I called Linksys to tell them about this issue and they simply wanted to close my ticket. I told them that was not right and that obviously there is a problem with these routers not fully rebooting and initializing correctly. After 10 minutes of trying to convince the tech of this he agreed to send this information up the next level of support for their review. I told them NOT to close my call and to email me back with their conclusion. We'll see if that happens.
  22. jagboy

    jagboy Network Guru Member

    if it is one companys support that pisses me off it is linksys. i dealt with computers companies isp's and all sorts of support personel but linksys just pisses me off. i dont call them anymore if i have a problem with my router becasue it is a waste of time.

  23. Toxic

    Toxic Administrator Staff Member

    Ok I first need to point out something.

    The new WRT54G v2.2 and v3.0 and WRT54GS v1.1 and v2.0 have a different chipset.

    older versions have the ADM6996L LAN chip whereas the new versions use a BCM5325EKQM Chip.

    To determine your version of WRT54G/GS, look at you serial number which should be on the bottom of the router.

    Known serial numbers (first 4 characters) vs versions:

    CDF0 = WRT54G v1.0 ADM6996L Chip
    CDF1 = WRT54G v1.1 ADM6996L Chip
    CDF3 = WRT54G v1.1 ADM6996L Chip
    CDF5 = WRT54G v2.0 ADM6996L Chip
    CDF7 = WRT54G v2.2 BCM5325EKQM Chip
    CDF8 = WRT54G v3.0 BCM5325EKQM Chip

    CGN0 = WRT54GS v1.0 ADM6996L Chip
    CGN1 = WRT54GS v1.0 ADM6996L Chip
    CGN2 = WRT54GS v1.1 BCM5325EKQM Chip
    CGN3 = WRT54GS v2.0 BCM5325EKQM Chip

    NOTE: Using the as a guide to what Hardware version you have is INCORRECT !!!!! most report v2.0 (WRONG for our needs)

    Use the Serial Number as the main guide.


    Sveasoft has commented, and i quote word for word:

    so you may find with even the lastest firmware versions that you do have problems. I cannot comment if this can be fixed as yet i am still waiting on word from James about if this issue could be fixed. he is atm getting some new v3.0 WRT54G units to test with.
  24. SometimesLinkyFan

    SometimesLinkyFan Network Guru Member

    Sorry for the repeat info on the WRT54G v. 3 (CDF8...) but..

    ... I got one of the hardware version 3 units the other day; the disconnects are still there. I returned it and went back to my bullet-proof BEFW11S4 version 4.

    The main benefit of the "G" technology in my situation was a 3X real life increase in speed of PC-to-PC transfers (when the WRT54G remained connected, that is) . With a DSL Internet connection speed of 2.5 mbit, there was, of course, no benefit in WLAN access. The extra tweaks the WRT54G offers are nice but obviously can't make up for the connectivity problems.
  25. JohnSK

    JohnSK Network Guru Member

    Guess what ppl...

    this may be somehow related to your network card. I have a MSI K8N DIAMOND SLI board which has dual gigabit LAN's. Using the Marvel PCI-E LAN I get disconnected when copying files over the wireless network, as I mentioned before. (although not all the time..) Now with the nVidia integrated LAN I get zero disconnects - I've transferred about 10 GB of data, had eMule running in the background (800max connections) and also 2 BT downloads.. what now? I will try the Marvell LAN again and report later..


    ps: max speed I've achieved was a stable 1,4MB/s over a 1,5km link
    ps2: what speeds are other people getting disconnected @?
    ps3: before I was using my Acer NB which had VIA integrated LAN card and got disconnects every so often as I described in previous posts..
  26. Rainey

    Rainey Network Guru Member

    Well I give up, i returned my WRT54G V2.2 today and went back to my BEFSR41 V2.0. Not only did i have the wireless to wired file xfer problem BUT i also had a problem with the router locking up during full IPS bandwidth downloads for long periods of time. I would start downloading many GIGs of information for the internet and the router would just lockup at radom times. Today it happen four times during about 6 gig download period. So i returned it for a refund, i did not exchange it as the new one will most likely have the same problems.

    I travel a lot and need to depend on this router to be online so i can connect to my home PC. The WRT54G V2.2 is not dependable enough for me.
  27. will792

    will792 Network Guru Member

    From my point of view the worse part is that WRT v.2.0 was close to being bulletproof while the next version (supposedly an upgrade) is nowhere close.

  28. moi666

    moi666 Network Guru Member

    Hv just contacted Linksys support. Had 2 replies from them, so far to :

    1) decrease MTU - problem persists
    2) upgrade firmware - problem persists.

    Let's see what else they say.
  29. mstombs

    mstombs Network Guru Member

    Been lurking here for some time hoping someone would solve this problem for me I have a

    CGN2 = WRT54GS v1.1

    and wireless laptops with XP Home SP2 plus Linksys WPC54GS card and win2000 with old WPC11 card.

    I have no problem copying gigs of files using wired connections via the router but I do have problems with transferring certain files over wireless from an XP PRO desktop using windows shared directories.

    I thought this was the same problem as others report here, the transfer stalls then windows reports " The specified Network Name is no longer available". With help from Linksys I have made the wireless connection more stable

    "Set the Beacon Interval to 50.
    Set the Fragmentation Threshold and RTS Threshold to 2304"

    which seems to slow down the maximum speed although windows still reports the spurioius 125Mbps and the Linksys utility "Speedbooster". Actual transfer rate I achieve is about 2 MegaBytes per second (20Mb/s ?) and I can transfer 650Mb CD ISOs without interruption.

    But certain folders with certain files just won't copy. The smallest file I have found that gives trouble is

    OWC10.MSI 547kB

    off an MS Office 2003 install disk.

    I have tried disabling firewalls, antivirus, antispyware but I haven't yet tried uninstalling them - but transfers via wired LAN work fine so why?

    I cannot understand how the router which only sees TCP/IP packets can be at fault I suspect Microsoft drivers.

    Is this the same fault as others have?
  30. pharma

    pharma Network Guru Member

    See if you are using WPA/AES Security. If so, try changing to WPA/TKIP and see whether you still have the same problems with large files.

  31. SometimesLinkyFan

    SometimesLinkyFan Network Guru Member

    FWIW, and only if you want to roll the dice on a version 2.0 WRT54G, I see that CompUSA (in Deerfield, IL, for example) has a few 2.0s (serial number beginning with CDF5) on the shelves.
  32. moi666

    moi666 Network Guru Member

    3rd reply from Linksys Support was to change the threshold values to 2304, but no mention of the Beacon Interval :

    Settings info:
    RTS Threshold: 2304
    Fragmentation Threshold: 2304
    DTIM Interval (If the value is 3 set it to 1) and (If the value is 1 set it to 3)

    I do not have my router atm. Has anyone tried this with success?
  33. marq111

    marq111 Guest

    It did not help ...
  34. no-talent-ass-clown

    no-talent-ass-clown Network Guru Member

    I am having the same issue going from WAN to LAN. I have a WRT54Gv2.2 with a WMP54GS card with the latest drivers from Linksys. I have made all of the changes talked about in this thread and continue to get dropped connections when transferring files from network computers.

    Unfortunately for me, I have this card in my HTPC in the living room thinking it would be a good way to get rid of cables, but I can't even watch a divx movie with MP3 without losing the connection.

    I have also tried all of the available third party firmwares (only HyperWRT at the moment for v2.2 models) and there is no differences whatsoever. I have no 2.4GHz phones and no one within a block, so there shouldn't be an interference from that. I am taking the router back tomorrow night and hopefully a new one will work better. I will let you know if the new one works or if it is sh*t as well.

  35. Scroatdog

    Scroatdog Network Guru Member

    I do beleive Linksys intends to write us off. Speakng of (oh yeah, I posted on page 3 or so of this thread. Have the same problems with large file xfers to/from the wireless comp.), I've got two $10.00 rebates I'm supposed to be getting from Linksys (through Fry's) but haven't heard squat. Bet I'll get juiced on that too.....
  36. PetrMegac

    PetrMegac Guest

    Well, try connect antene to the right connector on WRT54G and in firmware set RX and TX antene to the left. Sorry for bad english. :))
  37. tekknix

    tekknix Network Guru Member


    That's sound quite interesting. I don't think, that the discoonects occurs due to heave load or an overheating processor.

    I'll try to reduce the signal to one of the antennas. And will play with the firmware-features.

    Will post as soon, as i've got results.

    It could really be a problem, that (due to an hardware-related built-in Problem) the WRT54G doesn't seem to "Know", where it has to send or to receive and therefor the router will reboot.

    I don't know, if anyone has given it a try...

  38. Niteflight

    Niteflight Network Guru Member

    Hi all,

    I've been experiencing exactly the same problems with disconnects during 'large' file transfers (>40Mb). Linksys should really speed up fixing this problem. Reading this whole thread it's quite obvious for me that this is unacceptable! I upgraded from an old 11b model just a few weeks ago, but I might just return to using that (with it's own problems...)

    For the moment I've tried both the last Linksys Firmware and am now using HyperWRT. Although not all problems are solved, everything is at least more stable during normal web browsing.

    Oh, before I forget, using wired connection between my notebook and the network does not create any problems....

    Good luck to us all....
  39. JohnSK

    JohnSK Network Guru Member

    I tried changing the Marvel GB Lan settings.. changed all values from defaults to random values. Tried transferring 2 x 600MB AVI's, no problem. Now transferring a 4GB file - speed is around 1,42MB/s, no dropouts yet, 3,5GB downloaded. I attached an image from Task Manager,the patial graph is spiky as usuall but there are no dropouts.

    ps:can't attach a file,seems there is a problem with the message board :(
    ps2: the file was actually 4,6GB, transferred without any problems.. rebooted the AP's and trying again..
  40. NotLinked

    NotLinked Network Guru Member

    MSTOMBS, I must say that I have EXACTLY your scenario, right down to the version of WRT and OS version. I even discovered the failing Office2003 file (OWC10.MSI) which consistently produces the error message you've indicated, while huge files transfer fine (usually).

    I have just spent the last hour reading every post in this thread, and conclude that Linksys has a problem with this router hardware, probably based on the chipset being BC, but perhaps all chipsets. I have spent hours on the phone with Lvl2 support, same dead-end solutions as everyone here has received. Personally, I don't think this issue can be resolved with a firmware fix, and Linksys will wind up eating major crow.

    I am convinced that this issue is caused by a specific sequence of data in the stream. I based this on the fact that I've been able to isolate several files which consistently fail, while all others (including huge ones) succeed.

    One of the files, as indicated, is the Office2003 file "OWC10.MSI", which is only 547kb. This file fails at the same point every time, presumably when the sequence of bits is processed for wireless transmission. This is causing a reaction in the router to self-reset or reboot. I cannot attach this file because this sites attachment feature isn't working, but I will post it on a website elsewhere and add a post to this thread with location later. I suggest that folks try copying this across their wireless connection. I guarantee everyone with the problem that MSTOMBs and I are having will fail this test.

    How does this help? It doesn't. We'll all have to return our hardware eventually, when we grow weary of waiting for the pie-in-the-sky firmware fix that never comes from Linksys.

  41. NotLinked

    NotLinked Network Guru Member

    Just posted the file which cannot traverse the WRT54G/GS wireless connection at http://novaffl.tripod.com/ .

    Not the best "secure" method for testing this, but it's a zip file which you can download and view for yourself without harm. Unzip it, and try copying to or from your wireless NIC using the WRT54G/GS.

    I'm certain Linksys has already gotten this far, but I'm guessing they don't and won't produce a firmware solution for this, but that's just my bad attitude talking...

    Lost in Linksys,
  42. bpaskin

    bpaskin Network Guru Member

    I have a 54G v1.1. The orginal firmware was 2.x and it worked great. I had no problems. I upgraded to 3.03.6 and have the same problems as mentioned above. It has something to do with the firmware. The new firmware says it cannot be downgraded, so I am in the boat with everyone else. I hope Linksys fixes this problem pronto!
  43. mstombs

    mstombs Network Guru Member

    Great so I am not imagining it, I've tried transferring this file from an XP PRO machine or an old win 98 to an XP home wireless Pc or Win 200 wireless B PC. There is no problem transferring via wired connections so I don't believe it is a windows/firewall/antivirus/adware problem.

    Please can anyone who reproduces this problem contact Linksys via the linksys.com website (don't bother email linksys UK they do not even bother to acknowledge let alone reply!).

    And if you find a way round this let us all know!
  44. Pacif13r

    Pacif13r Network Guru Member

    Sweet... I swapped my GS out based on problems transferring certain files over wireless AND wired. The new one could transfer all the files that were giving me problems before so I thought the problem had gone. But I have been haunted by 'random disconnects' from my wireless network. But I only have 1 laptop and this is my only wireless AP so can't do much in the way of comparison diagnostics. But I have been following this thread to keep an eye on things. And now this... concrete proof - I have attempted to copy the file 3 times at 3 different distances from my AP and every time it goes bye-bye. At last I can return this cr%p as "unfit for the purpose for which it was sold" But I love the OpenSource firmware :/ I might give them another 3 weeks for a working solution

    Anyway.. thanks for the evidence. I can't believe this company still pretty much deny any problem and no fix despite all evidence to the contrary... talk about no shame!! Still I will do my bit to make sure I spread the word.... "Friends don't let friends buy Linksys."
  45. I fixed mine

    Well guys, I've been reading this forum, and was saddened to see that a lot of you have the same problem I've been having. When transfering large files from my wired computer to my wireless laptop, the wireless portion of my network would crash, or the router would crash altogether, throwing my wired network offline. It seems none of you have found a solution. I have found a solution that works for me, however. I installed the latest firmware from linksys.com, and then I restored the factory defaults, set up my internet connection (PPPoE) and set up security, i'm using TKIP. And all the suddon. Voila, I can transfer files. Although for some reason I'm only getting an average transfer rate of about 38-40% of my 54 mb connection. Maybe it's just the laptop being slow (brand new laptop) Or maybe I have something misconfigured...Well anyways, I hope this helps some of you. My guess is that the new firmware comes with new factory defaults, and when you set them, some bad configuration gets overwritten. (purely speculation, I have no clue if this is true or not) But most likely it's just pure dumb luck.
  46. Lo_Pan

    Lo_Pan Network Guru Member

    i was having the same problems on a WRT54G v2.2 until i stuck a couple heatsinks on the two broadcom chips which were generating a bit of heat, and stuck a 60mm fan in. no more reboots... interestingly, before i did this i'd see numerous overruns and errors on the wlan and wired interfaces when xferring large files to wireless, and the buffer would just get larger and larger. eventually it would just reboot. so for me, this was definitely a heat issue.
  47. mstombs

    mstombs Network Guru Member

    My problem above is not heat, the router fails on the problem files within seconds of power up when stone cold. How do you monitor "overruns and errors" and "buffer" sizes?
  48. bmandelj

    bmandelj Network Guru Member


    i had the same problem bought WRT54G v2.2 EU 2 weeks ago and got continous reboots when transfering large file from lan to wlan, i tried multiple firmwares but none helped. I tried original linksys 30306, alchemy pre7a, hyperwrt 2b1, dd-wrt, all had the same problem. also i had problem when running emule, dc++, bitorent programs on any of the pcs the router rebooted after couple of hours, lowering timeouts didn't help.
    finally i decided to take it bak to the shop and they exchanged the unit, after that i had no more problems transfer works great i am runing emule, dc++, bitorent for 2 days now no reboots currently i am using dd-wrt #22 prefinal3 with wep and it works great (without additional cooling).
    my guess is that a lot of the v2.2 series is faulty
    anyway after 14 days headache is over

  49. lnorange

    lnorange Network Guru Member

    WAG54g Failure and Linksys Response

    Linksys don't have anything on any websites but they have finally admitted that there is a problem. To date they have been saying to me that it is an isolated issue with me.

    I stated to them that the good were not 'fit for purpose' under UK law and I would be seeking leagal advice to recover costs.... their replay was :

    Dear Mr. Orange,

    Thank you for contacting Linksys Technical Support.

    I'm sorry for the inconvenience that this have brought you. We have received many reports from clients having the same concern as what you are experiencing, Linksys is aware of the said concern.

    Reports are collated and being processed for our Product Development Team.

    With your case, I did process the form and submitted your informations about your network setup, devices used and steps taken to troubleshoot the device for them to replicate and apply necessary steps and solutions.

    I'm sorry to inform you that this is still under laboratory testing and working for permanent solution for this concern, we still don't have specific date when an update will be released. You will be contacted once solutions have been applied.

    Again sorry for the inconvenience. Thank you.


    Cisco Systems, Inc.
    Product Support Specialist

    So simply put, they haven't got a clue!!

    Will post more when they come back to me, I will not give up, it is now an issue of principle.

  50. Lo_Pan

    Lo_Pan Network Guru Member

    using the standard os tools in openwrt. normal nix crap.
  51. -mb-

    -mb- Network Guru Member

    There may be some merit to the faulty batch theory. The unit I have has never hiccuped under any of the circumstances that I read about here.
  52. Xyse

    Xyse Network Guru Member

    Re: WAG54g Failure and Linksys Response

    Got to love UK laws to protect consumers. Too bad I dont live there. =/
  53. no-talent-ass-clown

    no-talent-ass-clown Network Guru Member

    Well, I was having the same issue as you guys with v2.2. So, I took it back to Best Buy and checked the model numbers on a few boxes until I found a v3.0 model. I brought it home and set it up quick and with no encryption, I transfered 5 GB of divx files. So, then I put WEP on and did the same thing, all with no issues and good speeds.

    So, if you have a v2.2 model, I would recommend giving the v3.0 a try and see if it works better.

  54. wigam

    wigam Network Guru Member

    Take it back or open it.

    I bought a WRT54GS v1.1 today. Before I opened it I thought I'd check out the 3rd party firmware option, anyway checking out this site I'm now extrememly alarmed!!

    Should I open the box now or take it back and try and swap it for something more reliable.
  55. no-talent-ass-clown

    no-talent-ass-clown Network Guru Member

    I would just open it and test it out for a few hours. It has been hit and miss on which router works and which doesn't, so you might as well see if yours works. Because if it works, Linksys are the best, bar none.

  56. kccoyote

    kccoyote Network Guru Member

    Does anyone know if the WRT54GX also suffers from the same problem? I'm going to bring my WRT54GS back and can exchange it with whichever router i want and would like to stay with Linksys, but only if works of course...
  57. bramat

    bramat Network Guru Member

    Just got of an hour and a half long live support chat with linksys..

    Got the WRT54G v2.2 router and the wlan part is really buggy.

    My advice for now is to stay away from that version scinse linksys doesnt have a clue to what the problem is..

    Personally i doubt a firmware upgrade could even fix it, but then again im no expert...

    Kinda pisses me off that they even put the v2.2 on the market..

    Why fix the v2.0 till it's broken ? :=

    Edit: If somone would take the time to write a letter to cisco and explain how this might put them in a bad light, they might give linksys a little whoopass :) and we as consumers dont have to buy broken routers at the store anymore :=
  58. bpaskin

    bpaskin Network Guru Member

    Found a solution

    After spending a long time with two people from Linksys and having to reset the router several times, I found my problem, and I hope this helps other people.

    I have a v1.1 router and was packed with 2.04.3 firmware. When I upgraded it suddenly started having problems. Since the latest firmware cannot be downgraded I was stuck. However, I did notice in their documentation that they were not wi-fi certified until 3.03.1 firmware. I am not sure that has anything to do with anything, but I was betting they tweaked their code to be compliant.

    My driver for my wireless card was also pre-certified. Once I updated the driver to the latest version everything works like a champ.
  59. wrt54gs

    wrt54gs Network Guru Member

    Hi All,
    I experienced same problem as mentioned before. So I exchanged one from service center , but this one was same as old . Tried two days then exchanged one too.
    The third is so good and have no problem so far. Will not reboot with original firmware: 3.03.01 or lastest version 3.03.06( maybe some mistake), Even with HyperWRT v2.1b1.
    All three WRT54G are same version : V2.2.
    So I don't know why Router will disconnect when transfer large file in Lan or download large file from internet.
    But I think not all WRT54G V2.2 have the problem , It's you luck if you could get stabel one.
  60. wigam

    wigam Network Guru Member

    I returned my WRT54GS v1.1 and found a WRT54G v2.0. Will stick with this until the problems are sorted:)
  61. JohnSK

    JohnSK Network Guru Member

    Some of the lucky ppl who don't have problems with transferring large files at high speed -- could you please post what LAN card you have in your PC? I've noticed this makes a BIG difference - I have 2 LAN's and one is more prone to dropouts,the other is almost perfect! Testing now with 10 BT downloads open - the Nforce4 LAN controller had dropouts, but the Marvel Gigabit LAN works great. I am attaching a graph of my LAN activity generated by BT download/upload which stresses the connection the most IMO. It's strange that a few pages ago the NF4 LAN controller was better - maybe because of the 64bit drivers, I had XP64bit RC2 installed at that time,back to 32bits because CREATIVE are unable to provide drivers for the Live!24bit soundcard..

    ps: again it's impossible to attach files? will this be fixed sometime soon?
  62. no-talent-ass-clown

    no-talent-ass-clown Network Guru Member

    I have three different LAN computers...one with a Marvell, one with an onboard Intel, one with an Intel PCI card. All are gigabit and connected to a gigabit switch which is plugged into the router. Also, my wireless card is a WMP54GS.

    Like I said before, the first router I had (v2.2) had major issues but my new one (v3.0) doesn't have a single issue. I have been testing it with big files or GB's of smaller files a few times a day and it handles it just fine. So, it sure seems like a router issue.

  63. mstombs

    mstombs Network Guru Member

    I had a problem with Nforce4 on a wired connection with old BEFSR41, but his was fixed by installing the latest Nvidia drivers.

    Other networks cards I have are SIS mboard, SMC PCI, 3com pccard, sony realtek mboard all 100Mb/s all have no problem with wired connections but cannot send certain problem files over the wireless lan
  64. marten

    marten Network Guru Member

    I had the same problem as you did. Though I have a WRT54G and a wmp54g. After communication with Linksys I did get a workaround. When you use static routing for your wireless station, the problems are over.

    - IP adres: 192.168.1.X
    - Subnet Mask:
    - default gateway and preferred DNS server both the IP adres of the router. Standard

    For me it worked. I hope it works for you as wel.

    They escalated the call. That means that there will be a bugfix in the future (we hope).
  65. mingworld

    mingworld Guest

    I am having exact problem. very frustrated.
  66. mstombs

    mstombs Network Guru Member

    Finally got a reply from Linkys UK support after 2 weeks but

    "there are however no known issues with this product"

    so if you are experiencing one of the above problems please report it to your local linksys and via linksys.com.

    So I can attempt to narrow down my file problem above can anyone recommend a good freeware windows packet sniffer?
  67. NotLinked

    NotLinked Network Guru Member

    Folks, sorry to say that I've had to bail on this problem. I had an old BEFSX41 and returned my WRT54GS for a WAP54G, and all is well in Linksysville. My test file (at http://novaffl.tripod.com/) transfers flawlessly, and the WAP was same cost as the router... so I guess if you don't need the firewall and router and wired functionality, you too can correct your problem with the crappy GS. :)

    I suspect now that it is probably firmware, and wish Linksys products weren't so good and easily configurable with real nice config gui's so I could hate them more... but I do like them, so ...

    Good luck to y'all, I'll keep an eye on this for when it gets resolved, but won't be holding my breath any longer.

    Once was lost, but now I'm found,
  68. Otis_fr

    Otis_fr Guest


    I have the same problem, but my configuration is a little bit different.
    I have 2 WRT54G V2.2 in bridge mode with the last HyperWRT firmware

    (workstation+server 2003 lan)---(WRT54G)+++WIFI+++(WRT54G)--(workstation lan)

    With a large transfert file or perhaps simply logon to the PDC the WRT reboot (randomly the first or the second)

    I plan to replace my bogus V2.2, please can you confirm me the V2.0 and V3 works perfectly ?

    Thanks for your answers
    Thanks for this good forum :mrgreen:

  69. bramat

    bramat Network Guru Member

    I've heard lots of people have the same problem with v3.0..probably since it has the same chip as v2.2..

    Can't confirm it personally, but be carefull :roll:

    Edit:typo was here
  70. TheRoDent

    TheRoDent Network Guru Member

    I have suddenly seen this problem cropping up on my development WRT. I've been trying to build perl via a root file system mounted on another host via NFS directly on my WRT.

    A ksymoops analysis revealed that the new et.o (ethernet driver) is most likely to blame.
    >>$1; 80210000 <ip_nat_irc_helpers+10c/1e0>
    >>$4; 80191180 <softnet_data+0/180>
    >>$13; 80ff6800 <_end+dd87f0/3fe8e8a0>
    >>$16; 80ab62c0 <_end+8982b0/3fe8e8a0>
    >>$17; 803e3a60 <_end+1c5a50/3fe8e8a0>
    >>$18; 80a71810 <_end+853800/3fe8e8a0>
    >>$22; 80d1c930 <_end+afe920/3fe8e8a0>
    >>$28; 80800000 <_end+5e1ff0/3fe8e8a0>
    >>$29; 80801a60 <_end+5e3a50/3fe8e8a0>
    >>$30; 8073ca20 <_end+51ea10/3fe8e8a0>
    >>$31; 800d5ca0 <netif_rx+20/318>
    >>???; 800d5cfc <netif_rx+7c/318>   <=====
    Trace; c00c68c8 <[et]et_sendup+fc/140>
    Trace; 800b4fbc <dma_rx+bc/e4>
    Trace; c00cb70c <[et]bcm47xx_et_chops+0/5c>
    Trace; c00c8218 <[et]chiprx+20/48>
    Trace; c00cb70c <[et]bcm47xx_et_chops+0/5c>
    Trace; c00c6704 <[et]et_dpc+54/11c>
    Trace; 800d671c <net_rx_action+b0/1dc>
    Trace; 800169b8 <tasklet_action+94/104>
    Trace; 80016610 <do_softirq+b0/170>
    Trace; c01420a4 <[sunrpc]rpc_restart_call+16c0/1878>
    Trace; c0144258 <[sunrpc]xprt_transmit+7a8/7d8>
    Trace; c0143e30 <[sunrpc]xprt_transmit+380/7d8>
    Trace; 800eced8 <ip_rcv_finish+0/2e8>
    Trace; 800ecc88 <ip_rcv+51c/590>
    Trace; 80143780 <vlan_skb_recv+320/56c>
    Trace; 800eced8 <ip_rcv_finish+0/2e8>
    Trace; 800b4fbc <dma_rx+bc/e4>
    Trace; c00cb70c <[et]bcm47xx_et_chops+0/5c>
    Trace; c0143c94 <[sunrpc]xprt_transmit+1e4/7d8>
    Trace; c01442f0 <[sunrpc]xprt_reserve+68/1c8>
    Trace; c0141214 <[sunrpc]rpc_restart_call+830/1878>
    Trace; c0140b88 <[sunrpc]rpc_restart_call+1a4/1878>
    Trace; c0145d14 <[sunrpc]rpc_delay+158/490>
    Trace; c0145d14 <[sunrpc]rpc_delay+158/490>
    Trace; c0171aa8 <[nfs]nfs_destroy_nfspagecache+1760/1b4c>
    Trace; c01460d0 <[sunrpc]rpc_execute+84/29c>
    Trace; c0140950 <[sunrpc]rpc_call_setup+50/98>
    Trace; c0171e44 <[nfs]nfs_destroy_nfspagecache+1afc/1b4c>
    Trace; c0171e34 <[nfs]nfs_destroy_nfspagecache+1aec/1b4c>
    Trace; c0171f00 <[nfs]nfs_pagein_list+6c/b8>
    Trace; c0172010 <[nfs]nfs_scan_lru_read+78/d0>
    Trace; c01720c8 <[nfs]nfs_pagein_inode+60/3c4>
    Trace; c01720a4 <[nfs]nfs_pagein_inode+3c/3c4>
    Trace; c01719e8 <[nfs]nfs_destroy_nfspagecache+16a0/1b4c>
    Trace; c0175a68 <[nfs]nfs_sync_file+94/bc>
    Trace; c01724fc <[nfs]nfs_readpage+d0/124>
    Trace; c017249c <[nfs]nfs_readpage+70/124>
    Trace; 80025588 <add_to_page_cache_unique+144/15c>
    Trace; 8002fdf4 <_alloc_pages+24/30>
    Trace; 80025684 <page_cache_read+e4/130>
    As is clear, the section of kernel where things went wrong is inside the ethernet module. This theory seems to be supported by people using V2.0 units that use the new drivers and have reboots. When the old V2.0 drivers are used, everything is fine.

    Unfortunately the old ethernet driver doesn't support the new hardware of the V2.2 units, so we're stuck until Linksys fixes the ethernet driver.

    This is just once again, one of the disadvantages of closed-source drivers. Thanks Linksys!
  71. JohnSK

    JohnSK Network Guru Member

    ummm.. the jibberish doesent make sense to me, could you please explain a little?
  72. TheRoDent

    TheRoDent Network Guru Member

    Basically, theres a bug in the new firmware ethernetdriver for V2.2 wrt's that causes a reboot under heavly load.

    I've found that dropping the MTU on my PC's and WRT's to 1024 seems to solve the problem.
  73. jagboy

    jagboy Network Guru Member

    that really sux i just bought a v2.2
  74. JohnSK

    JohnSK Network Guru Member

    The only drawback using these settings is a slower download/upload speed compared to a higher MTU.. LinkSys, FIX IT FINALLY!!!! :evil:

    ps: shame that upload dropped from 400 KB/s to only 40 KB/s and download from 1600 KB/s to 850 KB/s
  75. Pacif13r

    Pacif13r Network Guru Member

    Wonder how/if this effects GS 1.1 series. Also some peope (me included) have a problem with certain files. Almost like it's a specific byte sequence that occurs over TCP/IP & SMB shares whilst moving certain files. And can occur at other times causing seemingly random disconnects.

    Any thoughts/links ?
  76. dpearcePNG

    dpearcePNG Network Guru Member

    More information

    I discovered this thread tonight after struggling a bit with a file that wouldn't copy. Being an ex-QA tester for a SW company, I immediately devised several tests. Hopefully this information is helpful to someone.

    Wrote two batch files. Batch1 copies a whole bunch of JPG files to a Linux box. Batch2 copies a small number of big files. Batch1 runs by itself fine. Batch2 by itself goes until it hits a certain file, then stops. Running Batch1 and Batch2 together runs until Batch2 hits the same file. This also stops Batch1. Pings continued fine, no signs of rebooting on the router. Uptime advancing normally.

    I then took the file Batch2 was choking on (22 MB) and split it into ten pieces (each piece 2.2 MB in size). Pieces 1-6 and 8-10 will copy fine. Piece 7 always caused the router to choke.

    I then split piece 7 into ten peices (each piece 220 KB in size). Sub-pieces 1-6 and 10 copy fine. Sub-pieces 7-9 cause the router to choke.

    This leads me to believe there is a bit combination that is causing the router to choke.

    Anti-virus was turned off. I was able to duplicate the problem with Robocopy, COPY, XCopy and ViceVersa. I was not able to duplicate the problem with a wired connection to the router

    I was able to duplicate the wireless choke with Robocopy and a parm of /IPG:250 which slows it waaaay down.

    This is on a stock WRT54GS v1.1 (even if it says 2.0) with current firmware.
  77. RyFeR

    RyFeR Network Guru Member

    Even more info

    Hello all,

    I'm having the exact same thoughts regarding the bit-sequence thing... I can copy some 4.5GB DVD ISO's back and forth over my WRT54GSv1.1, but other (large or small) files give the "Network name can not be found" message, all AT THE SAME SPOT... This is no crach on heavy load, this is indeed a certain sequence that triggers the disconnect, but only for that file copy. A ping to the WRT54GS in another window shows no sign of disconnect...

    I insisted on buying a LinkSys for it's stability, easy config and the opportunity to run different firmwares... Stability sucks at the moment, let's hope LinkSys (or another firmware developer) discovers this bug and makes a fix for it...

    EDIT: Forgot to mention that i've tried all settings that could be changed in the WRT54GS and different firmwares (original LinkSys, HyperWrt, Alchemy, all the latest version), the problem still remains...
  78. dpearcePNG

    dpearcePNG Network Guru Member

    More information

    I can duplicate the problem XP to Linux and XP to XP.

    And (drumroll please), I can duplicate the hang using a single 1,580 byte file. This is amazing.

    There does seem to be a size component to the problem, but I suspect it may be Windows smoothing over the problem using buffers. Much smaller than this and it seems to be able to copy the file but very slowly. I saw the hang inconsistantly in files as small as 158 bytes.

    I think it's safe to safe this is not a high-usage problem, at least in my case.

    I'm trying to decide if I should post or make people ask for the file. I wish I could make Linksys ask for it.

    (This reminds me of the time I discovered how to crash a brand new printer in TWO bytes of text.)
  79. dpearcePNG

    dpearcePNG Network Guru Member

    Anyone care at Linksys?

    I will work on reducing my test files to the smallest size and the smallest combinations of bytes, but only if I can find someone at Linksys who actually cares to pursue this issue with me.

    If you know of someone who seems helpful or you are someone from Linksys who wants to be helpful, please contact me here via PM.
  80. Pacif13r

    Pacif13r Network Guru Member

    hmmm I just tried the file that failed on me 100% of the time over half a dozen different distances and today it works !!?? I must admit I have not tried it since the first day I saw it posted by NotLinked @ post no. 140 in this topic.

    I thought I would run a packet sniffer and see if I could identify the sequence but it has just worked every time for around 8 tries.

    Anyone have any idea if a share name change and trying on a different day would affect a change on SMB packets midstream ? I didn't think it sent the share name / dirname or date/time repeatedly during a given file txfr ?
    If when I originally tried it, it was a bit sequence generated by headers etc which combined with the data to cause the reset. Then what are the chances of breaking 6 times in a row previously and now working 8 times in a row ?

    And I wonder how some people seem to only have a smb session reset and others like me have a fast'ishrouter reset where the power light flashes for around 6 secs.

  81. TheRoDent

    TheRoDent Network Guru Member

    There's not much to be 'tested'. It's a random lockup in the ethernet driver. I've simulated it no end and sometimes it'll lockup within the first minute and sometimes after 30 minutes only. Naturally there's something specific that triggers it but it could be completely offset by a simple ping or a random broadcast. An ethernet driver doesn't care about the payload of an ethernet frame. The higher level IP stacks are solid. It's a DMA/Driver related issue.

    The best thing to do is to try and get a reasonably simple testcase setup so that the Linksys helpdesk can try this themselves with a stock router.
  82. dpearcePNG

    dpearcePNG Network Guru Member

    Useful file?

    So do you think my 1,580 byte file would be useful? Who would like to test it on their setup? PM me.
  83. Pacif13r

    Pacif13r Network Guru Member

    I don't follow.. If it's random and irrespective of data than why do certain files trigger it so reliably sometimes. Surely the odds are huge...
  84. dpearcePNG

    dpearcePNG Network Guru Member

    Certainly not random for me

    With the 1,580 byte file I have, it'll crash about 66% of the time. With a 45K file I have, it'll crash 100% of the time.

    Nothing random about 100% of the time.
  85. mnol

    mnol Network Guru Member

    Many problems here too..

    Setup: WRT54G v2.2 (EU) with default firmware, wireless security disabled, wired server (10/100 ethernet) with Filezilla FTP server, wireless desktop with Windows XP Pro (Asus wl-138g 54/G), wireless Apple PowerBook G4 (Airport Extreme 54/G). No programs running that cause disturbing transfers (mail, P2P), only one continues ping to the router and one continues ping to ping.xs4all.nl, to monitor connections.

    When trying to FTP a 100MB+ file from my wired server to my wireless PowerBook i can make my WRT54G v2.2 reboot anytime. Mostly after 2 seconds, sometimes 1 second, sometimes up to 6 seconds, but never later. The same goes for transferring from wired server to wireless desktop. Both transfers would probably be around 2100kbyte/s, if they would last.

    At lower speeds the router also reboots at some point. For example when downloading a 100MB test file from the internet via http to my wireless PowerBook (475-477kbyte/s, 4mbps cable). I've repeated this several times:

    1) reboot after 30MB
    2) reboot after 14MB
    3) reboot after 71MB
    4) success, no reboot
    5) success, no reboot
    6) success, no reboot
    7) reboot after 8MB
    8) no reboot but ethernet crash after 59MB (router web interface & wireless worked normal, but no connection possible from wireless<->lan/wan. after dhcp release / renew in router web interface: no wan ip, only's. had to power cycle router)
    9) reboot after 9MB
    10) success, no reboot

    Transferring from wireless PowerBook to wireless desktop (and vice versa) is not trouble free either. I've managed once to transfer a 700MB file from wireless->wireless (at 1200kbyte/s, using FTP). But after that no more luck:

    1) succes, no reboot
    2) router reboot at +-150mb, transfer auto resumed by FTP client, router reboot at +-170mb, +-240mb, +-250mb, and so on.
    3) router reboot at +-60mb, +-200mb, +-240mb, +-300mb, (cancelled transfer at this point).
    4) router reboot at 6mb, 66mb, 89mb, 338mb (twice!, with only 2 seconds in between), 358mb, 544mb (at this point internet connection was lost, router web interface worked, internet came back after i clicked dhcp release/renew), 589mb, then transfered untill the end without router reboots.

    With WPA/TKIP reboots even occured when browsing webpages with many or large images (news.google.com!). What i call a 'reboot' looks like this: wireless computers get disconnected and WLAN led goes off for about 5 seconds, then the POWER led blinks for about 2 seconds and about 2 seconds later the wireless connections are restored and all is back to normal).

    I bought two WRT54G's this week, not knowing of any issues. All above test results are done with one. But the other is no better. After installing it as ADSL router at my office last friday it has locked up twice and transferring files through it at high speed made it reboot. Now it's not responding since yesterday (< 1 day uptime!). Tomorrow i will swap back the old router.

    Shocking that Linksys still sells this product..
  86. flOrt

    flOrt Guest

    I fixed my WRT54G problem.

    After experiencing the router reboot on high throughput problem, I started following this thread for close to a month to see if a solution would surface.

    None have.

    So, with a few days left on my warranty, I called Linksys and got exactly what I expected. Someone from India, who spoke poor English and had little grasp of the problem I explained, much less any ability to provide a solution. I had to call back.

    The second phone call was almost a clone of the first one. The woman I spoke with had such a small command of English that she was barely able to comprehend the problem. The call dead-ended with her telling to flash my firmware to the latest.

    I did this, and it made things worse. The version of the firmware that shipped with my WRT54G would reboot the WLAN portion of the router under high load, dropping all wireless clients. Once the newest firmware was installed, the router would completely shut down, requiring that I unplug the router.

    This was not something recognizable to me as progress.

    My third phone call to Linksys put me in touch with someone who at least could speak English and comprehend clearly the problem I was experiencing. He was not, however, skilled enough with the product to offer any solutions on his own, preferring instead to place me on hold to confer with his 'resources.'

    That phone call ended with an explanation that this problem has been reported previously to Linksys, and that he would turn it over to the Product Development Group for a fix in the next firmware. When asked when a fix was expected, he said that he did not know when to expect one. I asked what I could do about my transfer problems in the mean time, and he suggested that I simply not attempt to transfer large (>12M) files between LAN and WLAN.

    Being that Linksys' answer in this matter was totally unacceptable, I was left with little recourse. There should be no reason that a vendor should tell you not to use a device for a task for which it was intended.

    My solution was to return my WRT54G to where I pruchased it, and bought a D-Link DI-524. After some initial issues with WPA-PSK, the router works flawlessly, and has more or less the same feature set as the WRT54G.

    I encourage those of you with more patience than I to keep mailing / calling / contacting Linksys about this. And don't just mention your problem. Be sure to describe how dissatisfied you are with their support. The trend of outsourcing entire call centers to groups of people who can't even understand the nature of a given tech support call because of a language factor is unsatisfactory. Encourage Linksys to be more proactive in their handling of this and other problems.

    As an aside, I drove through the city I live in yesterday with my wireless PDA catching SSIDs and noted that about half the 104 AP's I encoutered had the default SSID of 'Linksys'. It's a shame that with that much penetration in the wireless market, that Linksys can't get it together and fix this most pressing problem with their gear.
  87. mnol

    mnol Network Guru Member

    Re: I fixed my WRT54G problem.

    I've sent a lengthy email today describing the problem, linking to this and other long threads and asking when a solution will be released. I also urged them to clearly mention this problem on all WRT54G product webpages or stop selling this version of the product immediately, since it simply is not fit for it's intended purpose.

    Can't tell you how pissed i am about being screwed over like this. They have known for weeks maybe months that the router just doesn't do a single thing when it comes to wireless traffic (mine reboots within 6 seconds of transferring ANY file and locks up spontaniously every day).

    The WRT54G tops all price watch 'most viewed' and shop 'most ordered' lists in it's segment in the Netherlands, so hundreds of people are still buying one right now! If Linksys doesn't respond soon or satisfactory, i might take some action (apart from returning my WRT54G ;)). Any ideas?

    Send email to support@linksys.com and sales@linksys.com and email your regional office!
  88. jsimmons

    jsimmons Network Guru Member

    Linksys Acknowledges a problem

    I started a thread on this topic over at DSLReports.com: http://www.broadbandreports.com/forum/remark,13020161

    Near the end of the thread (dated 4/11), someone posted a response from Linksys support indicating the issue has been escalated.

    We'll see what happens.
  89. Guyfromhe

    Guyfromhe Network Guru Member

    I sucessfully transferred OWC10.MSI from the office 2k3 cd from my wired machine (VIA onboard nic -> d-link switch -> WRT54G { ( ( laptop ) ) } )
    i sent the file 5 times to make sure from win2k to win2k via windows file sharing...
    i'm using a v2.0 router running tanguy's wifibox. I have not been able to reprodouce any of these symptoms on either of my wrts.
    the router is in the other room but I can grab the serail numbers if anyone thinks that would be helpful...
  90. droopy

    droopy Network Guru Member

    Same reboot issues here with v2.2. After spending countless hours trying to get a grip of the problem and flashing a gazillion firmware versions, i returned it. I'm getting the strange feeling that the new unit will behave exactly the same, and if this is the case Linksys will be out of my shopping list for good. And a shame that is, because some of the products are very good (i own lots of WAP54G, all working outdoors with no hiccups).
  91. mnol

    mnol Network Guru Member

    Re: Linksys Acknowledges a problem

    Same reply here, from support@linksys.com.

    "Dear Valued Linksys Customer,

    Thank you for contacting Linksys Support, we apologize for any inconvenience.

    This concern has already been forwarded to upper management. Again I apologize for any inconvenience this has cause you.

    Hope this helps."

    They did not answer any of my questions and they didn't even mention a solution coming up. Just 'yeah, we know'. Pretty rude..

    No answer from support.nl@linksys.com or sales@linksys.com yet.
  92. Skate

    Skate Guest

    So if I understand all of this I will probably be OK if I have a WRT54G original version and are using the latest firmware from Linksys?
  93. Crazylegs

    Crazylegs Network Guru Member

    Wow, am I happy I found you guys!

    Bought a WRT54G on Feb-8-2005. Worked fine with my 2 ethernet XP computers and Toshiba cable modem. Transfers files and surfs the web virtually trouble free.

    Bought a notebook Apr-10-2005. Internet connection works fine on notebook. Tried DLing all my MP3's from one of the desktops to the notebooks... Kept losing connection. Sometimes sooner, sometimes later... You know the drill.

    Router is V2.2
    Firmware is latest DL.

    Called Linksys today. Oblivious to the problem. Asking me about the basics (how far from router, etc).

    This baby is going back. Can anyone tell me what routers seem to be working more reliably?

  94. TheDruid

    TheDruid Guest

    Same issue here

    Same issue here.
    I noticed that changing security options changes which file will fail. I have a folder with 50 largish (1MB) JPG. Given a set of security settings it will always fail on the same file.
    When it fails the wireless disconnects. Sometimes my downloads (off the internet) from a wired computer also stop until I power off the thing.

    Called support and I had to insist that the wireless connection was bad and not my file sharing, since I can copy when I am connect via ethernet and not wireless. Also contacted by e-mail and got useless response. I am sending a link to this forum to The Inquirer http://www.theinquirer.net/

    I am also returning the router to New Egg (If they let me) and I already ordered a D-Link.

    Thanks to

    1. A connection wizard that never worked and never had any hope of working
    2. Lockups
    3. Useless support

    Linksys will not see my money anymore.
  95. TheKing

    TheKing Guest

    Guys, don't expect Linksys to release a new firmware to fix the problem. THIS IS NOT A FIRMWARE BUG. IT'S THE HARDWARE. How do I know? I live in Hong Kong and I also bought a WRT54G v2.2. I've the exact same disconnection problem on transferring large file between a wireless laptop & wired desktop. I took the router back to Linksys distributor. The tech staff told me there are many others having the same problem. He told me it's the hardware problem and he exchanged another v2.2 to me. I tested the new one and transferred 10GB of data w/o a single issue.

    If you are having problem, send it back for a replacement. However, there are chances that you may get a broken one again. Insist Linksys to test out a replacement router before sending it to you. Good luck!
  96. -mb-

    -mb- Network Guru Member

    As scary as this sounds, it makes sense. I'm running a v2.2 here under "full load" and it has never hiccuped. If this is in fact true, suggested configuration changes and and slow in coming alledged firmware fixes will be in-effective . Eventually, in frustration, the affected users will replace their devices. I experienced a similar scenario years ago with a BEFSR41 and swore to never by another Linksys product. I did and got lucky I guess!
  97. barney34

    barney34 Network Guru Member

    Avoid purchasing v2.2

    I have a 2.2 and want to purchase another WRT54G or gs but avoid v2.2. How do I know from the box that its not a 2.2 and what stores would have older versions. Does 3.0 have the same bug? I got the orginal from bestbuy so maybe walmart?
  98. Crazylegs

    Crazylegs Network Guru Member

    More Linksys stuff

    Spoke with Linksys for a couple hours today. They had me disable firewalls, change MTU to Manual/1500, Frag threshold to 2304, RTS threshold to 2304, wireless encryption to 64, and then wanted to make more changes but I gave up. (None of this stuff worked).

    However, I have a question regarding my router that may be related to this...

    When I set my notebook near my router I get full signal, as expected. Looks great. But the SPEED can still bounce around anywhere from 54M to as low as 24M. This certainly happens more when doing these large transfers, (I thend to sit there watching it waiting for it to crap out) but I at least occasionally see it at other times. I can check more to see how much, how often.

    But before I start worrying about this, can someone tell me that this is normal, not a problem, etc? Or related to the crap out problem?

  99. jsimmons

    jsimmons Network Guru Member

    Re: More Linksys stuff

    When I'm pushing large file copies from wired to wireless devices, my link speed does fluctuate between 54 and 36 Mbps, even though there is no apparent fluctuation in signal quality. Is this normal? It seems to be for me. Should it do this? I would hope not.

    But the only time I really have a problem is when I set my encryption to AES. Using AES, my transfers start a t 54, then continuously drop until it levels off at 1 Mbps. Eventually, I lose connection. As long as I use TKIP or WEP, I don't have this problem.
  100. Not-me

    Not-me Guest

    I'm from Singapore. In the last 3 weeks, I have replaced my WRT54G v2.2 thrice.
    The first set - blinking power LED after 1 day.
    The 2nd set - soft reboot every day
    The 3rd set - Transfer from Wired to Wireless LAN would trigger reboot.

    Tried stock Linksys firmware and hyperwrt without much help.

    Finally gave up, paid the difference for the WRT54GX (MIMO). Have not had trouble since then. Everything works fine. Uptime as of now is 8 days troublefree.

    There is definitely some hardware problem with v2.2.

Share This Page