1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54GS Internet Gateway randomly disappears

Discussion in 'Cisco/Linksys Wireless Routers' started by Garindan, May 5, 2005.


Does your Linksys Router randomly show the Internet Gateway?

  1. Yes, it is always disappearing

  2. No, it is constantly there

  1. Garindan

    Garindan Network Guru Member

    Hi everyone, this is my first post. :D

    I recently purchased my first piece of Linksys hardware, a WRT54GS v1.1, and have had problems with the Upnp. Everything is enabled, on the router, in windows xp, all components of XP are installed, both the services needed start with windows, i've looked into it and checked everything. But.... it seems to only randomly show the internet gateway, i would say about 3 out of 5 times i start XP it shows the gateway, and the other 2 times it won't b there. Also i have noticed a couple of times it disappearing whilst windows was running, and a couple of times it appearing when it wasn't there at startup :(. Is it always going to be this intermitent or is something wrong?

    Also i don't know if everyone has this but with the Upnp User Interface installed in XP its supposed to show the router in My Network Places, but it never has, not once. Is that the same with all Linksys? because that's a shame, i have seen DLink and Belkin devices (the other two i thought about getting) both show there as upnp routers, etc.

    Does anybody have any idea's?

    Thanks in advance for your help.
  2. Garindan

    Garindan Network Guru Member

    Doesn't anybody have an idea about this then??? :'( Pleaaaassssseeeee
  3. mstombs

    mstombs Network Guru Member

    Yes, I have noticed this.

    At the moment my wrt54GS shows up as as Internet Gateway, but not in the my network places.

    I had a similar problem with a BEFSR41 - but had to disable UPNP as it broke LAN games.

    I've always assumed this was a problem with windows/software firewalls?
  4. freaky_00

    freaky_00 Network Guru Member

    This is happening to me a lot!!! Right now there is no Internet Gateway. Sometimes it does, sometimes it doesn't appear. I have set it to show up in the tray but I wish it would stay there. Hope someone finds an answer to it!!!
  5. Garindan

    Garindan Network Guru Member

    Well i'm pleased i'm not the only one :D

    I did speak to someone at Linksys about it and they were entirely unhelpful, and said it had not been reported before??? Maybe if everyone went to them and reported it they might take a bit more notice?

    I understand how it could be a windows problem, and i know upnp is still sketchy, but the part i dont like is that mine has NEVER shown up in My Network Places, whereas i've seen DLink and Belkin routers show up there as 'Upnp Enabled Router'. :(

    Starting to think i should have bought one of those :(

    Anyone else?

    Edit: Actually, just out of interest does everyone want to say what router and version they are using, and maybe firmware too? How about windows?

    Mine is:-
    WRT54GS v1.1
    Official Firmware Version 3.37.2
    Windows XP with Service Pack 2
    I have all components installed and i have both the upnp services needed running at windows startup :(
  6. freaky_00

    freaky_00 Network Guru Member

    WRT54GS v1.1
    Official Firmware v 3.37.6 US Code (had 3.37.2 before but had disconnecting problems)
    Win XP SP1

    Could you go more in detail about that? What have you done? I have not known that UPnP is needed for this to work. Do you have some kind of tutorial which I could use?

    I think I have a possible answer. In the Windows help it says possible reasons not to show up could be if you boot your the ics host (router) is not connected to the internet. My DSL modem sometimes needs some time to connect because I have an extension cord with a switch to turn off. So every time I start the PC it has to get some info before connecting to the internet.
  7. Garindan

    Garindan Network Guru Member

    Yeah if you go to 'Network Connections' then to the Advanced menu at the top and then select Optional Networking Components. In there go to networking services. 'Internet Gateway Device Discovery and Control Client' is the part of xp that detects gateways. As far as i understand upnp is needed for xp to detect the router as a gateway in the first place.

    Below that is another option which is usually unchecked - 'UPnP User Interface'. That component lets you check UPnP devices in 'My Network Places' although mine never works :(

    Then go to run, and enter services.msc, in there check for 'SSDP Discovery Service' and 'Universal Plug and Play Device Host', they're the services windows uses for UPnP, i have both mine set to automatic.

    As far as the reason being the modem, its possible but doubtful as mine is always on and always connected and i get the same problem :(

    My router hasn't been detected as UPnP for the last two days now :( :( :( Starting to get annoying!!!
  8. Jeffrccar

    Jeffrccar Network Guru Member

    I got a fix just disable it.
  9. Garindan

    Garindan Network Guru Member

    Yes....a very helpful post!!! Why didn't i think of that!
  10. mstombs

    mstombs Network Guru Member

    WRT54GS v1.1

    Currently running v4.50.5 US beta firmware, same behaviour before as v3.37.2 (EU)
    Windows XP PRO SP2 or (XP HOME SP2)

    Internet Gateway was there just after booting, but has now disappeared.
  11. Garindan

    Garindan Network Guru Member

    K well i got some good news, hopefully for you too. I tested out my UPnP using the Mark Gillespie test... http://www.mgillespie.plus.com/ and it failed the last 2 tests, out of 8. So i read the pages related to tests 7 and 8 and it says

    "Windows Problems

    You have installed another firewall in addition to the Windows firewall, and it's blocking the UPnP messages. (create a rule for UDP 1900 and TCP 2869)
    You have installed some other software that is interfering somehow with the UPnP messages. Norton Internet Security is a good example here. Many people still fail these tests, and it's down to the Norton/Symantec firewall. Bottom line: Remove it, or live without UPnP."

    So i looked into it and low and behold, Norton has two 'UPnP Block' rules!!! It blocks UDP port 1900 and a TCP port (5000) tho i'm not sure the second one is as important? So i changed both those rules to 'Permit', and low and behold, its there and hasnt disappeared once so far! Touch wood!!!!!!!!!!!!!!! lol. Bl**dy norton! its the cause of so many problems!

    So does everybody else have norton? Or some other software firewall? If so the first thing to do is check thoroughly to see its not blocking the required ports. Hope that helps.
  12. Partizan

    Partizan Network Guru Member

    I tried the Mark Gillespie test too:

    TEST 1 - Operating System Support - PASSED
    TEST 2 - SSDP Service Running Check - PASSED
    TEST 3 - SSDP Service Automatic Check - FAILED
    TEST 4 - UPnPHost Service Running Check - PASSED
    TEST 5 - UPnPHost Service Automatic Check - PASSED
    TEST 6 - UPnP Framework Firewall Exception Check - PASSED
    TEST 7 - Adapter #0 - - PASSED
    TEST 8 - Get External IP Address (Result: xx.xxx.xx.xxx) - PASSED

    Any idea how to fix it?


    I just put the SSDP discovery service from manual to auto :)

    Regards, Partizan
  13. mstombs

    mstombs Network Guru Member

    I used the Gillespie test too, Tests 7 and 8 fail.

    The only way to get I know to get round my (free) Ez Armor firewall is to uninstall it - I think its based on an old zonealarm with different UI.

    So might as well disable UPNP here again...
  14. freaky_00

    freaky_00 Network Guru Member

    I have Norton and these UPnP blocking rules are enabled but right now I see the Internetgateway. With Norton enabled I fail only test 6 (TEST 6 - UPnP Framework Firewall Exception Check FAILED). Since I only have Service Pack 1 installed I can't change the settings because I don't have the "Security Center". Right now I am trying to find info on how to activate UPnP Framework without installing SP2.


    I updated to SP2. Internetgateway is visible. All tests passed. I will tell you if it disappears again!!!
  15. Garindan

    Garindan Network Guru Member

    Yeah thats right, u have to have sp2 for full UPnP support.

Share This Page