1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54GS V4, Very slow internet :( Help me please :)!

Discussion in 'DD-WRT Firmware' started by Stormz, Mar 8, 2006.

  1. Stormz

    Stormz Network Guru Member

    Hello Guys,

    I have had many routers in this past year including the WRT54GS v4, I have ended up returning them and testing other routers to see which one is best. D-Link DI-634M was one of the best out of the lot, I never had any problems with it until a few days ago, 2 of the computers in our house couldnt detect the wireless network. The result was me buying the WRT54GS v4 again, its the only choice I had, there are no v2's in "PCWorld" and yes, PCWorld sucks.

    I am using the firmware "dd-wrt[1].v23_wrt54gsv4"
    As soon as I got the router I installed this firmware, it seems to have the most options. After a while of being connected, the internet connection is really slow. When I go to the routers page "192.168.1.1" it takes like 5 minutes to load, when the page loads, the page loads white with all the data of the original firmwares page. I go to the Administrator page and reboot the router which seems to fix the problem. The problem comes back in 5 minutes. :) I then have to turn off the router and modem, turn my computer off, turn the router and modem on and power up my computer to get the internet working properly. I hate the linksys software to connect to the net, it wont connect without it, I cannot use windows software. Most internet pages take ages to load, including this one.

    The only setting I changed in the router was the mac filter, I put computer 1 & 2's mac addresses to only be allowed by the router, thats the only settings I changed with this firmware.

    I just want to be able to use a router where the internet is working properly and I can use my p2p without the worry of my connection dropping and lagging :)

    I am not complaining about the firmware, its free and I am greatful, I do have a problem and need help, so please, help me! I cant handle this router problem anymore :_(

    P:S

    My half open tcpip connection limit is 100 so that is not the problem, its definantly the router.

    You can see I joined in August 08 2005, this was around the time I got the same linksys router I have now, I have been having so many problems with routers :) I can use a computer without problems, I just dont have a clue whats happening, everything should be working perfectly.
     
  2. Stormz

    Stormz Network Guru Member

    :cry:
     
  3. NateHoy

    NateHoy Network Guru Member

    Did you erase your NVRAM and redo your settings to make sure you don't simply have some oddball setting left over from the stock firmware?

    Also, you MAY want to try HyperWRT Thibor 14. Overall performance seems (according to comments I have seen) to be somewhat faster in the HyperWRT builds than the DD-WRT builds. Probably a result of a thinner feature set not taking up so much processor and memory. Just load up Thibor 14, do the factory reset with erase NVRAM, and set it up from there.

    It's free, too, and you can always flash back to DD-WRT.
     
  4. Stormz

    Stormz Network Guru Member

    I am going to the Thibor 14 firmware, does the erase NVRAM mean the reset button on the back for 30 seconds?

    I will let you know how I go!
     
  5. ofbarea

    ofbarea Network Guru Member

    If you have not installed Thibor 14 yet, read the this guide: The "Right Way" to Flash Your WRT54G/GL/GS and make sure you cleanup the NVRAM as recomended.

    After you go to Thibor in Admin screen you will find and option to erase the NVRAM. This is a must also.
     
  6. Crusader397

    Crusader397 Guest

    Hi,

    I got the exact same problem with my WRT54GS V4 with DD-WRT v23 SP1 (20-03-06). Internet and router control panel become waaaayyy to slow everytime I start Azureus on my computer.

    The azureus port on the router has been forward to my computer...

    Thanks for any help. And BTW is HyperWRT compatible with the GSv4, since on the webpage it's written that only V1, V1.1, V2
    are supported...
     
  7. DeLaRafi

    DeLaRafi Network Guru Member

    wait the minute u guys. thibor and dd can mix?? or thibor is just another firmware??
    anyway... try to unchek the enable ipv6 options.. when i do this. my ddwrt seem to be smooth .. b4 this crawlig like err snail. :eek:
     
  8. trey504

    trey504 Network Guru Member

    look for an option to allow more open ports that will fix the problem im not sure where it is im running openwrt
     
  9. unggy

    unggy LI Guru Member

    anyone manage to fix the slow internet problem? im having similar problem at the moment.
     
  10. Toxic

    Toxic Administrator Staff Member

    if your running any P2P file sharing utility you may encounter slow browsing since usually the p2p utility is taking up ALL your upload bandwidth. you will need to make sue there is minimum connections to your PC in the p2p util and alos setup QoS to make sure the p2p util has the lowest priority.
     
  11. kdubbz

    kdubbz Network Guru Member

    I also seem to be having this slow router problem also on my WRT54G V4 router with dd-wrt v23. I think I fixed the problem by going to the administration panel and going down to the IP Filter Settings and setting the Maximum ports to 4096, the TCP Timeouts to 90 or 120, UDP Timeout to 90 or 120. This seems to help out a lot. I am not running P2P Software thru the router because simply it cant handle it.
     

Share This Page