1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54GS V5 Slow Speeds

Discussion in 'Cisco/Linksys Wireless Routers' started by tttttt, Jan 1, 2007.

  1. tttttt

    tttttt LI Guru Member

    hey i just bought a wrt54gs about 3 weeks ago and after a week my internet has started to go really slow. but for like 30 minutes in a day it would go at regular speed but then for the rest of the day it would go slow. I have 2 wired computers and one wireless and all 3 go slow anyone got any suggestions on what to do?
  2. ka9yhd

    ka9yhd LI Guru Member

    What type of connection do you have? Cable or DSL?

    A friend has Comcast cable here in the Chicago area and when all of the kids come home from school, he does not download anything because it is so slow. After all of the kids go to bed and are not online then it speeds up again.
  3. tttttt

    tttttt LI Guru Member

    i have cable and my internet is always slow the whole day
  4. Toxic

    Toxic Administrator Staff Member

    are you using p2p software? what is your MTU set at on the WRT?
  5. tttttt

    tttttt LI Guru Member

    nope i am not using any p2p softwares

    and my MTU is auto
  6. ka9yhd

    ka9yhd LI Guru Member

    Have you tried connecting the computer directly to the cable modem to check if the speed stays the same or slows down at some point?
  7. BlackGoku03

    BlackGoku03 LI Guru Member

    I have the same router... and although speakeasy says my connection is the same (607KB/s) as when I had the older compact wireless Linksys, the WRT54GS cuts my download speeds by 2/3.

    I can't download anything off my FTP at more than 120~Kb/s when I used to get up to 550KB/s.

    My point is, my downloads are slow. Bit torrent, P2P, direct http downloads, and FTP downloads are just slow.

    When I connect the modem to my computer, it isn't slow, but going through the router, it is. So I know it's the router. Please help... thank you in advance.

    My MTU is set to 1500.
  8. docinthebox

    docinthebox LI Guru Member

    What firmware are you using - stock or third-party? Which version?

    When you said you had the same router, you mean you also have v5 of the WRT54GS, right?
  9. BlackGoku03

    BlackGoku03 LI Guru Member

    It seems my downloads are back to normal. It's weird. The first day I had this router, downloads were slow and painful. Now, even when all 4 comps are connected to the router, my downloads are unnefected. It's like it fixed itself. :/
  10. rakeshjmd

    rakeshjmd LI Guru Member

    reset router for 45 sec & power cycle router => upgrade firmware reset & then reconfigure
  11. kklier

    kklier Guest

    I've recently noticed the same thing.

    Directly connected to my TWC Surfboard 5102 I was getting just under 8Mbs/512kbs, with my wrt54gs v3 connected, wired I get half the speed, wireless I got 1/10th the speed when direct connected to the cable modem. I have been using DD-WRT v23 for a while, but have never noticed this problem until I upgraded to "turbo" with TW. Also, I did have the Surfboard 4xxx. TWC says there is no problem here.

    Is this a problem with the 3rd party firmware or with the router? Is there anyway to test this?

Share This Page