1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

wrt54gs & wmp54gs - slow file copy, but fast stream?

Discussion in 'Cisco/Linksys Wireless Routers' started by b_u_z, Apr 13, 2005.

  1. b_u_z

    b_u_z Network Guru Member

    Hi All,

    I have a WRT54GS and two desktop machines (XP SP2, using WZC) with WMP54GS nics.

    Internet works essentially fine. BUT - when I try to copy large video files between the two WLAN machines I can't get them to move the data above about 2Mbps ... yet if I actually play the same files from across the network, it streams in at a steady 8Mbps!

    Currently, I have everything set to work at 54. I turned afterburner off as i noticed the speed would keep switching between 125 and 54, despite an excellent signal. Also am using HyperWRT ... tried various radio power settings, with no visible effect.

    I can't see anything wrong with my IP setup or the sharing/security configs of the clients. same settings work fine for wired clients.

    seems really weird to me...i'm out of ideas...any thoughts?
     
  2. mstombs

    mstombs Network Guru Member

    I guess you mean MBytes per second?

    When you are streaming does the software report the uncompressed bit rate?

    You would expect less than half the throughput with WLAN to WLAN as they share the same notional 54Mbps(+35% speedbooster) bandwidth.

    Updated drivers for a WPC54GS (in my case) drop the fictional 125Mbps mode so you could try the recently released new drivers for the WMP54GS.

    PS what version of the WRT54GS - do you also experience the disconnect problem with v1.1 as others here?
     
  3. b_u_z

    b_u_z Network Guru Member

    Nope - I mean 2 Mega BITS per second.
    0.25 megbytes per second

    :(

    I am using AnalogX's NetStat Live to measure Nic throughput. with both file copying and file streaming.

    http://www.analogx.com/contents/download/network/nsl.htm

    Real world throughput vs. advertising: On a 54MBit wifi, i'd hope to see something in the 20-30MBit range...is that a reasonable expectation?

    Updating the WMP54GS drivers: I'll try file transfers between the two clients in Ad Hoc/P2P mode, cutting the WRT out of the equation. If the files copy fine that way, would you still recommend messing with the nics?.

    WRT54GS HW Version: I'll check the serial# tonight, I don't remember if it's 1.0 or 1.1 ... i doubt very much it's anything newer.

    The Typical WRT Dropouts: I have experienced the disconnect probs like other people. I probably still do, but I tend to cancel the transfers because of the slow rate...i'll try letting one go longer to see if it still drops the connection.
     
  4. b_u_z

    b_u_z Network Guru Member

    My router hardware version = WRT54GS v1.0 = ADM6996L Chip.

    I went to ad hoc mode between the two clients with WMP54GS nics, I can do the file copy at 27Mbps!

    Returned to infrastructure mode, copying via the router, back to 2Mbit. Definitely a router issue in my eyes.

    Fwiw - I updated the nic drivers to the latest from Linksys (4/6/2005?), and am letting the linksys util manage the connections, rather than WZC.

    Util shows 7 bars for both strength and quality. Speed incredibly unstable, varies from 1 Mbps to 18 Mbps.

    Noise Level -90dbm
    Signal Strength -60dbm

    Interestingly, when in ad hoc mode, util showed only 3 bars for strength and quality, but a steady speed of 54, and of course i could transfer files nice and fast.

    WRT54GS = POS?

    lol, am i missing something?
     
  5. jagboy

    jagboy Network Guru Member

    did you try different wireless adapters. i worked with the linksys wireless adapters and they are a pirce of crap. try diferent adpaters and maybe try another router in the place of the WRT54G. just to rule out the wrt for sure. did you try restting the thing. what firmware is it running.

    sorry could not be anymore help.

    -jag
     
  6. b_u_z

    b_u_z Network Guru Member

    Hi Jagboy, thanks for taking some time to check this a little.

    No, I didn't try different wireless adapters ... because, when I connect the two WMP54GS's directly, without going via the WRT, speeds are really good. Put the WRT back in between, speeds are really bad. Do you still think it's worth messing with alternate PCI cards? I feel like this must in some way be related to the high-throughput disconnect problem.

    I have used all the Official Linksys firmwares and I'm currently running HyperWRT 2.1b1. My hardware is WRT54GS v1.0 so I haven't tried installing the 4.x beta, I read it's only good for v1.1 and higher.

    I didn't do a reset to factory defaults, at all, ever.
    I guess I'll try it tonight and see. Just hold it in for 30sec?

    btw - does anyone have any comment on my signal/noise figures? I don't know what's normal and can't judge if it's ok or not..
     
  7. jagboy

    jagboy Network Guru Member

    then you should do one. that should be the first thing that you should have done...resetting the router.
    and yes hold it down for 30 sec. and if that does not work then try the new beta firmware
     
  8. b_u_z

    b_u_z Network Guru Member

    ok - I reset to factory defaults, but problem remains...actually, it's worse.

    I used to be able to watch a video file at 8Mbps over the wifi (wifi client and server) but it now drops out on me after about 1min, I don't lose the connection, just the file stops transferring, it hangs.

    And trying to simply copy the file (14GB) starts out about 12Mbps but eventually dropping to around 24Kbps after about 15sec.

    The nic shows excellent signal strength and 54Mbit connection the whole time.

    I'm a bit afraid of the beta fw from gandalf's website, I am not convinced it will work ok on v1.0 hardware. I suppose I'll go ask in that thread.
     
  9. jagboy

    jagboy Network Guru Member

    yeah i think that that would be a good idead of asking of the firmware wil work on your router
     

Share This Page