1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54Gv1 won't obtain IP!

Discussion in 'Cisco/Linksys Wireless Routers' started by AlphaQ, May 7, 2005.

  1. AlphaQ

    AlphaQ Network Guru Member

    So this morning I tried to flash with Sveasoft Alchemy 1.0 today. Everything flashed well and went fine. I log onto my router via and all is good. Then I try to use the internet and it doesn't work. So I was confused and then I realized that it wouldn't automatically obtain the DHCP. I thought my internet might be down but if I plug in my DSL directly to my laptop it works fine.

    Then I flashed back to the newest Linksys firmware thinking it would fix it, but it still doesn't obtain DHCP. I tried soft reset and hard reset but still doesn't work. Right now it has the default Linksys firmware and is on factory default settings. What could be the problem?

    Everything works fine with the router, it pings, I can connect via WAN and LAN and etc., but it just won't obtain DHCP therefore not allowing me to go on the internet using the router. Does this mean it is bricked? I don't know what the definition of bricked means. Help me!
  2. Toxic

    Toxic Administrator Staff Member

    try resetting the router. press reset button for 30 seconds
  3. AlphaQ

    AlphaQ Network Guru Member

    I did. I also tried holding reset for 5 seconds and letting go for 5 times (Linksys support said to do this). After a series of resets and stuff now when I have my router on it only shows Power and the red Diag LEDs. If I plug anything into port 1-4 or the Internet port, no LEDs work. Does this mean its bricked? I can't ping or access the router anymore.

    Am I still covered by warrenty since I tried to use Alchemy firmware? I don't have any receipts for this router though :( Maybe I should go to BestBuy and get a new one and return the old one in the new box.
  4. spacelord

    spacelord Network Guru Member

    I seem to be having the same issue with my WRT54G v2.2, using Alchemy v1.0

    Here are the facts:
    It won't get an IP via DHCP when I Connect directly to my cable modem.
    If I connect my computer directly to my cable modem I can get an IP via DHCP.
    If I connect my Sunrocket gizmo directly to my cable modem, the gizmo gets the IP just fine. Then when i connect my WRT54G to the Gizmo, it gets an address perfectly fine from the Gizmo DHCP server.

    summary, the WRT54G will not get DHCP from cable modem, but can get from other sources. Other devices can get DHCP from the cable modem just fine.
  5. Guyfromhe

    Guyfromhe Network Guru Member

    this happened to my v1.0 router as well, red diag no response from any of the ethernet ports.. I think your pretty much screwed you can try a couple of the fixes in the unbricking guide but it's different for the v1.0s... you can try the bestbuy trick but they usually pull the router out and look at it to make sure it's not snapped in half and they may notice that it has almost 3 times as many lights on it than the picture on the box shows...

    Linksys has claimed on chats that people have posted that they still warrant routers that were using custom firmware (i wouldn't go out of my way to mention it to them or anything) however if it's a 1.0 it's probably not covered by warantee anymore but you can give it a shot... you could also do like me and rip out it's minipci card and throw the router out and get a new one :)

Share This Page