1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54Gv1 won't obtain IP!

Discussion in 'Networking Issues' started by AlphaQ, May 7, 2005.

  1. AlphaQ

    AlphaQ Network Guru Member

    So this morning I tried to flash with Sveasoft Alchemy 1.0 today. Everything flashed well and went fine. I log onto my router via http://192.168.1.1 and all is good. Then I try to use the internet and it doesn't work. So I was confused and then I realized that it wouldn't automatically obtain the DHCP. I thought my internet might be down but if I plug in my DSL directly to my laptop it works fine.

    Then I flashed back to the newest Linksys firmware thinking it would fix it, but it still doesn't obtain DHCP. I tried soft reset and hard reset but still doesn't work. Right now it has the default Linksys firmware and is on factory default settings. What could be the problem?

    Everything works fine with the router, it pings, I can connect via WAN and LAN and etc., but it just won't obtain DHCP therefore not allowing me to go on the internet using the router. Does this mean it is bricked? I don't know what the definition of bricked means. Help me!
     
  2. cromrell

    cromrell Network Guru Member

    DHCP problem

    Have you tried assigning a static address to your router?

    connect the DSL up to you your PC & check the DHCP settings...
    Then assign these same settings to your linksys, and see if you are still unable to connect...

    Chris
     
  3. spacelord

    spacelord Network Guru Member

    Did you ever figure this out? I have a similar issue, where I can hook my PC or my Sunrocket Gizmo directly to my Cable Modem and they get an address via DHCP just fine, but if I hook my WRT54G v2.2 with Alchemy 1.0 directly to the modem it will not get an address via DHCP no matter what. I have cycled power on everything, reset everything.. in every order I could think of.

    The funny thing is that the WRT54G gets the DHCP from the VOIP Gizmo just fine. really strange.

    I guess my router doesn't like talking to my LINKSYS modem, or what it has to say.

    any ideas?
     
  4. cr8zy07

    cr8zy07 Network Guru Member

    well...what is ur IP on ur computer?? bc that should be changed to the the same network as the router...bc u cant have the router to have a 192.168.1.xx ip when ur DSL modem has EX: 192.168.8.xx they arent on the same net work then...u have to make sure that the IP address starts off with the same thing... as in ur router and the DSL modem and ur computers IP should ALL start with 192.168.8.xx bc then puts them all on the same network...well i hope this works for u
    IM or email me if u have ne more questions
     

Share This Page