1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54Gv4 4.20.7

Discussion in 'General Discussion' started by stilnox, May 1, 2006.

  1. stilnox

    stilnox LI Guru Member

    Hi There,

    Recently have bought a WRT54Gv4 router.

    I have tried to upgrade to 3rd party firmware. From DD-WRT, DD-WRT Mini, HyperWRT, OpenWRT, EWRT, Seavsoft Alchemy and Talisman.

    So far only DD-WRT, Mini and EWRT works. They rest cause the WRT54G to brick.

    Can anyone please advise which is the best firmware to use with WRT54Gv4. Have anyone tried HyperWRT, Alchemy and Talisman on WRT54Gv4.0?

    Also does anyone have the offical linksys firmware for WRT54Gv4 4.20.6?

    Thanks in advance...
     
  2. Toxic

    Toxic Administrator Staff Member

    Alchemy may work but i dont think it supports v4. Talisman should work, HyperWRT ( http://www.thibor.co.uk ) definately works.

    if v4.20.6 is official then it will be available at linksys.com

    what exactly are your needs of the firmware?

    HyperWRT Thibor14 or DDWRT v23 SP1 should meet most requirements.
     
  3. svg1

    svg1 Network Guru Member

    I have 4.20.6 which is the previous official release & also 2 newer beta versions . 4.20.8 & 4.30.2

    http://firmware.arcticgateway.org/Linksys/WRT54G/
     
  4. stilnox

    stilnox LI Guru Member

    Hi Toxic,

    I have tried HyperWRT and Talisman but does not work.

    Do u have to link to DL the Talisman? Which version should i use?

    Is there any step that i have to take note.. What i did the last time was updatre to MINI, waited till router reboot. Waited more than 5 min, restore factory defaults, on off router, waited again than upgrade to HYPERWRT/Talisman but the router got brick instead.

    Hi SVG1,

    Got Linksys to email me the older version. Thanks..
     
  5. figgs

    figgs LI Guru Member

    Talisman is a pay-for firmware, you can get "Freeman," the TheIndividual's Talisman freeware (same functionality with no MAC limit, he hates Sveasoft... see his page):
    http://wrt54g.thermoman.de/

    I thought that OpenWrt worked with the v4... IIRC they didn't switch to VxWorks until v5??? Or am I mistaken... hrm.
     
  6. Thibor

    Thibor Super Moderator Staff Member Member

    Hyperwrt definitely works, i have tested it going from stock firmware directly to Hyperwrt using v4's
     
  7. stilnox

    stilnox LI Guru Member

    Hmmm.. Thou that Talisman and freeman was the same.. Apologise for the wrong info.. I tried on freesman but failed.. trying the HYPER now..
     
  8. stilnox

    stilnox LI Guru Member

    Thank you everyone for you help.. manage to get Hyper running...
     

Share This Page