1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54GX - Upload Issues

Discussion in 'Cisco/Linksys Wireless Routers' started by GSRacing, May 15, 2005.

  1. GSRacing

    GSRacing Network Guru Member

    Hey guys,

    Hope someone can help me out here with an issue I am having with my new WRT54GX router. I am trying to upload some files to my website server and the files start off real slow and then go to nothing on speed. When I connect my old router or plug my DSL modem direct into the PC the speeds are fast as expected. Downloads on the WRT54GX are right on target but I am getting extremely slow upload speeds with it. I have tried both FlashFXP and WSFTP. Any recommendations on a fix would be greatly appreciated.

    Thanks
     
  2. RoundSparrow

    RoundSparrow Network Guru Member

    I can confirm this and related problem. The WRT54GX has some kind of mtu/fragmentation problem in the NAT. I've had all kinds of similar issues.

    Rebooting it sometimes helps, but not for very long.
     
  3. murph206

    murph206 Network Guru Member

    I am also getting VERY SLOW UPLOAD SPEEDS. Even when I hard wire to the router. No problem when I hard wire to my modem.

    I updated the firm ware (always linksys's suggestion). That didn't help the problem.

    Another crappy Linksys product!
     
  4. jaegerm

    jaegerm Network Guru Member

    I am having the same problem with uploading via FTP. I have switched back to my WRT54G and had no problems uploading. I use the GX for everything because it is a great product but when it comes to uploading I either RDP to a different computer and network or switch routers, both of which seem to work fine. I have had little success with Linksys tech support. I guess I am just waiting for a new firmware update.
     
  5. jaegerm

    jaegerm Network Guru Member

    I just got a reply back from linksys for my FTP problems. They suggested to change the MTU settings on the basic setup page for the router to Manual and change the value to 1382, 1400, 1450, 1492, 1024, or 1464. I tried each one and it worked on 1492 for a short while but now everything has bogged down again. I am still working with tech support to find a solution.
     

Share This Page