1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRT54GX4 Terrible range & dropped connections

Discussion in 'Cisco/Linksys Wireless Routers' started by KingRocky, Mar 12, 2007.

  1. KingRocky

    KingRocky LI Guru Member


    Can someone please tell me why I can't get connected with this thing? Here's what I've got:

    2 PC laptops
    1 Mac Mini desktop
    WRT54GX4 Firmware version 1.00.19

    The router is being used as an access point ONLY. There's already a DHCP server set up in the office. There are at least 6 other wireless networks in the area. I've changed channels on multiple occasions, and moved the unit to different locations in the building. Moving the unit less than a foot, or rotating it will DRASTICALLY affect its wireless performance. Wall-mounting the unit seems to actually make things WORSE. There are NO other networks on my channel (currently set to 10). There are NO cordless phones in the office. Encryption is WPA-TKIP. All wireless settings are set to DEFAULT, except the "network density," which I set to "high."

    As long as everything is in the same room, it works fine. Moving ONE ROOM AWAY causes dropped connections, or an inability to get an IP address. The building I'm in uses standard wood framing with sheetrock walls, and there are windows between each room.

    With a plain-jane WRT54G, I get EXCELLENT range and no drop-outs. Unfortunately, that router had to be moved to another location and converted to a wireless bridge. With this GX4 piece of s**t, I get terrible range.

    Something else strange: My Mac can connect to this router all day long with no problem. The PC laptops can't seem even GET a connection with this thing.

    I'm to the point of reaching for my trusty sledgehammer, smashing this thing to bits and mailing the pieces back to Linksys. I have NEVER had this much trouble with a wireless router--even my piece-o-crap DLink that I use at home is better than this thing.

    Can someone please tell me what I'm doing wrong, here? ANY help that anyone can provide will be greatly appreciated.
  2. howardp6

    howardp6 Network Guru Member

    What wireless NICs are you using, to get maximum range and performance you have to use a WPC54GX4 or a WMP54GX4, utilizing two adjacent channels (e.g. adaptive channel expansion). What channels the other networks using, with the current channels available there are only four minimumally overlapping channels.
  3. KingRocky

    KingRocky LI Guru Member

    The Mac Mini uses its internal wi-fi, called Airport Extreme.
    The laptops (Both Compaqs) use their built-in wi-fi also (Broadcom chipset).
    We have a third Compaq laptop that uses a Belkin F5D7010 "Wireless G" PC Card. About 60 ft away in an adjacent building, the signal strength is good, but it refuses to connect.

    I brought in my DLink DI-524 from home and set it up right next to the GX4. Despite being much older, and sporting only one tiny antenna, I get better connections with it (though not reliable ones).

    I'm starting to wonder if there is some other type of device that is generating interference on the 2.4GHz band--but that wouldn't explain why I got such good performance out of the WRT54G. And the GX4 has the "SRX400" multi-channel feature, though I don't notice any difference when it's turned on.
  4. binarypc

    binarypc Network Guru Member

    Phones are funny

    I had a problem with my home wireless also, getting constant disconnects and misconnects. As I started reading the manuals on my phone, I found out that it wasn't a "true" 5.0GHz phone. The manual stated that it would drop to 2.4GHz for base communication (we used it for monitoring babies room) or if someone sneezed really loud.

    After replacing my dancing bandwidth phone with a Panasonic 5.0 GHz phone my wireless network issues went bye-bye.

    As a troubleshooting step, you could power off your base station and pop the batteries from any handsets and see how well that works.

    Another FYI is that I tried to connect a Belkin wireless card to my broadcom based Linksys 54G network and the chipset on the Belkin would not allow a WPA 128 bit key connection.

    So, as another troubleshooting step, you could try dropping your keys to 32/64 (or no key) temporarily to see if everything can connect that way.

    Hopefully this helps you get on the right track...

Share This Page