1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

wrtls54gs - There is not enough space on the disk

Discussion in 'HyperWRT Firmware' started by Rodb, Dec 24, 2006.

  1. Rodb

    Rodb LI Guru Member

    I get the error "There is not enough space on the disk" whenever i try to update something on the file share. I can create empty files there, and i can drag large files over, but if if try to update a file i get that error.
    It's a 320GB drive, claimed and formatted FAT32 through the router, connecting via a share from XP. Guest and Admin have rw to the share.
    The backup software always gets the same error as well.
    Any ideas?
     
  2. Thibor

    Thibor Super Moderator Staff Member Member

    if you are talking about overwriting a file with another larger file of the same name, i'm afraid i cannot confirm this symptom as i've just tried it here, and it worked without issue. the problem is that you are being a little ambiguous with your definition of "update something on the file share"
     
  3. Rodb

    Rodb LI Guru Member

    If i map a drive to a share on the Linksys and create a text file on a shared folder with nothing in it, it works fine. However, if i open that text file on the share and add some text, then try to save it, I get the error.
     
  4. Rodb

    Rodb LI Guru Member

    I actually got this working by formatting the drive as NTFS and then reconnecting it to the Linksys - for some reason FAT32 just wouldn't work for me.
     
  5. bigclaw

    bigclaw Network Guru Member

    I have noticed a similar problem. I tried to save a very small text file (actually one containing my WPA2 passphrase, about 25 characters or so) to a shared drive, and it complained about insufficient disk space. I copied a much larger file without problem. I have not determined the threshold for this to occur yet.
     
  6. grcore

    grcore Network Guru Member

    is there anything in the logs that may provide insight?

    (investigating myself, but not getting the error...)
     
  7. Rodb

    Rodb LI Guru Member

    I checked but found nothing incriminating... Now it's NTFS and working, but i think i'll cut back to FAT32 and try again out of curiosity.
     
  8. Toxic

    Toxic Administrator Staff Member

    fat32 partitions are limited to no more than 4gb files. are you trying to move files that are larger than 4Gb on FAT32?
     
  9. grcore

    grcore Network Guru Member

    Well it appears to be a zero-length file size problem between samba and Windows on a FAT partition.

    If a file has zero length and you go to edit it with windows, then when you save the file you get the error. Doing the same from a Linux box and it works fine.

    Bug confirmed in the original Linksys v2.06.0 firmware also.

    ...digging some more....

    g
     
  10. grcore

    grcore Network Guru Member

    evan more curious...

    Seems trying to save (or move) a file of less than 4096 fails, 4096 and larger is good. (something to do with allocation unit size maybe?)

    strange..

    g
     
  11. Rodb

    Rodb LI Guru Member

    Thanks, now i know it's not just me. I guess I'll stick to NTFS for a while...
     
  12. grcore

    grcore Network Guru Member

    Its Samba

    The problem is in Samba. I reverted back to the Samba code from 15c and the problem no longer exists.

    Now just need to find what Linksys did to Samba between versions....

    g
     
  13. plugh

    plugh Network Guru Member

    Thibor, did you use my samba patch in 15c or theirs?

    I think I should rescan the two sources and more closely examine the diffs between my set of patches and theirs. I posted a preliminary analysis in Hyperwrt forum shortly after 2.06 kit came out, and the samba patch was one of the differences. I'll try to get to it in the next few days.
     
  14. Thibor

    Thibor Super Moderator Staff Member Member

    theirs first, it was the cause of the issue. they only did half of what was necessary
     
  15. plugh

    plugh Network Guru Member

    Are you referring to 15c or 16 - my question was re: 15c

    ie did 15c use the samba patch michael1231 posted here (same as in 2.06 sources) or the one I posted in the other forum and sent to you back then?

    The zero length write I did looks odd, but from digging through the fat fs code, it seemed to me that was the better approach (at least with *that* fs - not sure about the others) vs skipping the write entirely...
     
  16. Thibor

    Thibor Super Moderator Staff Member Member

    15c used your patch. 16 used Linksys' and 16a used yours.
     
  17. plugh

    plugh Network Guru Member

    Ah, cool. I won't worry about that one then.
    I still want to double-check their fat patches though.
    I'll post my findings in the other forum when I'm done.
     
  18. Thibor

    Thibor Super Moderator Staff Member Member

    "the other forum"? are you referring to Hyperwrt.org? it's not a taboo word you know :)
    the error in T16 was a Samba issue, not a fat fs issue, i can pin it down to the exact line of code if you wish
     
  19. plugh

    plugh Network Guru Member

    Yeah, Hyperwrt.org; and given my samba patch was only two lines,
    identifying which one fixed the problem shouldn't be *to* hard ;)

    but anyway, I just finished my re-scan, so I'll post results here.

    Their fat patches are "ok" - identical except for tabbing and some comments, as I concluded on my first scan.

    However, seems they left out my patch to dosfstools/dosfsck/boot.c in v2.06 kit. So if you didn't include my patch in v16x, the 'unable to find volume label for fats larger than 64K' problem is still present.
     
  20. tcsdoc

    tcsdoc Network Guru Member

    I could be wrong (and often am) but FAT32 has a limit of 2.1GB and NTFS has a limit of 4GB. Or am I confusing something?
     
  21. Toxic

    Toxic Administrator Staff Member

    FAT32 has a volume limt of 32GB (in formatting) from WinXP. and FAT32 has a 4GB filesize limit on a single file.
     

Share This Page