1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

wrtp54g DNS Error/cannot connect to server

Discussion in 'Other Linksys Equipment' started by islandclassic, Jun 23, 2005.

  1. I recently purchased the wrtp54g to use with Vonage and Adelphia. I cannot get connected to the internet with this router for the life of me.

    I can reach a distination using the ip address but not by the domain name. When the browser opens it hangs and errors cannot find server.

    If I ping an ip address everything is fine, if I ping with the domain name it fails. I have checked and re-checked my my dns settings. They are set to obtain IP and DNS automatically.

    Tried to force Windoze to use of the router's address but no luck.
    Tried to clone the dns in the console but still no luck with that either.
    I have contacted Vonage, searched forums and the web but cannot find a solution.

    Can someone please, please help me out?!!!!
  2. JayC_VB

    JayC_VB Network Guru Member

    I had the same issue. Eventually ended up manually entering the DNS addresses from the Router into the TCP properties for both my Wired ethernet adapter and my Wireless adapter. Very poor solution though, since it's no longer dynamic, but it's the only way I could find to make it work.

  3. sakaike

    sakaike Network Guru Member

    Thanks JayC_VB for that "patch" solution.

    I'm in the same boat as you folks. I have Vonage and Adelphia and have the exact same issue. I was on the phone with Vonage tech support for over 4 hours last night. They insisted the issue was with firewalls stopping the complete communication between the computer and router. I was very skeptical, but it was so late that I just gave in to end the call (after 1 AM).

    Manually entering the DNS addresses got me back online, but since we commute with a couple of laptops, this can't be a permanent solution.

    FWIW - This problem is isolated to this hardware. I am a longtime Vonage and Adelphia consumer, and bought this box to replace the Linksys RT31P2 provided by Vonage, and my old Linksys BEFW11S4. They both worked like champs, but I wanted to consolidate boxes (maybe a bad move on my part). Since my phone is working perfectly, and this seems to only impact Internet access, this may need to be dealt with through Linksys tech support, and not Vonage. I haven't tried yet, but when I do, I'll post results. Anyone else with this problem, please do the same. Thanks!
  4. sakaike

    sakaike Network Guru Member

    Well, after several hours with Linksys tech support (3 levels), here is what they said, and where I stand:

    - They say it's MY fault that the device doesn't completely work for my network configuration (Tivos with wireless USB adapters and several computers connected wired and wireless). Without repeating their longwinded explanation, it boils down to their claim that no combination between Windows XP Pro and any particular router, no matter the brand, can be expected to handle every possible scenario and combination of devices and ISPs. I think that a bunch of you know what, but I'm just repeating what they said. FWIW, this statement was made by the highest up level of support I spoke to - not one of the gatekeepers.
    - The assigning of static IP addresses and DNS server addresses within the network should resolve ALL my problems. I'm not a techie, but I expressed severe reservations that would work with my laptops, which travel every day, and thus need to be able to connect to many different networks, without having to set parameters each time. I was assured that the static DNS addresses were global in nature, and I would have no problem connecting to any network.
    - For those of you who are techies (I am not one, as you can tell), you probably know what a lie that is. This morning, upon attempting to log onto my office network, I was not able to until I removed the fixed DNS server addresses, and went back to assigning DNS addresses automatically.
    - Linksys expects firmware to be updated on a periodic basis, but when I specifically asked if a new version would be pushed within the next two weeks (so I could decide whether to keep or return this unit within the two week return period), I was told definitively that there would be NO new firmware upgrades within the next two weeks. Maybe in a month...
    - During troubleshooting with Vonage, they were able to enable VOIP through my Phone 2 port, but not the Phone 1 port. However, we have not tried again since things have settled down, relatively speaking. I will be contacting Vonage again to see if both ports are indeed working.

    Bottom Line - I have my voice service back. I have been able to accomplish my primary goal of replacing two boxes (BEFW11S4 and RT312P2) with this one single box, while also upgrading to wireless G. But to do so, I have had to 1) Assign static IP addresses to my internal network, and 2) I now have to change DNS parameters every time I move between home and any other network with my laptops.

    The first change does not bother me, but the second one is incredibly annoying. I will keep this box and hope that a firmware upgrade will address it in the future.

    I post all these details in the hope that it helps others. And if someone reads this and has any advice on how to address the issues I have raised, please let me know. Thanks!
  5. dayeliu

    dayeliu Guest

    Just want to echo the exact same problem (WRTP54G can't forward DNS). This is the second time I tried a Linksys router after 10+ routers in 5+ years. All others from some cheap makers had no problem at all. I switched back to Linksys because of the wonderful words I heard from people. What a surprise!
  6. sakaike

    sakaike Network Guru Member

    I am still in the midst of testing all my devices, but it appears that the latest firmware push of 1.00.37 resolves the DNS issue. I will post again if it doesn't, but so far, so good...
  7. Anonymous

    Anonymous Guest

    I have this same problem. I can't find where to enter in my DNS manually though..I don't find that to be a problem if I knew where to do it.

    I can't find any firmware updates either.
  8. Anonymous

    Anonymous Guest

    Great post, here is the way to get the new firmware

    Firmware 1.00.37 solves the issues, but it is not available on the linksys site for download and the 1.00.20 release doesnt allow a local upgrade anyhow. A TFTP upgrade will work, but they wouldnt release it to me.

    Call into Vonage support at 1-866-243-4357, and ask to get transferred to the Advanced Solutions Department. They can remotely upgrade the firware to the 1.00.37 revision. You will need to disable the wireless portion of the router for the remote upgrade to work. Make sure you disable it under Wireless Network Mode and not Wireless SSID Broadcast as the first tech instructed me to do.

    Good luck, and the new firmware seems to have a lot more features in it...
  9. cnegron

    cnegron Network Guru Member

    Still no joy after 1.00.37

    DNS won't resolve. I manually entered DNS servers on the router but the machines will still "DHCP" the router IP. Which would be fine if the router was fwding the requests, but its not. How dissapointing this is.

    I mailed the 1.00.37 firmware to an admin here, so it should be up soon. Unfortunately, this is still not a fix for me.
  10. Anonymous

    Anonymous Guest

    Hang in there... it works.

    I had the same issue at first. I kept getting the GW IP for DNS and it wouldn't forward. I released and renewed and it worked, even though the GW was still my DNS Server. Why they dont config the darn thing to just pass along the external DNS to the DHCP client is beyond me. It isn't like they can claim it is some security feature or something. Hang in there and just ask work with the Advanced Solutions Department. It took awhile, but they did fix it for me. Make sure that wireless is disabled when you flash it. That is the big gotcha.

  11. XJJoe01

    XJJoe01 Guest

    I have the same router, but do not have the DNS problems. I have a couple of ideas to try out.

    Router: If you look at the status page, you should see the DNS servers from your ISP. If you are using the DHCP server in the Linksys, just manually add the DNS servers here.

    Clients: On your computers (wired and wireless), ensure your machines are set to DHCP, everything auto. Click the ok. After the network interface connects again, click Start->Run and type cmd. This will bring up the DOS promt. Type ipconfig /all and you will see something like this:

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\jllawrence>ipconfig /all

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Wireless-G Notebook Adapter
    Physical Address. . . . . . . . . : 00-06-25-41-AE-7E
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . :
    Subnet Mask . . . . . . . . . . . :
    Default Gateway . . . . . . . . . :
    DHCP Server . . . . . . . . . . . :
    DNS Servers . . . . . . . . . . . :
    Lease Obtained. . . . . . . . . . : Saturday, July 23, 2005 7:35:50 AM
    Lease Expires . . . . . . . . . . : Sunday, July 24, 2005 7:35:50 AM

    My linksys router is Notice it is the DNS and DHCP server. This is normal. The router is the DNS server.

    To test, type nslookup cnet.com

    You should see this:

    C:\Documents and Settings\jllawrence>nslookup cnet.
    DNS request timed out.
    timeout was 2 seconds.
    *** Can't find server name for address
    *** Default servers are not available
    Server: UnKnown

    DNS request timed out.
    timeout was 2 seconds.
    Non-authoritative answer:
    Name: cnet.com

    This indicates the router is providing DNS resulation. This means you should have no issues.

  12. Manning

    Manning Network Guru Member

    I also had this problem when I first plugged in the router. Renewing DHCP worked for me.
  13. Anonymous

    Anonymous Guest

    DNS Problems with 1.00.37

    I only began to have DNS problems after upgrading to 1.00.37. The DNS server addresses from my ISP and entered into the router Basic Setup, but when my interface comes up, the router (DHCP server) tells my PC that the DNS server is itself, not my ISP DNS servers. If I manually enter the ISP DNS servers to my interface configuration, everything is fine. This is not a firewall issue. Any more ideas?


Share This Page