1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.


Discussion in 'Cisco/Linksys Wireless Routers' started by vincentfox, Jan 24, 2006.

  1. vincentfox

    vincentfox Network Guru Member

  2. bbarrett

    bbarrett Network Guru Member

    Real-time clock for WRTSL54GS


    Did you ever come up with a way to put a real-time clock on yor WRTSL54GS? I had posted a possible solution on the BBR forums...don't know if you saw it: http://www.dslreports.com/forum/remark,15550332
  3. vincentfox

    vincentfox Network Guru Member

    No, I did not tackle that real-time clock problem yet. I was hoping to find something really straightforward and this i-Button thing looks a bit complicated so I pushed it down further on the list.

    If you have an SL and the i-Button thing, perhaps you could come up with something? It's still an important issue I think. Particularly for Mobile-AP, it would be nice if it can keep it's own time correctly since it wouldn't be online at all times.
  4. solikedude

    solikedude Guest

  5. vincentfox

    vincentfox Network Guru Member

    I think at this point the SL source-code changes have been rolled into the SVN repository. So anyone building a new copy from there would end up with the SL firmware as well as all other platforms.

    Developer nbd seems to have the most frequent snapshots of current work in progress. He seems to the most active with the pre-RC5 work. I wouldn't expect there's a big diff between Kaloz and nbd firmware at this time though, the date stamps are only 2 weeks apart. If I were going to reflash I'd probably use the nbd image though on the assumption it has a few less bugs and hopefully no new ones.

    Use all of this at own risk of course! I would probably stick with the squashfs version for it's fail-safe support, unless you really need fully-writable filesystem and like living a bit more on the edge.

    I haven't heard anything lately about how far they are from RC5 release.
  6. bbarrett

    bbarrett Network Guru Member

    How to open WRTSL54GS case


    Received my WRTSL54GS via UPS today. How do you get the case open (with minimal aesthetic damage)?
  7. vincentfox

    vincentfox Network Guru Member

    On one side there are some rubber bumps. Just pull up an edge of it and you get access to the 4 screws. No need to completely remove the rubber covers.
  8. bbarrett

    bbarrett Network Guru Member

    Ah...there ARE screws under there. I thought the top pryed off...

  9. vincentfox

    vincentfox Network Guru Member

    WARNING about OpenWRT "nbd" firmware for SL

    I was previously using Kaloz firmware on my SL, worked fine.

    I flashed the newer firmware in people/nbd directory and having problems. I would not recommend using nbd firmware until this is sorted out. The firmware I used was dated Feb 19 2006. If you have already done so and having troubles, you may need failsafe mode. For some unknown reason for me, only LAN2 and LAN4 work in failsafe mode with nbd firmware. The failsafe at least allowed me to get in and fix the unit. I am checking a few things out, and posted comments on OpenWRT forum about this error, will see what nbd or olli say.

    If you want to flash, I think Kaloz firmware is safest choice right now.
  10. JHarris9999

    JHarris9999 Network Guru Member

    :clap: vincentfox you are the man. Thanks for the work on the SL54GS. You have inspired me (and a friend of mine) to purchase a SL54GS and join the community. Just picked mine up from Fry's today (seems to be the only place in Atlanta with them in stock).

    We can I (we) do to support the community? One thing that would be nice is a html/.pdf install manual for those that are new to the process. Can you think of anything else?

    All the best,

  11. vincentfox

    vincentfox Network Guru Member

    There's some good info at http://wiki.openrwrt.org/ already. If you are familiar with Wiki editing, you are free to add to it. If not there is a "sandbox" area for experimenting with the markup language first. Documentation is the most difficult part to "get right" I think of something this complex. I was surprised how long it took me to write that seemingly simple MobileAPHowTo on the Wiki, lots of edits needed.

    Outside of OpenWRT specifically, I'm sure any HTML anyone wanted to toss together would be welcome by the folks here at LinksyInfo. They don't just do Autopsy reports, there are a few HowTo items also although they are rather old now.

    Another useful thing is new experiments (and of course documentation). That USB port has many possibilities that I think are untapped as yet. I am very interested in the vehicular applications, so I am tinkering with that a lot lately.

    I think there's a TON of work to be done on the Samba portion. Linksys firmware doesn't work very well, only supporting FAT32 semi-reliably, by most reports it craps out with large file writes also. I'm struggling to come up with ways to pin down where the problem actually lies. Is it kernel-level with VFAT, is it in the Samba code, I just am not sure. As well as USB printing. I really haven't had the time to delve into those topics in any detail.

    Important SL note that several people have confirmed:

    With Kaloz firmware dated Feb 5 2006 the LAN1 port seems not to work. I don't know the why of this perhaps it's something very trivial and easy to fix with a script or configuration change. But at this time it's important to be aware of. I had always plugged into LAN4 so I never noticed until now.

    This is pretty cool stuff, yeah. I keep expecting this thread to die out, but after 14,000+ hits and 6 pages it seems to keep going.

    What part of Atlanta? I lived there until recently, worked at Georgia Tech. That Fry's in Gwinnett was one HECK of a long way out for a MidTown-Atlantan. My favorite place though was MicroCenter, the one in Cobb was a gold-mine of bargain-bin items. Sacramento Fry's had WRT54GL on shelf as well, so it's out there on retail shelves despite rumours.
  12. JHarris9999

    JHarris9999 Network Guru Member

    Thanks for the direction about where to add my support. I do know a little about wikis and will take a look and see what I can add.

    A good friend of mine and I have fallen in love with this entire embedded linux stuff. He is far more advanced than me when it comes to linux and embedded systems (also a form Ga Tech Grad), but I have a passion for the applications and the internet. I have started calling these little boxes DADs (dedicated application devices); I have been thinking about it so much that I'm starting to see the possibility for them all over the place.

    My goal is to have a DAD that will keep the schedule for an entire family by the end of the summer. HUGE potential market for simple FTP, Blog and Web Server DADs as well.

    Well talk to you soon,


    PS My, wife and two daughters live in the Eastlake area; and a trip to Fry's is like taking a trip to another planet.
  13. vincentfox

    vincentfox Network Guru Member

    Hardware hacking

    Over on BroadbandReports.com Linksys forum, user bbarrett has a much keener eye for the hardware than me. He posted the following useful comments:

    I think there is JTAG on the board in some fashion. "JTAG" is silkscreened next to a group of resistors in at least two locations on the bottom side of the board. But I do not see a header for it anywhere. Perhaps there isn't a connector, because it's accessible only via a bed-of-nails test fixture.

    JP4 appears to be a serial port (CMOS 3.3V signaling, no RS-232 line driver). Pin 1 is 3.3V, and Pin 5 is Ground. Pin 2 has 115.2kbps output, so it is RxD. Pin 3 appears to be TxD (there is a visible trace connected to it). Pin 4 seems to be unused, but might have a function I'm unaware of. I've not had the time to make a 232 driver board and see what's on the port--I just probed with a scope and multimeter. But I'm sure it's the CFE bootloader.

    JP3 also has 3.3V at pin 1, Ground at pin 5, and traces connected to pins 2 and 3. There is no visible output on pin 2. Nonetheless, I suspect it's a 2nd serial port.

    By the way, did anyone notice that the board will support two antennae? And that LED10 is not populated--a spare GPIO for 1-Wire or other hacking...
  14. vincentfox

    vincentfox Network Guru Member

    March 8th snapshot of OpenWRT -preRC5 present in people/nbd directory, fixes the outstanding problem with LAN1 not being usable.

    Also adds the improved failsafe mode which can actually pop a message on a client PC to let you know when is the right time to hit reset to get into failsafe. This mode is like single-user on a regular Linux distro, can save your bacon if for example you fsck up a startup script. Not that I've done this.....
  15. JHarris9999

    JHarris9999 Network Guru Member


    I'm amazed and in slight shock as to how COOL OpenWRT is on SL54GS. :thumb: One of the very cool features is the ability remove/install apps via the web interface. One of my first projects will be document all of the files in the Kaloz folder. As a newbie I'm not sure where to start. How can if identify and detail all the files that have been compiled for the SL54GS?

    I would like to create either a text file or PDF with details and links. Do you think this would be valuable? I look forward to your advice.
  16. vincentfox

    vincentfox Network Guru Member

    Lots of info on OpenWRT.org site, either in the forums, the Wiki, or the buildroot or SDK. I was surprised at how easy it was to download buildroot.tar.gz on a Linux box, run make menuconfig to customize my firmware loadout, and make to build it. The Wiki is in constant need of updates though, example the VLAN stuff right now is changing but as yet undocumented. Dive in!

    If you wanted to write a popular article for a magazine, or a Introductory HowTo I'm sure no one would mind! A "Getting Started with OpenWRT" here at LinksysInfo would probably a popular addition. The site here seems short on guides and longer articles lately.

    I have a bad habit of adding a bunch of packages I *might* need like nmap, tcpdump, screen, etc. although I don't use them that often. So I'm down to 2 megs flash free right now. Still a lot of functions in under 8 megs!
  17. vincentfox

    vincentfox Network Guru Member

    less than $100 now!

    Newegg has the SL for $104.99 and a $10 rebate bringing it to $94.99. I decided to order a second unit for messing around with.
  18. vincentfox

    vincentfox Network Guru Member

    While this thread has largely served it's purpose now, several places link and people read it for starter info.

    So I will still occasionally add items of interest to it.

    One is, I really should have hacked on a serial port right at the start. That would have made the exploration much simpler. Knowing how, future projects will go quicker. At minimum, you can see the console messages fly by and you know what the hardware really is setup like.

    With the SL unit, pinouts like so:

    JP4: ttyS0, baud=115,200 8N1, no hardware flow control
    1=3.3V, 2=TX, 3=RX, 4=NC, 5=GND

    JP3: ttyS1, baud=9600 8N1, no hardware flow control
    1=3.3V, 2=TX, 3=RX, 4=NC, 5=GND

    I picked up an IDC-10 right-angle connector for 59-cents at local Fry's Electronics. This is very common part in computers so easy to find. I used the right angle-version because I planned to dremel a hole in front next to SES button so it could poke out in an accesible location. With the 10-pin connector sticking out the front like that, I can easily hook up the rest of the required equipment for a serial port when I need to. I actually think to add this cheap connector on all my routers. The MAX233 serial adapter kit (further down) is the expensive part and it seems silly to add one to every router when need for it is infrequent.

    My store had no 10-pin cable so I bought 15-pin cable and ripped away the extra 5 wires, they tear off easily. When you connect up the cable ALWAYS set it so the red striped side is pin 1 it makes things easier.

    I couldn't find a quick doc with the IDC-10 pin layout so I mapped it with my multimeter. This is looking at it with the notch on top side:
    2 4 6 8 10
    1 3 5 7 9

    You'll need one of these:


    I bought a AD233AK single-port serial (no CTS/RTS, WRT doesn't have that anyhow) kit from Compsys1.com, for extra $6 assembled instead of kit to make things easier. The serial port pinouts here are 3.3V instead of usual PC RS232 levels so you need a little circuit to convert for you.

    To get the console, I used these pins from the IDC-10 cable to the 233 board:
    wire #2 to +5V
    wire #10 to -5V
    wire #4 to TX
    wire #6 to RX

    The 233 board provides a DB9-female connector on the other side made in the DCE way. Since your PC is DTE, this means making a serial cable is REALLY simple. I just used a DB9-male and DB9-female of the type that accepts ribbon-cable and used a 9-pin ribbon cable between them. This is a "straight" cable meaning pin1 goes to pin1, etc. nothing is swapped.
  19. JHarris9999

    JHarris9999 Network Guru Member

    VincentFox Thanks for the encouragement


    Thanks for the encouragement and direction. So, LCFX and I have been successful in setting up a fully functional sl54gs blogging platform. Check it out at:


    Take a look. We would love to know what you think.

    It's not much, but a great learning platform and test bed for new ideas (and we have a ton of the them). We are learning alot about the speed of USB drives and USB memory sticks; with the hope of putting together a package or kit for those that are not yet "do it yourselfers".

    More to come,

  20. vincentfox

    vincentfox Network Guru Member

    Dang, are you really running that on an SL?
  21. JHarris9999

    JHarris9999 Network Guru Member

    Yes. It amazes me too...

    We are now trying to figure out how to get the LAMP stack into the internal ram to see if we can run SugarCRM and other popular apps. We are not sure if it will work or if it works what will break it, but we are willing to give it a try.

    I'm think of the benefit of having a low power, always on computer on the net. Maybe some light weight apps that help you organize your life could be useful. Still thinking about it.

    More to come.
  22. netddos

    netddos Network Guru Member

    omg..how did you set up your SL unit like that?

    can you provide us step by step on how to run blog server and remotely access web console on openwrt?

  23. netddos

    netddos Network Guru Member

  24. JHarris9999

    JHarris9999 Network Guru Member


    We are working on it. We had a conf. call last night to decide how to document the process. We have been hacking at it for a while and not really taking detailed notes. So, give us a week or two to refine the process and figure out how to present it to the world.

    However you could help us with the following:

    One thing that you could do a check the linkbox.denizenid.com blog regularly and and try to put a little stress on it. We are still not sure how the set up will work with multiple people using the system at once. If you have a few friends that would not mind posting to the blog that would be great as well. We need to learn how the speed of the USB storage effects the performance of the system.

    We are also in the process of finding Pivot (the blogging package the we are using) templates that are easy to modify and low in bandwidth - we think that this might help the SL when a dozen or so people try to hit the blog all at once (think the simple interface of Google)

    The last thing that would be helpful would be to find someone that could complile the 0.2.4 version of mt daaap - the itune music server, for the SL - more on that later.





    for more info.


  25. netddos

    netddos Network Guru Member

    I will gladly do the first two, but none of my friends(including myself) are knowledgeable enough to compile files. :(

    keep up the good work!
  26. netddos

    netddos Network Guru Member

    server is down on march 24th 10:51pm pacific time
  27. jmranger

    jmranger LI Guru Member

    RAM "socket"

    Just curious...

    Am I the only one getting excited about the second RAM "socket" that is visible in the autopsy photos ?

    Has anyone attempted a RAM "upgrade" on any WRT54 ?

  28. vincentfox

    vincentfox Network Guru Member

    I'm interested in the idea also. If you are successful, appreciate a note about it. I might be tempted to try it.
  29. crawdaddy

    crawdaddy Network Guru Member

    I'm decent at sautering, I sauter just about every other day at work, but I would not be confortable soldering a flat-pack ram chip to a board like that... :|
  30. jmranger

    jmranger LI Guru Member

    more guesses on RAM socket

    I don't currently have an SL, so I'm kinda limited in what I can try. However, simply by googling around, I found a couple of interesting things.

    First, there has been a fair amount of experiments with RAM tuning in the past, with the WRT54G v2.2, because some of them were shipped with 32MB but configured to only use 16. Threads are

    What I understand from there is that the CFE bootloader is in charge of initializing the SDRAM controller (both for itself and Linux) based on NVRAM settings. A list of possible values is available at

    I found SL's NVRAM default settings at
    and values appear to be compatible with those on Oleg's page.

    We also know that the SL's Hynix chip is a 16Mbit x 16, DDR333, 6ns - full datasheet at

    So my guess is that the two sockets are configured "in parallel", and that populating the second socket would make a 16Mbit x 32 configuration, but only usable if the NVRAM settings are changed accordingly (I'd guess sdram_init=0x0009 and sdram_ncdl=0x0000). Based on various post in the WRT54G v2.2 thread, this has a 99% chance of bricking for the first of us that'll try.
    So before we try, we need to either:
    find a way to try without commiting to NVRAM, or
    find a way to reset NVRAM to defaults once we bricked it.

    So the next things to check (nothing that I can try without an SL) would be:
    1) Figure whether the MIPS core in the 4704 is a BCM3302. According to
    it's as simple as
    grep cpu /proc/cpuinfo
    That info would give hints on whether Oleg's table is relevant for the SL.
    2) Use an ohmmeter on both RAM socket. If I'm right, probing on any address or chip-select line would "return "closed circuit" - same signal is provided to both RAM locations. Probing on any data line would return "open circuit", different connections from the CPU to both. This would confirm if those two sockets are connected "in parallel", as I'm guessing.

    Oh, and while I'm at it...
    3) For anyone with an open SL... On the Autopsy pictures
    the processor shield is removed, but its frame is still present. Is it soldered ? Or does it seem "easy" to remove ? It seems it must be removed if soldering of the second RAM chip is to be attempted.

    Another hint, if someone want to try...
    I've been looking for sources for the Hynix RAM, but I've been unable to find any, unless if the request is backed by a company or volume orders. However, the Micron MT46V16M16TG-6T and MT46V16M16P-6T seems to be exact replacements, available in quantity of 1 at Digikey - part number 557-1020-1-ND and 557-1185-1-ND. The spec is available here:

    Now, I'm wondering whether an x32 configuration would be faster than an x16...

  31. vincentfox

    vincentfox Network Guru Member

    # cat /proc/cpuinfo

    system type : Broadcom BCM947XX
    processor : 0
    cpu model : BCM3302 V0.6
    BogoMIPS : 263.78
    wait instruction : no
    microsecond timers : yes
    tlb_entries : 32
    extra interrupt vector : no
    hardware watchpoint : no
    VCED exceptions : not available
    VCEI exceptions : not available

    Removing the RF shield is no big deal.

    I'm interested by the claim on that guys' page that he got a BU-303 GPS working. I have been unable to duplicate that feat with a BU-353. However the Twiki page has no email or PM or identifying info that I can find, for contacting it's author. Hmmmm......
  32. jmranger

    jmranger LI Guru Member

    So it's really a 3302. Great ! Thanks for checking.

    The author is known as mrdvt92 on openwrt forums - see
    but it's not an email address...

  33. JHarris9999

    JHarris9999 Network Guru Member


    Sorry for the downtime. The linkbox is back up at linkbox.denizenid.com.

    keep posting and more to come soon.

  34. alunde

    alunde Network Guru Member

    Dedicated Blog Server on WRTSL54GS

    I've set up a WRTSL54GS using OpenWRT as a dedicated blog server. This is the second one I've set up and it's sporting a new Pivot template. The first one was for jharris9999. Thanks James for the support. If you're interested, leave a comment at:


    The next step is to automate the setup of the firmware image.

  35. JHarris9999

    JHarris9999 Network Guru Member


    OK netddos,

    Here we go.

    Alunde has decide to build a few custom Denizen Boxes for the faithful that want to blog on their GS54SLs. If you would like to sign up for one follow this link - www.denizenbox.com

    It's my understanding that he is looking for a group to beta test the entire set up and that there is still a lot of work to do before allowing the general public to play.

    All the best and thanks for posting to my box/blog


    BTW - I believe his site is running on one of his GS54SLs

  36. Toxic

    Toxic Administrator Staff Member

  37. vincentfox

    vincentfox Network Guru Member

  38. Toxic

    Toxic Administrator Staff Member


    thanks for the link however looks like you have to purchade this beta program, you forgot the fee:)

    Pay To: Lunde Cognitive Effects, Inc.
    Payment For: DenizenBox Beta Offer
    Currency: U.S. Dollars Help
    Amount: $119.99 USD
    Shipping & Handling: $12.00 USD
    Total Amount: $131.99 USD

    i think i'll give this a miss.
  39. alunde

    alunde Network Guru Member



    The $119.99 is for the router itself. At this time I'm purchasing them, reloading them, adding a USB Flash Drive and reshipping them. When I can get the process down and automated, I want to be able to offer downloading the firmware image so that you can load it directly on your WRTSL54GS. But for the time being, I have to hand-build each one. These boxes make great little dedicated servers once you put some storage on them.

    -Andrew Lunde
  40. Toxic

    Toxic Administrator Staff Member

    Thats nice m8 however could you please add this information to your site then as the site is less informative of what you are actually getting for your money :) or put a seperate post in the WRT forums about your package.
  41. albertr

    albertr LI Guru Member

    USB ports tracing

    I haven't received my WRTSL54GS yet, but looking at the pictures posted (thanks to vincentfox!) it looks like two USB2/USB1.1 ports are traced on the front of the PCB. Maybe they have designed the PCB for stacked two ports connector, but then decided to go with a single one? Anyway , the second port can be connected with a little soldering.
    There're something that looks like another three USB2 ports next to it, but there's no USB1.1 pulldown resistors present... Can someone please post a hi-res picture of the back of PCB (especially area near NEC USB controller chip)?
  42. vincentfox

    vincentfox Network Guru Member

    I sent in some high-rez of front and back but I think James decided not to post them.

    I'll dig around and if I still have them, may take a day or two, well where should I put them? I don't have a web-site.

    Would soldering new ports onto the board be better than using an external powered hub?

    I could see at least one use for another internal port though, you could mount a flash-drive nice and neat inside the case. Then still have the external port for hooking up other items.
  43. step-hen

    step-hen Network Guru Member

    rapidshare.de offers free up and downloads, up to 100MB, for up to 4 weeks.
  44. alunde

    alunde Network Guru Member

    More DenizenBox Info

    On Simon's request for more detail on our site, I've added more detail to DenizenBox. At this time, I don't have every detail enumerated, but the general gist is this:

    - First and foremost we don't pretend to know what everyone will want loaded on their router and part of this process is just to discover what people want. With only 8MEG to work with, you can't get to crazy.

    - For your $$ you get a Linksys WRTSL54GS router with OpenWRT customized for you.

    - Also a small USB Flash Drive with a customized file system.

    - And an identity via our DynDNS domain DenizenID.om so that your DenizenBox is visible to the outside world.

    - At this point we've focused on getting a decent blog software loaded and have had great success running it as an iTunes server as well. Maybe next we'll try icecast.

    We that's it for now. Come visit us, if you get a chance.
  45. albertr

    albertr LI Guru Member

    Re: USB storage

    Wouldn't OHCI give you only usb1.1 ports of NEC controller?
    AFAIK, EHCI should be supported by NEC chip.
  46. albertr

    albertr LI Guru Member

    That is exactly what I wanna do too.
    P.S. I PM'ed you my email address in case you want to email pics directly to me.
  47. vincentfox

    vincentfox Network Guru Member

    Regarding OHCI, etc.

    I was just documenting the quick steps I took to prove that things would work. OpenWRT has choices of kmod-ohci and kmod-uhci. Didn't see any kmod-ehci choice.

    For the USB2.0 support I added kmod-usb2 module.
  48. albertr

    albertr LI Guru Member

    That probably is EHCI.

  49. albertr

    albertr LI Guru Member

    I've received my SL, and second USB port is indeed traced to the connector. Its power is provided by LM3526 power regulator located on the back of the PCB. It's able to provide at least 500mA to each port.
    Both 1.1 and 2.0 controllers are connected to this port.

    So in theory all it should take to get the second USB port is just a simple replacement of USB connector with a double stacked one.
    I'll try to located a spare double stacked connector and try it out.

  50. albertr

    albertr LI Guru Member

    Got serial console connected (thanks to vincentfox for tracing the UART lines!).

    CFE version 1.0.37 for BCM947XX (32bit,SP,LE)
    Build Date: 一 11月  7 19:02:17 CST 2005 (root@localhost)
    Copyright (C) 2000,2001,2002,2003 Broadcom Corporation.
    Initializing Arena
    Initializing Devices.
    No DPN
    et0: Broadcom BCM47xx 10/100 Mbps Ethernet Controller
    rndis0: Broadcom USB RNDIS Network Adapter (P-t-P)
    et1: Broadcom BCM47xx 10/100 Mbps Ethernet Controller
    CPU type 0x29006: 264MHz
    Total memory: 32768 KBytes
    Total memory used by CFE:  0x80300000 - 0x803A3890 (669840)
    Initialized Data:          0x803397A0 - 0x8033BEB0 (10000)
    BSS Area:                  0x8033BEB0 - 0x8033D890 (6624)
    Local Heap:                0x8033D890 - 0x803A1890 (409600)
    Stack Area:                0x803A1890 - 0x803A3890 (8192)
    Text (code) segment:       0x80300000 - 0x803397A0 (235424)
    Boot area (physical):      0x003A4000 - 0x003E4000
    Relocation Factor:         I:00000000 - D:00000000
    Boot version: v3.5
    The boot is CFE
    mac_init(): Find mac [00:16:B6:06:94:7A] in location 0
    No eou key find
    Device eth0:  hwaddr 00-16-B6-06-94-7A, ipaddr, mask
          gateway not set, nameserver not set
    Reading :: Failed.: Interrupted
    CFE> ^C
    CFE> ^C
    CFE> help
    Available commands:
    rndis               Broadcom USB RNDIS utility.
    et                  Broadcom Ethernet utility.
    modify              Modify flash data.
    nvram               NVRAM utility.
    reboot              Reboot.
    flash               Update a flash memory device
    memtest             Test memory.
    f                   Fill contents of memory.
    e                   Modify contents of memory.
    d                   Dump memory.
    u                   Disassemble instructions.
    autoboot            Automatic system bootstrap.
    batch               Load a batch file into memory and execute it
    go                  Verify and boot OS image.
    boot                Load an executable file into memory and execute it
    load                Load an executable file into memory without executing it
    save                Save a region of memory to a remote file via TFTP
    ping                Ping a remote IP host.
    arp                 Display or modify the ARP Table
    ifconfig            Configure the Ethernet interface
    show devices        Display information about the installed devices.
    unsetenv            Delete an environment variable.
    printenv            Display the environment variables
    setenv              Set an environment variable.
    help                Obtain help for CFE commands
    For more information about a command, enter 'help command-name'
    *** command status = 0
    CFE> show devices
    Device Name          Description
    ------------------- ---------------------------------------------------------
    uart0                NS16550 UART at 0x18000300
    uart1                NS16550 UART at 0x18000400
    flash0.boot          New CFI flash at 1C000000 offset 00000000 size 256KB
    flash0.trx           New CFI flash at 1C000000 offset 00040000 size 1KB
    flash0.os            New CFI flash at 1C000000 offset 0004001C size 7904KB
    flash0.nvram         New CFI flash at 1C000000 offset 007F8000 size 32KB
    flash1.boot          New CFI flash at 1C000000 offset 00000000 size 256KB
    flash1.trx           New CFI flash at 1C000000 offset 00040000 size 7904KB
    flash1.nvram         New CFI flash at 1C000000 offset 007F8000 size 32KB
    flash0               New CFI flash at 1C000000 size 8192KB
    eth0                 Broadcom BCM47xx 10/100 Mbps Ethernet Controller
    eth1                 Broadcom USB RNDIS Network Adapter (P-t-P)
    eth2                 Broadcom BCM47xx 10/100 Mbps Ethernet Controller
    *** command status = 0
    CFE> printenv
    Variable Name        Value
    -------------------- --------------------------------------------------
    BOOT_CONSOLE         uart0
    CFE_VERSION          1.0.37
    CFE_MEMORYSIZE       32768
    NET_DEVICE           eth0
    STARTUP              go;
    *** command status = 0
  51. albertr

    albertr LI Guru Member

    Flashed to OpenWRT. Does anyone know why power led keeps blinking all the time and why poweroff doesn't turn power off? Are these known issues?

    md: stopping all md devices.
    flushing ide devices:
    Restarting system.
    Please stand by while rebooting the system...
    CFE version 1.0.37 for BCM947XX (32bit,SP,LE)
    Build Date: 一 11月  7 19:02:17 CST 2005 (root@localhost)
    Copyright (C) 2000,2001,2002,2003 Broadcom Corporation.
    Initializing Arena
    Initializing Devices.
    No DPN
    et0: Broadcom BCM47xx 10/100 Mbps Ethernet Controller
    rndis0: Broadcom USB RNDIS Network Adapter (P-t-P)
    et1: Broadcom BCM47xx 10/100 Mbps Ethernet Controller
    CPU type 0x29006: 264MHz
    Total memory: 32768 KBytes
    Total memory used by CFE:  0x80300000 - 0x803A3890 (669840)
    Initialized Data:          0x803397A0 - 0x8033BEB0 (10000)
    BSS Area:                  0x8033BEB0 - 0x8033D890 (6624)
    Local Heap:                0x8033D890 - 0x803A1890 (409600)
    Stack Area:                0x803A1890 - 0x803A3890 (8192)
    Text (code) segment:       0x80300000 - 0x803397A0 (235424)
    Boot area (physical):      0x003A4000 - 0x003E4000
    Relocation Factor:         I:00000000 - D:00000000
    Boot version: v3.5
    The boot is CFE
    mac_init(): Find mac [00:16:B6:06:94:7A] in location 0
    No eou key find
    Device eth0:  hwaddr 00-16-B6-06-94-7A, ipaddr, mask
          gateway not set, nameserver not set
    Reading :: Failed.: Timeout occured
    Loader:raw Filesys:raw Dev:flash0.os File: Options:(null)
    Loading: .. 3732 bytes read
    Entry at 0x80001000
    Closing network.
    Starting program at 0x80001000
    CPU revision is: 00029006
    Primary instruction cache 16kB, physically tagged, 2-way, linesize 16 bytes.
    Primary data cache 16kB, 2-way, linesize 16 bytes.
    Linux version 2.4.32 (albertr@t42) (gcc version 3.4.4 (OpenWrt-2.0)) #9 Fri Apr 28 15:17:50 EDT 2006
    Setting the PFC to its default value
    Determined physical RAM map:
    memory: 02000000 @ 00000000 (usable)
    On node 0 totalpages: 8192
    zone(0): 8192 pages.
    zone(1): 0 pages.
    zone(2): 0 pages.
    Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 init=/etc/preinit noinitrd console=ttyS0,115200
    CPU: BCM4704 rev 8 at 264 MHz
    Using 132.000 MHz high precision timer.
    Calibrating delay loop... 263.78 BogoMIPS
    Memory: 30100k/32768k available (1766k kernel code, 2668k reserved, 112k data, 92k init, 0k highmem)
    Dentry cache hash table entries: 4096 (order: 3, 32768 bytes)
    Inode cache hash table entries: 2048 (order: 2, 16384 bytes)
    Mount cache hash table entries: 512 (order: 0, 4096 bytes)
    Buffer cache hash table entries: 1024 (order: 0, 4096 bytes)
    Page-cache hash table entries: 8192 (order: 3, 32768 bytes)
    Checking for 'wait' instruction...  unavailable.
    POSIX conformance testing by UNIFIX
    PCI: Fixing up bus 0
    PCI: Fixing up bridge
    PCI: Fixing up bus 1
    Linux NET4.0 for Linux 2.4
    Based upon Swansea University Computer Society NET3.039
    Initializing RT netlink socket
    Starting kswapd
    Journalled Block Device driver loaded
    devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
    devfs: boot_options: 0x1
    JFFS2 version 2.1. (C) 2001 Red Hat, Inc., designed by Axis Communications AB.
    squashfs: version 3.0 (2006/03/15) Phillip Lougher
    pty: 256 Unix98 ptys configured
    Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI enabled
    ttyS00 at 0xb8000300 (irq = 3) is a 16550A
    ttyS01 at 0xb8000400 (irq = 3) is a 16550A
    b44.c:v0.93 (Mar, 2004)
    eth0: Broadcom 47xx 10/100BaseT Ethernet 00:16:b6:06:94:7a
    eth1: Broadcom 47xx 10/100BaseT Ethernet 00:90:4c:60:00:2b
    SCSI subsystem driver Revision: 1.00
    cfi_cmdset_0001: Erase suspend on write enabled
    Using buffer write method
    Flash device: 0x800000 at 0x1c000000
    bootloader size: 262144
    Creating 5 MTD partitions on "Physically mapped flash":
    0x00000000-0x00040000 : "cfe"
    0x00040000-0x007e0000 : "linux"
    0x000e0000-0x00540000 : "rootfs"
    0x007e0000-0x00800000 : "nvram"
    0x00540000-0x007e0000 : "OpenWrt"
    sflash: found no supported devices
    usb.c: registered new driver usbdevfs
    usb.c: registered new driver hub
    PCI: Enabling device 01:02.2 (0000 -> 0002)
    ehci_hcd 01:02.2: PCI device 1033:00e0
    ehci_hcd 01:02.2: irq 2, pci mem c0070000
    usb.c: new USB bus registered, assigned bus number 1
    ehci_hcd 01:02.2: USB 2.0 enabled, EHCI 1.00, driver 2003-Dec-29/2.4
    Manufacturer: Linux 2.4.32 ehci_hcd
    Product: PCI device 1033:00e0
    SerialNumber: 01:02.2
    hub.c: USB hub found
    hub.c: 5 ports detected
    host/usb-ohci.c: USB OHCI at membase 0xb8003000, IRQ 6
    host/usb-ohci.c: usb-00:03.0, PCI device 14e4:4715
    usb.c: new USB bus registered, assigned bus number 2
    Product: USB OHCI Root Hub
    SerialNumber: b8003000
    hub.c: USB hub found
    hub.c: 2 ports detected
    PCI: Enabling device 01:02.0 (0000 -> 0002)
    host/usb-ohci.c: USB OHCI at membase 0xc0072000, IRQ 2
    host/usb-ohci.c: usb-01:02.0, PCI device 1033:0035
    usb.c: new USB bus registered, assigned bus number 3
    Product: USB OHCI Root Hub
    SerialNumber: c0072000
    hub.c: USB hub found
    hub.c: 3 ports detected
    PCI: Enabling device 01:02.1 (0000 -> 0002)
    host/usb-ohci.c: USB OHCI at membase 0xc0074000, IRQ 2
    host/usb-ohci.c: usb-01:02.1, PCI device 1033:0035
    usb.c: new USB bus registered, assigned bus number 4
    Product: USB OHCI Root Hub
    SerialNumber: c0074000
    hub.c: USB hub found
    hub.c: 2 ports detected
    Initializing USB Mass Storage driver...
    usb.c: registered new driver usb-storage
    USB Mass Storage support registered.
    Initializing Cryptographic API
    NET4: Linux TCP/IP 1.0 for NET4.0
    IP Protocols: ICMP, UDP, TCP
    IP: routing cache hash table of 512 buckets, 4Kbytes
    TCP: Hash tables configured (established 2048 bind 4096)
    ip_conntrack version 2.1 (5953 buckets, 5953 max) - 360 bytes per conntrack
    ip_tables: (C) 2000-2002 Netfilter core team
    NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
    NET4: Ethernet Bridge 008 for NET4.0
    802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
    All bugs added by David S. Miller <davem@redhat.com>
    VFS: Mounted root (jffs2 filesystem) readonly.
    Mounted devfs on /dev
    Freeing unused kernel memory: 92k freed
    Algorithmics/MIPS FPU Emulator v1.5
    Unlocking linux ...
    Unlocking OpenWrt ...
    Erasing OpenWrt ...
    Partition moved; please reboot
    init started:  BusyBox v1.1.2 (2006.04.28-19:14+0000) multi-call binary
    Please press Enter to activate this console. jffs2.bbc: SIZE compression mode activated.
    PCI: Enabling device 01:01.0 (0004 -> 0006)
    eth2: Broadcom BCM4318 802.11 Wireless Controller
    loop: loaded (max 8 devices)
    device eth0 entered promiscuous mode
    BusyBox v1.1.2 (2006.04.28-19:14+0000) Built-in shell (ash)
    Enter 'help' for a list of built-in commands.
    _______                     ________        __
    |       |.-----.-----.-----.|  |  |  |.----.|  |_
    |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
    |_______||   __|_____|__|__||________||__|  |____|
            |__| W I R E L E S S   F R E E D O M
    KAMIKAZE (bleeding edge, r3709) -------------------
    * 10 oz Vodka       Shake well with ice and strain
    * 10 oz Triple sec  mixture into 10 shot glasses.
    * 10 oz lime juice  Salute!
  52. vincentfox

    vincentfox Network Guru Member

    I've got 2 SL's running OpenWRT RC5 and on both of them the power LED seems to be on solid, not blinking.
  53. albertr

    albertr LI Guru Member

    Blinking power light turned out to be diag not compiled into the kernel.
  54. ka9yhd

    ka9yhd LI Guru Member


    I would love to help. I am good with a soldering iron, I am an Amateur Radio op and have built many of stuff. Also used to build cell phones for Motorola.

    But I am lacking on the experience with the code, gaining more knowledge as I go. :)
  55. vincentfox

    vincentfox Network Guru Member

    A lot of the hardware details are already mapped out on the Wiki page for the SL at the OpenWRT site. See here:


    I think a big untapped area is I've seen one guy playing around with using the GPIO functions for other interesting interfaces. As previously noted the LED10 location is empty, probably used in some other product but not the Linksys version. In any case several people have said that you should be able to hack in a 1-Wire interface there. There's a number of nifty devices for the 1-Wire bus, one of which is a clock. So that would be one way to resolve the need for a real hardware clock that keeps correct time when the power is off.

    On a related note, I thought this thread being old was no longer being read. But I see the view count is up to 25,000 which is a lot of viewers! Hoping to see more people hacking on the SL!
  56. Bird333

    Bird333 Network Guru Member

    We need to get BS one of these since it seems that Linksys won't be selling any in Europe.
  57. ka9yhd

    ka9yhd LI Guru Member


    Thanks for the link. :)
  58. shishtawoo

    shishtawoo LI Guru Member


    Does installing openwrt on my WRTSL54GS require a physical mod.
  59. shishtawoo

    shishtawoo LI Guru Member


    Does installing openwrt on my WRTSL54GS requrie a physical mod.
  60. vincentfox

    vincentfox Network Guru Member

    No. Firmware flashes are something you do with a web-browser or TFTP software.
  61. Kamilion

    Kamilion Network Guru Member

    Howdy! I just got rid of my WRT54G 1.0 today, sacrificed for a project. So, I've been poking around, trying to find a suitable replacement for it.
    Looked at the WRT54GL. Eh. Same deal, slightly different processor. Then I looked at the GS. Oh dear, that's been clipped and vxworks'd up.
    So that's out. Then I happened to notice the WRTSL54GS on the shelf at fry's in sunnyvale today. $99.99. Headed home and took a quick gander at the data online. Seems like a sweet unit with 8MB of flash and 32MB of ram. I've played around with my fair share of routers, even hacking up kaid in the early days (think my tutorial's probably still stickied on the kai forums... Edit: Yep. http://texas.teamxlink.co.uk/forum/...ghlight=&sid=e39923855034353319960f4e9e71c0a1 ) and I know linux pretty decently. I'll probably head back tomorrow and pick one up. I've got a NSLU2, but depending on how well the WRTSL54GS does, it may be pulling backup duty with root over NFS pretty soon.

    Just curious, what's the current state of support for this unit?
    I havn't found much about it on the web, seems like a flurry of data in febuary and march, and then chatter afterwards.
    Do I take this to mean using thibor's HyperWRT SL version is the cutting edge, or is this a good unit to start experimenting outwards with DD-WRT or OpenWRT?

    I've been trying to get mono to compile on my slug for a while, I do a lot of work with an online metaverse called Second Life, and we have a C# based library system for interacting with the world simulation externally that can run on mono, has anyone tested installing mono-1.2 on the WRTSL54GS?

  62. Kamilion

    Kamilion Network Guru Member

    Well, picked it up today, opened the box, and was greeted with a nice big "RUN THE CD BEFORE PLUGGING IN ANYTHING" sticker covering the back ports.
    Given that I already have a real linux router and just wanted a wireless AP with USB (Oooh, Webcam and storage support... Just what I need for a cheaper wireless camera solution!)
    Running the CD just made it a pain in the butt to set up. First it showed me pictures of how to cable it all. With the power on.
    Normally this doesn't bother me too much, just about everything's plug and pray now. But there was no paper manual, just a little pamphlet outlining other linksys devices.
    Anyway, since I wasn't intending on hooking it up direct to the modem, the installation CD would stall looking for it.
    So eventually, I just closed their stupid installer and went right to the webconfig, installed thibor 15c and started poking about.
    I'm just about to throw my SSH public key on it and see how well it holds up to sftpdrive.
    Well, SSH worked out well. But shutting off DHCP and assigning the internal IP to managed to wipe out all my config settings and lock the web interface up. I had to hold the reset button down to reset to defaults.
    Plugged my NSLU2's disc into the SL, and it detected both EXT3 partitions on it and immediately mounted them for use. Very nice.

    Seems like Thibor is going to release a new version sometime soon.
    But for now, I'll stick to 15c.

    The one problem I have with the SL is that it's range seems... Severely limited, compared to my old WRT54G 1.0. I cranked the transmit power up to 84mw. Still short ranged. Is there something different about the SL's wireless chipset? Has anyone else noticed this decreased range?
  63. skilmer

    skilmer LI Guru Member

    Not sure if this will help but the first one I got would not give me a good signal in the same room, took it back and got another one and the signal is excellent now.
  64. vincentfox

    vincentfox Network Guru Member

    The SL is a mixed bag. On the one hand, plenty of flash and RAM, USB and really nice router. Well supported with OpenWRT which you MUST check out. I've never had so much power or functions in a 7-Watt device before.

    On the downside, the radio is kinda mediocre.

    I have one WiFi community network setup, where the SL unit is the brains of the operation. Runs ChilliSpot, OpenVPN, does all kinds of magic. Tossed on a 256-meg flash-drive for more local space and storage. But I disabled the SL radio because I don't need it and I have better ones. I have a bunch of WRT54GL units to do the AP radio functions with directional antenna, all connected by LAN to the SL unit. Works really well for me.
  65. dissident

    dissident LI Guru Member

    I just got a WRTSL54GS from Newegg.com today. The first thing I noticed was that the case was scratched. Not badly scratched, but enough to be annoying, since I'm neurotic that way.

    The unit wasn't in a plastic bag, which seemed odd to me. Everything else seemed fine--the AC/DC converter and the LAN cable seemed untouched, and the unit even had the "Run CD First" sticker over the LAN ports.

    This is probably the strangest question I've ever asked, but... Does the WRTSL54GS normally come in a plastic bag? (On the unit itself that is; I'm not talking about the outer shrink wrap that covers the whole box.)

    Edit: I think I found an answer, five seconds after asking. Looks like they're just packaged carelessly by Linksys. I don't think Newegg.com (or the other resellers) sent used units. Or, if they did, the marring was still caused by the lousy packaging. Oh well. The last time I returned a router for this type of thing, I got one back that had a banana-shaped antenna, and I kicked myself in the crotch for wasting time and money on return shipping.
  66. ka9yhd

    ka9yhd LI Guru Member


    Thank you for providing all of the info and doing the research on the SL. I have both the WRT54GL ver. 1.1 and the WRTSL54GS ver. 1.1 and neither will connect to my DSL provider (Covad). Covad must of changed something in their PPPoE because if I use a PC connected directly to the modem I have a connection, but neither the GL or the SL will connect or if they do get a connection, they will not hold the connection very long.

    Currently I am using a spare PC with two eithernet cards in it and I am running a Linux Firewall/ Router application called Dachstein, which is using Roaring Penguin's RP-PPPoE ver. 2.6. And I have the SL behind the Linux router as a access point.

    So far my Linux firewall/ router has not droped the connection with Covad for about 6 months.
  67. matr8x

    matr8x Guest

    Did linksys stop making this? None of the stores have this in stock. What a shame. Appears it's asus or buffalo routers for me from now on.
  68. u3gyxap

    u3gyxap Network Guru Member

    Asus wl-500g premium is the very same thing.
  69. RoadRanger

    RoadRanger LI Guru Member

    Didn't see it mentioned here so thought I would add that Thibor 17RC3 (and the stock firmware?) supports NTFS drives. I just got my SL and didn't try this with the stock firmware so don't know who/when started supporting NTFS. My 40gb bus-powered drive was originally FAT32 and wasn't recognized so I had the SL reformat it and it ended up FAT32 and readable - maybe different cluster size? Anyways I plugged it into a WinXP machine to format it as NTFS and the SL works with it fine both via CIFS shares and the resident uPNP media server. Doesn't look like DD-WRT supports the USB well enough yet for me to want to try it. Anyone know if the stock firmware supports EXT3 drives?
  70. Aquafire

    Aquafire LI Guru Member

    Hello All,

    Waiting badly for the webcam support. Wanted to turn my USB Webcam into IP Cam by hooking them up to the USB port on the router WRTSL54GS .

    Some sort of PAN and Tilt would be great as well.

    Has any of you experimented with this. It seems to be a working solution with DD-WRT



Share This Page