1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRTSL54GS with Tomtato 1.28 VPN Bricked

Discussion in 'Tomato Firmware' started by Aquafire, Jan 28, 2011.

  1. Aquafire

    Aquafire LI Guru Member


    I have bricked my Linksys WRTSL54GS with tomato 1.28 VPN , possibly due to sudden power fluctuation /outage at home.

    I have read and tried the de-bricking procedure mentioned on the forum and other places however cannot succeed.

    The step/conditions are as follows :

    1. Blinking Power LED

    2. No DMZ LED (which is supposedly the reason of trouble)

    3. Other network ports and USB LED Soild (as devices are plugged in(

    4. No Wireless LED

    5. No SES/front orange button LED coming up.

    6. Router starts and takes the default IP address , which I am able to ping not only for a short moment at startup, but even during all the time router is in bricked state and turned on, I can easily ping it.

    7. Hoping it is still alive, since I can ping it. I start the command "tftp -i PUT tomatofirmware.bin" , but the command runs for a while and then gives a timeout error.

    8. I have tried tftp numerous times with various possible timing combination however, even though the router is pining from the default IP address, I am unable to upload the firmware file to via tftp.

    I would appreciate any help/guidance for the said issue. Possibly because of the missing DMZ LED it is not accepting the tftp transfer method.

    Any ideas how to resurrect this dead unit, (would appreciate sure shot pics if a method of shorting PIN 5 and 6 is to be suggested :) )

  2. TexasFlood

    TexasFlood Network Guru Member

    I suggest reading through the DD-WRT "Recover from a bad flash" guide. Whatever happened, bad flash or otherwise, the guide may help. You can TFTP DD-WRT as per the guide then load Tomato or just TFTP Tomato instead. But if you TFTP Tomato, go with a small build, probably official build is safe.

    One note, a memory from the old days. If you're having trouble getting TFTP going because the boot_wait time is too short, you can gain a bit of an edge by plugging the WRTSL54GS and your computer both into a hub or switch. This way your computers interface is up and doesn't have to wait to be initialized by the WRTSL54GS so you can start trying to push the TFTP slightly sooner. As I remember this saved me once but it was long ago so can't be sure I'm remembering it right.
  3. mstombs

    mstombs Network Guru Member

    Also check/swap the PSU brick if you have another of correct voltage/sufficient current rating.
  4. Aquafire

    Aquafire LI Guru Member

    Will try doing it, but as the router is responding to the ping from default address , so can it be due to any voltage fluctuations.

  5. BeHappy

    BeHappy Network Guru Member

    I suggest as TexasFlood, do it w. a small fw build, less than 4 MB.
    Open 2 windows of dos-prompt; one w. ping (1) and the other one w. tftp (2)

    (1). ping -t then note the reply when the router is in the boot state (through TTL), my normal TTL is 64, boot state TTL is 100
    Pinging with 32 bytes of data:
    Reply from bytes=32 time=1ms TTL=64

    (2). Immediately when the router is in the boot state do (2)

Share This Page