1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRV200 v1.0.32.2 Beta Firmware Released

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Apr 4, 2007.

Thread Status:
Not open for further replies.
  1. Toxic

    Toxic Administrator Staff Member

    NOTE: This is Beta Firmware

    WRV200 Firmware Release Note

    4/01/2007 (beta testing)

    1. Support Vista Teredo, TCP Window Scaling, and TCP Explicit Congestion Notification (ECN).
    2. Removed the Global NAT-T checkbox from the IPSec VPN page. IPSec NAT-T is configured on a per-tunnel basis.

    Issues Fixed:
    1. Fixed an issue with internet connection lockout when the connection type is DHCP.
    2. Fixed an issue with L2TP WAN Connection Type.
    3. Fixed an issue that syslog may stop working under heavy logging workload.
    4. Fixed an issue where port forwarding will stop working when router's LAN IP is changed.
    5. Fixed an issue with SIP Application Layer Gateway (ALG).
    6. Fixed an issue with admin password, which can be 16 characters at most.

    Known Issues:
    1. IPSec tunnels do not pass NetBIOS broadcast packets. This may create a problem when users want to search computers by names or to browse the network neighborhood on Windows Explorer. Users can use a LMHOSTS file to work around this issue. More information can be found at

    If you find any issues with this firmware, please post them in this thread. Give as much detail as you can of your WRV200 setup. this helps with linksys replicating the issue. Grab the file over here: WRV200 v1.0.32.2 firmware
  2. HughR

    HughR LI Guru Member

    Is there any way that you can get the GPL'ed source for this? It would be useful to have it and its concurrent release is required by the license. I can see no reason not to release the source.
  3. TazUk

    TazUk Network Guru Member

    You can download the GPL source from this page on Linksys's website, be aware that it might not be complete though :wink1:
  4. Toxic

    Toxic Administrator Staff Member

    its a beta and therefore unofficial. I cannot see linksys releasing the gpl source code for this version. though when the next official version comes out the GPL source code should be released
  5. tsjostrom

    tsjostrom Guest

    I have the same problem with SIP ALG as in 1.0.29 sorry to say. My Grandstream Handytone 488 sees it as a symmetric NAT, which is not good for SIP

    Anyone else seing this problem?

    Tried what I can come up with to get past this problem, disabled DOS detection, basically all firewall settings where disabled at one time but no luck...
  6. MarkToo

    MarkToo LI Guru Member

    12 Hour Update

    The 2 issues that I am hoping are corrected are SIP connectivity with my Sunrocket "gizmo" and the ability to open ftp sites without rebooting the router.

    I upgraded to 12 hours ago. The good news it that both SIP and FTP are working normally right now. I'll try again later in the day.

  7. homa1978

    homa1978 LI Guru Member

    Hi !!

    Nice to hear from a new release. I have a big problem with all firmware version with pptp on wan interface. The default route will be set false. Is there any solution ???

  8. homa1978

    homa1978 LI Guru Member

    Update to my previous post.

    The last firmware where pptp is going well is 1.0.19

  9. Tom0964

    Tom0964 LI Guru Member

    VPN between 2 WRV200 with DDNS and PPPoE Connection is still not working as suspected
  10. Sfor

    Sfor Network Guru Member

    1) "Automatically adjust clock for daylight savings changes" option is not available in all GMT+01:00 time zones.

    The work around is to switch between GMT+01:00 (winter time) and GMT+02:00 (summer time) time zones.

    2) It appears, the "Cancel Changes" option is not working on the Setup - Basic Setup - Static IP screen.

    3) Some SysLog entries are corrupted:
    [New Connection] [Outgoin**q
    [URL Detect]čÂq
  11. Toxic

    Toxic Administrator Staff Member

    SFOR had you set your WRV200 to factory defaults before setting this up? can anyone else confirm this?
  12. Sfor

    Sfor Network Guru Member

    Yes, I did the hardware factory reset before and after the firmware upgrade.

    The corrupted SysLog entries are not freqent (one on a hundred, or so). So, the SysLog is working quite good, when compared to the previous firmware versions.
  13. Toxic

    Toxic Administrator Staff Member

    ok thanks for the input.
  14. MarkToo

    MarkToo LI Guru Member

    36 Hours and SIP / FTP still working!

    It has been almost 36 hours since restarting the WRV200 with and my VoIP service is still connected and I can also open FTP sites... I think this is a record for my router... I will continue to monitor.

  15. MarkToo

    MarkToo LI Guru Member

    VoIP stopped working after about 40 hours

    Well... the party is over :frown:

    Same story as before (maybe a few more hours of happiness, not sure):

    After about 40 hours my Sunrocket "Gizmo" (SIP device) lost the ability to connect to our VoIP service. My wife rebooted the WRV200 and the phone started to work again. Unfortunately, I wasn't available at the time to see if I could still access FTP sites.

  16. netgeek

    netgeek LI Guru Member

    IM Stopped after 12 hours

    I flashed to the new firmware last night and left my IM session up all night, and they just disconnected, and would not re-connect until I rebooted the router.
  17. Bishop1

    Bishop1 Guest

    I bought WRV200 4 days ago and upgraded FW to 1.0.29 version. The original FW was 1.0.13 and it must have been very bad, cause i had some problems upgrading it.

    1.0.29 was working fine. It had some minor moments but was ok. Even thou I was thinking of replacing it with WRT54G / GS. Still am.

    But 32 ver. looks promising for now. Will see how thing turn out.

    This router doesn't look like having same range as WRT54G even thou it should have longer.
  18. arSouth

    arSouth LI Guru Member

    just upgrade to the new beta firmware.

    i see you guys still have alot of problems.....
    new Firmware
    well......first thing first. the WAN connection still locks up when it's on DHCP setting, it just won't lease an IP address from the Modem.

    1.0.29 firmware
    I was having a party last night, i had my laptop running, and desktop, desktop only serving the web, and some youtube stuff. the wireless just keep dropping out on the laptop. it's was a nightmare.

    I'm going to get tire of this pretty soon, and spend $300 on a brand new Cisco 871w. let me see how much i can get from this side job.
  19. Walrus78

    Walrus78 LI Guru Member

    I know this isn't exactly on topic, but where can you get a Cisco 871w for $250?
  20. arSouth

    arSouth LI Guru Member

    ohoh.............you have to be in the Cisco Networking Academy, it's a promotional deal for Student and instructors.
    Cisco 871 for $250($street price $450-$500), 871w $300(street price around $550-$600).

    the new firmware is not up to expectation, i was just doing a light Nmap scan, and the router drop everything else............i mean everything else. Web surfing, IM client, BT,........
    I disconnected it the router for the afternoon.

    the 1.0.29 version, it's ok at lease.....
  21. MarkToo

    MarkToo LI Guru Member update - FTP and VoIP issues still unresolved

    I've had running for a while now (yes, I factory defaulted the router before upgrading). Bottom line: FTP and VoIP just don't work for more than a few hours without rebooting the WRV200. There has been no noticible improvement from previous versions of the firmware with these services. Since accessing FTP sites and using VoIP (SIP) telephone services are relatively popular functions for end users, I hope that this issue is being addressed by the developers of this product.

    Thank you,
  22. kspare

    kspare Computer Guy Staff Member Member

    can you try disabling the firewall and see if that helps?
  23. arSouth

    arSouth LI Guru Member

    well.................finally the Bittorrent is not causing other software to drop connection now.
    going to try VPN in the next few days.
    wireless is ok, not much of improvement tho....
  24. DerToob

    DerToob LI Guru Member

    - wireless is dropping out and after a few days i can´t connect to the router anymore (wireless) until hard reset

    - GUI seems to be stable.
  25. Tom0964

    Tom0964 LI Guru Member

    please, all i want is a stable ipsec vpn (PPPoE, Germany) between two wrv200 for more than a few hours!!!
  26. DocLarge

    DocLarge Super Moderator Staff Member Member


    if you can, try setting the WRV200 to "static" on your PPPoE connection and see if that's of any help. My WRV200 would die consistently if I left it set to dhcp on PPPoE connection "but" my vpn wouldn't work; when I set it up for "static" on my PPPoE connection, my vpn would work fine.

  27. MarkToo

    MarkToo LI Guru Member

    Disabling Firewal to test FTP and VoIP


    Thank you for your response.

    Anyway, as requested, I have now disabled the WRV200 firewall and restarted in order to test FTP and VoIP issues.

    Will report back.

  28. Tom0964

    Tom0964 LI Guru Member


    "static" isn't a good idea because in germany the ISP drops down the internet connection every 24 hours and authentication with connection type "PPPoE" is required. I can't use "Automatic Configuration - DHCP" or "static".

    Because both WRV have different start up time the VPN works for a few hours an then there is no way to get it work again:

    019 [Wed 19:06:42] "TunnelB" #10: [WRV200 Response:] Remote peer has no tunnel entry to correspond to this tunnel.
    020 [Wed 19:06:42] "TunnelB" #10: [WRV200 Response:] Please check your Remote Secure Gateway setting.

  29. DerToob

    DerToob LI Guru Member

    I had the same Problem. Look here:
  30. DerToob

    DerToob LI Guru Member

    By the way:

    i had to restart my WRV because the GUI wasn´t rechable.
    Except a connected tunnel no traffic was going on
  31. Tom0964

    Tom0964 LI Guru Member

    Yes same problem. I hope this will be fixed soon cause there's no chance for me to get a static IP.

  32. Sfor

    Sfor Network Guru Member

    Well. If another router would be used, it would be possible to set the WRV200 to Static IP WAN mode.

    The other router would have to be connected to the provider, WRV200 would have to be placed after the other router. The WRV200 can be set as DMZ host. So the router chain would be just to provide a static IP for WRV200.

    It is just a workaround. But it could work.
  33. Sfor

    Sfor Network Guru Member

    A whole week passed, since I've reflashed router with firmware. Everything seemed to work fine. It was a good time to put the new firmware to the second router. But, first, I decided to look at the current router status. And...

    Gosh... The system up time was just 1 day, instead of 7 days. The router must have been rebooted itself. The power supply is backed up with an UPS. So, the power outage can not be the reason. Let's look a bit closer. Perhaps a VPN log can give some information about what happened.

    Erm. The VPN log:
    There is no VPN Tunnel or Quick VPN behavior in this moment.

    But... There is an IPSec tunnel enabled and it's status is "Try to connect to Remote Peer". I've restarted the tunnel, but it changed nothing. The details button diplayed a window saying: "Tunnel Adding...Please reflash this page."???!!?. (So happened, I have not been using the VPN tunnel during last few days. So, I did not noticed the failure)

    I tried resetting, power cycling etc.. The factory default settings did the job (I had to enter all settings again, of course).

    My routers are working with Static IP, IPSec VPN, no wireless, no QOS, SysLog enabled.
    SIP and IM were working correctly - better than with 1.0.29 firmware.
    There were no GUI lockout - the other router GUI with 1.0.29 firmware crashed during the last week.
    SysLog was working quite fine, I think.
  34. Sfor

    Sfor Network Guru Member

    I gathered some more data. I had the bad router config data saved, when the IPSec VPN tunnel was locked. I saved a the current good config, as well.

    The experiment:
    - restored the bad config with the VPN tunnel locked.
    Well tunnel is locked, all right. Exacly as described in previous post.
    - disabled the tunnel, saved settings, enabled the tunnel, saved settings
    Wow. The tunnes started working. (Why I did not tried this trick before?)
    - restored the good config saved a while ago, after entering the whole config data, after router factory reset.
    Erm. The IPSec VPN tunnel is locked again. Looks like I have to disable and reenable VPN tunnels, every time I load a saved config file. That's... a bit strange, isn't it.
  35. Toxic

    Toxic Administrator Staff Member

    is the saved config from the same firmware version?
  36. MarkToo

    MarkToo LI Guru Member

    Update: Results with firewall OFF - FTP and VoIP

    Well, about 36 hours into the test suggested by kspare my WRV200 has the same problem. As suggested, I turned the firewall off to see if I would still experience FTP and VoIP issues. Unfortunately, no improvement... still needed to restart the router after about 36 hours in order to re-enable the ability to access FTP sites and connect to my VoIP service.

    Does anyone know if Linksys even considers this to be an issue?

  37. Sfor

    Sfor Network Guru Member

    Yes, it is.

    - I saved the "bad config", while IPSec tunnel was locked.
    - I did hardware factory default reset
    - I entered all the setting by hands
    The VPN tunnel was working fine
    - I saved the "good config"

    During further experiments, I've noticed the tunnel is locked every time I'm loading a config. It does not matter, if the config file was saved as "good" or "bad" one. In every case the tunnel disabling and reenabling makes it working, again.
  38. Toxic

    Toxic Administrator Staff Member

    Thanks for the info.
  39. ccbadd

    ccbadd Network Guru Member

    My uptime with the new firmware is @ 6d:10h:45m:8s. The GUI did not crash and ftp and voip is working fine. I never had problems with my voip though with any of the fw releases. I hope more people who are not having problems will reply so we can have a better feel for how the WRV200 is doing now.
  40. eaware

    eaware Guest

    no routing to internet with PPTP connection

    I have the same problem with PPTP. I checked version 1.0.19 and this version is working, all newer version connect to my ISP, it received an IP adress as well DNS server setting, but it is not working to make connections to the internet. I'm very interested in a working version that is able to connect internet via PPTP. version is working, but without the PPTP.
  41. DerToob

    DerToob LI Guru Member

    I have a wish to the linksys developers:

    could anyone enable wireless lan access to the internet by default??

    I always have to connect my PC with cable after reseting to factory default to acces the gui :frown:
  42. Jogonboch

    Jogonboch LI Guru Member

    Just upgraded to and can't access my HTTPS webserver anymore.
    With the actual firmware the WRV200 doesn't seem to forward port 443...

    Ok, HTTPS works now... so it isn't forwarding port 443. I solved the problem by using an other line in the port fowarding configuration. Maybe there is a problem with the lower lines; in line 5 it works but when I use line 7 it doesn't.

    Done a bit of testing; the first 6 forwardings work fine. Beginning with the 7th slot I'm not able to connect to any of them....
  43. Sfor

    Sfor Network Guru Member

    I can not confirm this issue.

    It works correctly in my case. But, I'm using fort forwarding with a SIP protocol.
  44. Rhoderick

    Rhoderick LI Guru Member

    I'm trying to get the WRV200 working behond a sip-spoofed Speedtouch 510 modem. In DHCP mode it's a no-go, but in static IP mode there's a little more light at the end of the (VPN)tunnel. However I need to adjust some settings like the wan subnetmask which the GUI won't let me. Is there a way to telnet or ssh into the box to adjust these?
  45. Sfor

    Sfor Network Guru Member

    It is not possible to adjust WAN net mask in the DHCP mode. You have to make all changes in the DHCP server. In your case it will be the Speedtouch 510 router.

    DHCP protocol will transfer all the changes made in the DHCP server to all devices in the network, with the WRV200 included. Reboot of the WRV200 will be necesary after making changes in the Speedtouch DHCP serwer settings, I believe.
  46. Rhoderick

    Rhoderick LI Guru Member

    I know, the sip spoof setting is a bit funny with a DHCP server mode on the modem and a static ip on the router. It's working on a BEFVP41 in DHCP client mode and an ASUS WL500Gp in static ip mode. I can't get the WRV200 to work in de DHCP mode and want to try the static ip. Thus having to change the wan_netmask and some other stuff.
  47. Sfor

    Sfor Network Guru Member

    There is no text interface in the WRV200, just the WEB GUI, as far as I know. If you will switch the mode to the static IP, you will be able to enter the IP and mask from the GUI. But, the subnets of the LAN and WAN have to be different. If subnets are the same, the router will not work correcly.

    It is not possible to set both subnets to use the same range of IP, as the WRV200 will not let to do it in the static IP mode. I'm a bit curious, if the WRV200 DHCP client will accept a WAN IP in the LAN subnet range. If yes, than it could be source of problems for the DHCP mode users.
  48. Kphth

    Kphth LI Guru Member

    GUI stops working

    I have 5 WVR200 all connecting to a WVR54G through IPSec VPN for backup purposes. They seem to work fine, except after about 4-5 days I can't log into any of the WVR200's unless I reboot them? Three are running v1.0.32.2 and the two others are running v1.0.29. I've had this issue with every firmware upgrade starting with v1.0.21. Everything still works; I just can't login to manage the routers. Is there a way to fix this or is it still just an issue?

  49. Sfor

    Sfor Network Guru Member

    In my case, I've never lost the access to the WEB GUI of, but it does reset istself. It wouldn't be a problem without a VPN locking bug. If the self reset happens, I have to switch off, then switch back on the VPN tunnel. Then it starts to work correctly, again.

    I'm curious. Does the router have a watchdog, or something rebooting it in case of some troubles?
  50. reiichiroh

    reiichiroh LI Guru Member

    I have the same problem of being unable to login to the web GUI after a few days, I mentioned it a few posts ago. This new beta has not fixed the problem since it was the same with v29.

    My Apple Airport Express didn't seem to want to obtain an IP address from the router again (the light was green before i reset the airport express) when I tried to unplug-replug it until I reset the router so it seems the DHCP server may have gone on the conk as well.
  51. yawdib2

    yawdib2 LI Guru Member


    As you can see below , the router has been up for quite awhile. I have not been doing anything fancy, Just have two wireless channle enable with 3 to 4 computers conncted via Lan. I am just testing the overall uptime without VPN and other service. I do have syslog and snmp enabled.

    Hardware Version: WRTR-147G_V02
    Software Version:
    Current Time: 2007/05/07 Mon 21:02:57 (GMT -05:00)
    System Up Time: 21d:22h:47m:50s
  52. Kphth

    Kphth LI Guru Member

    I'm having issues with the URL blocking feature. I'm trying to block the website myspace and it won’t do it. Is there something special that I have to do? I just put in www.myspace.com right? I do that then I go to my browser and type it in and it lets me access the blocked website. Anyone else having this issue?

  53. yawdib2

    yawdib2 LI Guru Member

    After you have xhosen the name of the access policy, enter a specific IP address that you want to restrict..( It appears the an IP rage will not work, it did not for me ) , you then add the URL " http://www.myspace.com/" , remember to check that the policy is enabled , then save. Of course if the sites are already in your browser cache even with the access policy you will still be able to get there. Clear the browser cache and start a new explorer seesion.. that should work.
  54. suedoenims

    suedoenims Guest

    I have been using Sunrocket Gizmo with WRV200 through many firmwares... I had to enable port triggering... NOT forwarding... on 5060 - 5061 amd 16384 - 16482... Once I did that the thing has worked better than ever... crystal clear calls and 100% uptime and reliability... GO SUNROCKET!!! You will never have another VOIP provider once you get it running and get hooked.
  55. MarkToo

    MarkToo LI Guru Member

    Sunrocket? I wonder if this will help FTP as well?


    Thanks for the info. I have been having trouble with the WRV200 and Sunrocket since the beginning (need to restart the router about once a day to keep Sunrocket connected... even with the latest firmware). Have posted many times and have never seen a firmware update help the issue. I'll have to try your approach.

    In the same way I have to reboot about once per day to be able to access FTP sites. I wonder if the Sunrocket workaround is something that could possibly help the FTP issue? Anyone?

  56. ghost_zero5

    ghost_zero5 LI Guru Member

    Trigger those ports to which ports ?

    Still I wonder when the FTP Problem will be finally solved... Although if this would work with the triggering it would be great too (would be a nice workaround) :)
  57. Kphth

    Kphth LI Guru Member

    Thanks for the help

    That seems to be working. You were right; I was setting it up for a range of IP's not just for one machine. Once I set the policy to the one IP it seemed to work ok. I'll keep watching it to make sure.

    Thanks for the help,
  58. Kphth

    Kphth LI Guru Member

    Question & Suggestion

    I have another problem that I wanted to run by the group to see if you have a work around for this issue. I would like to use the access restriction to block the web (port 80) from 8:00 PM until 8:45 AM, but for some stupid reason the time function won’t let you go from PM to AM??? Sooo I setup two policies, one to block from 8:00 PM to 11:55 PM which works great but when I tried to setup a second policy to block from 12:00 AM through 8:45 AM it wouldn’t accept the 12:00AM??? It kept switching it to 12:00PM??? So the only way to block the port is to set the second policy to block from 1:00 AM to 8:45 AM which leaves port 80 open from 11:56 PM through 12:59 AM. Any suggestions?

    As far as my suggestion, it seems to me that if you wanted to block the internet (port 80) as I do. It would be nice to be able to allow key sites that you may need access to. Sooooo, why is there no way to allow specific sites when you setup your access restrictions... Just a thought.

    Thanks for the help,
Thread Status:
Not open for further replies.

Share This Page