1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRV200 with 1.0.38 firmware can't keep TCP connection open for longer than 30 minutes

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by redox930, May 24, 2008.

  1. redox930

    redox930 Guest

    I have 2 WRV200. Both with 1.0.38 beta firmware. And both have this problem:
    I have a Zonbu mini computer that back up everything to Amazon S3 using http PUT. Recently, I found out that it can't backup anything larger than 70 MB. So first, I thought it was problem with amazon S3. But every other user told me there is no such problem. And I was able to upload 700MB to Amazon S3 at work. Then I suspect the ISP, time warner cable. Call them, and turns out not their problem either. So I decide to plug my zonbu mini directly to cable modem, and sure enough, it has no trouble uploading file all the way to 1GB. And then I realize that my remote desktop connection to work often disconnect after about 30 minutes of connection. So it would seem during those time that remote desktop connection did work pass 30 minutes, it somehow recovered. But with file upload, http PUT consistently timeout. The time 30 minutes is approximation from 70MB divided by 40KB/s which is 1750 seconds, roughly half hour. And I can see when I use wget, after about 30 minutes, it timeout, and reconnect, recover the download.

    Resetting the router doesn't make this problem go away.

    Anyone else can confirm this problem?

    Thanks in advance,

Share This Page