1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WRVS4400N (After The Download...)

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by DocLarge, Dec 6, 2007.

  1. DocLarge

    DocLarge Super Moderator Staff Member Member

    Okay,

    for those who haven't been following, I've been downloading an 11GB file from the web to see how much thrashing my 4400n can take; it's still standing :) I pulled down about 5GB of junk over a 24hr period and during that time I was still able to access my webmail server (send/receive), access my ftp server, and still have my vonage calls routed to me without packet loss (I'm using simultaneous ring). To boot, I've got a quickvpn session going to the 4400n using quickvpn client 1.0.28 (hey, it seems to work). What could make this even more interesting? The DHCP server is assigning ip addresses...

    Lately, folks have been getting WRVS4400N's that have been making loud "whining" sounds. My 4400n was one of the first made, so I'm not having this problem (I count myself lucky). The original firmware mine came with was 1.0.12; running 1.1.03 has made a world of difference with this router. To get the functionality I'm getting, here's the configuration steps I use:

    1) Disconnect "all" cables (including power)
    2) Hold down reset button, plug in power and keep holding reset button (at least 60 secs; pressing the reset button repeatedly for 10 -15 seconds can also help expedite clearing of memory)
    3) When system comes back up, configure router "via" ethernet cable; assign the computer's NIC the default ip scheme of 192.168.1.x; go into wegui and select "factory default"
    4) When system comes back up, configure router "via" ethernet cable; assign the computer's NIC the default ip scheme of 192.168.1.x again; set your configuration for the router
    5) If dhcp server issues an ip address, the router is functioning properly; if it cannot issue an ip address, the configuration is still error prone
    6) Repeat steps 2 and 3 until router can issue addresses via dhcp
    7) Once the router is issuing dhcp addresses, the router "should" be functioning and free of errors; now you can reconnect devices to WAN and LAN ports.
    8) Change the ip address from default ip scheme to whatever scheme you normally use

    I've received posts saying that users who have "whining" from their 4400n's get no benefit from this; again, the longest I've run my 4400n "without" dropouts, file transfer disconnects or loss of VOIP access was 7 days. I restarted the router using the above methodology and I'm back in good shape again just to prove it wasn't a fluke.

    (NOTE: The router dropped out initially within 4hrs, but after re-applying the technique, it's running great again).

    Overall, from what I can see, newer 4400N's appear to have a structural default (in my opinion) but if possible, to further test this, I'd like any WRVS4400N owners to try the above technique and let me know if it works for you as well as it works for me...

    Jay
     
  2. blake_

    blake_ LI Guru Member

    I'll have to give this a shot when I can be bothered reconfiguring it again... already factory reset must be at least 30 times with this router to try and fix issues with earlier firmwares.
     
  3. DocLarge

    DocLarge Super Moderator Staff Member Member

    Yesss,

    it is crazy when you do a factory reset nowadays, you have to do it "7 times as a minimum" before the memory clears. Toxic and I talked about this and the best we can come up with is whoever linksys is going to for the board (prior to badging it with the linksys name) doesn't pay enough attention when developing the memory aspect...

    I'm currently still running after the 30+ hour download (I terminated at 5GB's) and the thing is running smoothly! The clock has the most accurate time, I'm accessing the webgui via remote management, I have a vpn tunnel running to Toxic's ASA5505 which is still connected, ftp is still functioning, I'm running a session with quickvpn (1.0.28) "and it's pinging devices on the remote side!" I did notice that when I went to bed last night, quickvp had been connected fo 1hr 44mins; I woke up this morning and the connection had dropped. I've just restarted and everything appears to be fine (don't know what the drop was all about but that's quickvpn for you :) ) Oh, I forgot to mention, I changed the clock setting to local GMT via remote management because I neglected to do that after I reconfigured it the other day :)

    Dude, try it again with the steps I've posted and see what that does. I'm curious if you've got one of the first ones like I do. "If" this does work, then it will highlight a discrepancy between the WRVS4400N's coming off the assembly line recently and those of us who got ours when they were first available.
     
  4. swiego

    swiego LI Guru Member

    I followed the posted procedure exactly. So far so good although I haven't stretched the wireless component yet.
     
  5. DocLarge

    DocLarge Super Moderator Staff Member Member

    I'm not sure what you mean by "stretched the wireless component." Could you give a little more detail please?

    I've reset my WRVS4400N again using the above procedures and again, it's kicking azz!! I've been streaming from youtube.com, downloading movies via ftp from Toxics NAS as a means of testing the throughput (to include talking to him on his VOIP from my VOIP while the download was going) and there were ZERO dropouts!! As of now, it's still running fine after 6 days (almost a week now).

    FTP works, the vpn tunnels are up, VOIP is solid; I'm loving this new firmware! I'm going to see if I can get the developers to explain how to set the vlan up because even though I have a CCNA, I'm not making "heads or tails" of how to do it. Dare I say it's easier configuring vlan on an IOS router and a catalyst switch...

    Jay
     

    Attached Files:

  6. swiego

    swiego LI Guru Member

    We've had a lot of connectivity problems with wireless ever since using the latest firmware. It would disconnect everyone connected via 11b/11g every 1-2 hours regardless of the device being used. (Booted devices include multiple brand laptops, a windows mobile PDA and an iPhone.) It was as though the wireless component was just rebooting itself... but PCs and servers connected via gigabit worked fine.

    Today I'll be using wireless a lot after doing the above procedure and will see how it holds up now.
     
  7. blake_

    blake_ LI Guru Member

    Just did the steps in post#1, we will see how stable my unit is.
     
  8. DocLarge

    DocLarge Super Moderator Staff Member Member

    I'm on another reset and I'm at 7days and 3hrs; wrvs4400n is still working it with no wireless dropouts or internet disconnects! :) Internal file transfer is still solid, and I downloaded a movie from Toxic's NAS (via ftp on through his public ip) and played it without problems (I didn't have to reboot the router after the transfer which is a positive).

    I personally think the current firmware is an achievement; if you haven't done so, peops, try the reset procedure and gauge the difference.

    Jay
     
  9. blake_

    blake_ LI Guru Member

    It's been ok so far. Tell me though, can you telnet to any IP on port 5190 and get a connection? That annoys the hell out of me.
     
  10. DocLarge

    DocLarge Super Moderator Staff Member Member

    I haven't tried the telnet aspect of it because it's never been a priority to me; I'll try that this evening.

    So, your wireless is still running along with dhcp still being functional?

    jay
     
  11. blake_

    blake_ LI Guru Member

    Yeah it's working just fine, been d/l torrents for 2 days.
     
  12. DocLarge

    DocLarge Super Moderator Staff Member Member

    Just a quick function check for all my WRVS4400N owners...

    After resetting, are you guys still up and running or have you had dropouts?

    Jay
     
  13. markbjohnson

    markbjohnson LI Guru Member

    Still need to try the 7-8 reset version. Was running okay, but then lost DHCP after a few days. Everything but that is working okay now, but will try resetting again during the holidays to see if that solves the DHCP issue.
     
  14. blake_

    blake_ LI Guru Member

    Mine has crashed twice in one day. It seems to happen more frequently when I am running torrents then when I am not.
     
  15. DocLarge

    DocLarge Super Moderator Staff Member Member

    Guys,

    I "SWEAR," I'm not having these problems :) Currently, my 4400n is attached to an ethernet ADSL modem (I'm on an dsl PPPoA connection).

    Who's using cable modem and who's using DSL?

    Jay
     
  16. blake_

    blake_ LI Guru Member

    Mines using ADSL over PPPoE. I'm also on a highly attenuated line, not sure if this is related to my problems... I've tried with two different modems.
     
  17. DocLarge

    DocLarge Super Moderator Staff Member Member

    FACT:

    the connection you make to the internet (cable, PPPoA, PPPoE) does affect how the firmware performs. Most evident with me was how my wrv54g wouldn't renew the dhcp lease on the adsl connection but would then turn around and do it when I connected it to my cable modem.

    Also, my wrv200 would not run vpn tunnels on my adsl (PPPoA) line unless I set the entire router to "static." Once I did this, the vpn tunnels would connect. The only reason I checked into this as deep as I did is because Toxic said his WRV200 would run vpn tunnels just by making the connection. It turned out that he was not having issues because he was on a "cable modem" connection.

    When I had my cable modem line installed, I put my wrv200 on it, and "presto!" it ran vpn tunnels without my having to assign it a static ip address.

    I'm going to move my 4400n over to my cable modem connection and see if that affects the performance...

    jay
     
  18. Infobits

    Infobits LI Guru Member

    reviving interest in WRVS4400N v1 or v1.1 router, what's the latest verdict on it?

    I know this is an old old thread, but they still seem to be selling these routers and I just got interested in trying out the latest firmware in hopes that they have finally fixed this VPN router ready enough for prime time. DocLarge if you are still around, (or anyone else using this router) what's the latest opinion you have on it? I tried it out over 2 years ago and was so disappointed in all of its bugs and non-functioning (especially for its high price) that I returned two of them disgusted. Hope things have changed as I just ordered another WRVS4400N V1.1 from ebay and hope it works out...

    All of you folks specifying your problems and solutions, please, please, please also include info like what version of the router you are using (V1.0, V1.1)? I hope QuickVPN VPN tunneling is working with the latest fixes in place else I've just wasted a bunch of money again.
     
  19. WRVS440N Firmware 1.1.13-ETSI

    WRVS440N-UK V1.1 Manufactured Jan 2008

    Bought refurb unit from Amazon.co.uk to replace Virgin Netgear WGR614v9 which kept having to be rebooted during/after network port scans (despite unlocking and using latest firmware).

    Firmware & IPS Signature upgrade via ethernet was seamless.

    IPS Signature v.1.38 not updated since 18th July 2008 despite firmware v.1.1.13 readme file indicating that firmware includes upgraded IPS version 1.40 <shrug>

    Attached to Cable Modem, rebooted cable modem. DHCP working fine.
    Only a handful of dropped wireless packets (14) after a weeks heavy use.

    Using IPSec VPN passthru, FTP & SSH Port Forwarding, DHCP, Dynamic DNS (Virgin don't do static:mad:)

    No problems whatsoever except it does run hot if not vertical.

    Haven't tried L2 configurations but will certainly be experimenting with mirror port in the near future. Haven't done any performance testing as such but appears extremely stable and works with PS3 online gaming. Would definitely recommend.:thumbup:
     
  20. Kompressor

    Kompressor Network Guru Member

    Try throwing allot of connections at it and see how fast it goes to its knees.
     
  21. DocLarge

    DocLarge Super Moderator Staff Member Member

    Still Kicking with 1.01.8

    Well, I can still say my WRVS4400N is still whomping azz with 1.01.8; it's a version 1, by the way. It's currently connected to a verizon fios line and I smash the shizzle out of with torrent downloads. The most I've ever pulled down at once is 2GBs and it did so without any backtalk and didn't require a reboot because of being exhausted like previous firmware.

    I'm considering getting a version 2 just for a comparison...

    Jay
     

Share This Page