1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WUSB54G connection problem

Discussion in 'Other Linksys Equipment' started by argon18, Feb 28, 2005.

  1. argon18

    argon18 Guest

    I have a pc running Win XP Pro SP2 with WUSB54G. It connects to WRTG54G (with the latest Satori firmware) without any problem. But, it failed to connect to the internet. The signal strength and link quality are all good. I know the problem is not with the router as my laptop (with Intel 2200BG) is connected without issue from the same location as the pc.

    Anybody has suggestion?
  2. nicki

    nicki Network Guru Member


    I have the same device, and have experienced problems connecting when the signal is below +-60%. After the connection is established, I can move away until the signal is just one block, no problems.

    After I upgraded to the latest drivers, it solved the problem I was having. I can now connect even with 1 block showing in the signal strength.

  3. joemdmi

    joemdmi Network Guru Member

    Drivers for WUSB54G

    Where can I find the latest drivers for the WUSB54G? I couldn't find anything that looked like it in downloads.

  4. nicki

    nicki Network Guru Member

  5. joemdmi

    joemdmi Network Guru Member

  6. jagboy

    jagboy Network Guru Member


    Last Driver version: (Windows 98SE, 2000, ME and 98SE)
    Last Setup Wizard version: 4.1
    Last WLAN Monitor version: 4.1

    - Updated the Setup Wizard and Wireless Network Monitor version to 4.1.
    - Resolved wireless connection issue with any Access Point that has SSID Broadcast disabled.
    - Resolved Windows 98SE hanging issue.
    - Passed Windows 2000 and XP WHQL.

Share This Page