1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WVC54G WPA Firmware upgrade

Discussion in 'Other Linksys Equipment' started by bear105, Apr 24, 2005.

  1. bear105

    bear105 Network Guru Member

    Has anybody heard of the WVC54G Webcam having a firmware upgrade to do WPA?? Is it even capable of this?? There is NOTHING on the linksys website and no replies to my email. TIA...
  2. 2.11 (on the linksys website here) supposedly supports WPA-PSK TKIP. I have been unable to get it to work, but I'd be interested in hearing is anyone else can.


    ps. The mail notification isn't working for me either with this firmware...
  3. barwis

    barwis Network Guru Member

    I also use 2.11 firmware for WVC54G and WPA doesn't work for me... Wireless settings (SSID, WPA Key) are the same as on my WRT54GS (Alchemy stable 1.0), but it doesn't work... (I have to use wired connection between camera and router) Anyone got WPA working?
  4. merlin25

    merlin25 Network Guru Member

    I also upgrade to firmware v2.11, but I didn't get WPA connection to WRT54GS (Alchemy v1.0) up and running. Does anyone get a WPA connection to an AP with the WVC54G ?
  5. Photochromatic

    Photochromatic Network Guru Member

    Linksys Helpdesk re: WVC54G and WPA-PSK

    I upgraded to 2.11 to use WPA-PSK, and like everybody else, couldn't get it to work. I tried the online support pahes at Linksys. It wasn't very useful, but it did demonstrate what we are up against!

    Transcript follows:

    Marietta Q(17533): Hi, my name is Marietta Q(17533). How may I help you?
    You: Hello
    You: I have just upgraded the firmware in my camera to 2.11
    You: In order to use WPA-PSK authentication
    You: It doesn't connect at all if I use WPA
    You: Looking at the Linksysinfo message board, nobody seems to be able to get this to work. Is it a known bug?
    Marietta Q(17533): No. What version of Windows is currently being used on the computer? (for example, Windows 98, ME, 2000, XP, etc.)
    You: Oh Dear. XP Pro SP2. This doesn't have anywhing to do with my computer - the Linksys Camera will not associate with the Linksys AP
    Marietta Q(17533): Can you please confirm the model number of your Linksys product?
    You: Camera = WVC54G, Firmware 2.11
    You: AP = WAG54G, Firmware 1.00.39
    Marietta Q(17533): Ok
    Marietta Q(17533): Can you access the WVC54g on the LAN?
    You: No problems there. The camera has been operating perfectly on wireless as well, using WEP. I upgraded to improve the security to WPA, but that function seems completely broken.
    Marietta Q(17533): Do you have WPA option on the winXP computer?
    Marietta Q(17533): Have you loaded the winXP service patch for the computer?
    You: The computer is connected via cable
    Marietta Q(17533): Ok and how about the wireless computer?
    You: There are two other computers which are connected wirelessly using WPA
    You: One is XP2 SP2, the other is Win2k, SP whatever-is-current(!)
    Marietta Q(17533): Ok but at this time the WVC54G support 64 & 128 WEP only
    You: http://www.linksys.com/download/firmware.asp?fwid=239
    You: This is released, nob-beta firmware, with WPA
    Marietta Q(17533): Let me chekc on it hold on please
    You: OK
    Marietta Q(17533): I apologized that's right Pre-shared key, do you have that option on the WVC54g?
    You: Yes. It is configured with the same PSK as the rest of the network, but simply will not connect. I am not the only person having this problem:
    You: http://www.linksysinfo.org/modules.php?name=Forums&file=viewtopic&t=4543
    Marietta Q(17533): Ok. I would like to vreify what is exactly the error you have?
    You: There is no error - when the camera is restarted in wireless mode (it can't do wired at the same time as wireless), it just doesn't connect to the AP
    Marietta Q(17533): After you upgrade the firmware did you hold the reset button of the WVC54G and reconfigure it?
    You: Yes. It was reconfigured from scratch
    Marietta Q(17533): Ok and can you ping the WVC54g?
    You: Of course not, it hasn't associated
    Marietta Q(17533): Is the WVC54g connected to the router?
    Marietta Q(17533): I mean hardwired connected to the router?
    You: If I hardwire, everything works fine, but the WVC54G only uses ethernet OR wireless, so if it is plugged in, you can't test any wireless functions.
    Marietta Q(17533): Yes
    Marietta Q(17533): What are the lights lit on the WVC54G if it is wirelessly connected?
    You: Steady READY, ACT/LNK and WIRELESS
    Marietta Q(17533): Please verify if the UPnP and alternate port was enabled? ANd what port is it?
    You: uPNP is OFF. I have tried the default port (80) and 8080.
    You: Its not getting a layer 3 connection though - the AP doesn't even see the MAC
    Marietta Q(17533): The UPnP and alternate port should be enabled then the prot number should be 1024.
    You: One moment please...
    Marietta Q(17533): Go ahead
    You: restarting...
    Marietta Q(17533): Ok
    Marietta Q(17533): Then make sure the port 1024 was set on the router unde rth Application and Gaming.
    You: No luck. The prot forwarding won't make a difference - the AP doesn't even see the cameras MAC address if WPA is on.
    Marietta Q(17533): Did you open the ports
    You: Yes
    Marietta Q(17533): Did you set the WPA on the WAG & WVC?
    You: Yes
    Marietta Q(17533): Ok Power off the WVC54g and the computer wait for 1 minute then turn on first the computer then check the internet if it is working with WPA then turn on the WVC54g then ping the WVC.
    You: I am sorry, but you really are not understanding this. This has absolutely nothing to do with the computer. The WVC will not associate with the WAG if WPA is enabled. No MAC, no IP. If WPA is not enabled, it works perfectly. PING uses a layer 3 protocol. There is no MAC registered on the WAG for the WVC, ergo, there is no layer 2 connection.
    You: Would you please just log the call, and the second URL I sent you, with the other people who are having this problem, and have somebody test it please?
    Marietta Q(17533): Ok. Let me verify on this, hold on please
    You: ok
    Marietta Q(17533): please wait.
    Marietta Q(17533): I've tried to verify on this but we don't have any issues on it.
    You: Well would you open one please?
    Marietta Q(17533): Thank you for giving us valuablle feedback and I will forward your concern.
    You: Fine. Could I have a case number please?
    Marietta Q(17533): For your records, a transcript of this chat session will be e-mailed to you. Feel free to contact us if you require further assistance.
    You: SO what are you going to do about it?
    Marietta Q(17533): I'll be forwarding your concern on the right department then we're going to do some test as well. You may contact us again and also you may go to our website to keep posted.
    You: So, why can't you give me a case number?
    Marietta Q(17533): After this conversation there wil be a transcript of chat session will be emailed to you which also include the number and you can use it as your Reference Number.
    Marietta Q(17533): Are you still there?
    You: Yes.
    You: Thank you
    Marietta Q(17533): You're welcome.
    Marietta Q(17533): Do you have other concerns I can help you with?
    You: No. Thank you for your help.
  6. Mike95

    Mike95 Guest

    I can't get it to work also...and I have spent over two hours resetting everything ...etc.

    Same conclusion, WPA can't get it to work. I now have it hardwired with ethernet for the time being.
  7. norm911

    norm911 Network Guru Member

    I'm having the same problem. Upgraded to 2.11 for WPA-PSK support and it doesn't work. On the chat with support now and they still insist that there are no reported problems with WPA-PSK. I even pasted the link to this thread to the guy!


    More updates later,
  8. norm911

    norm911 Network Guru Member

    Well, after a lengthy chat with support, they told me that my unit must be bad because there were no known issues with WPA-PSK not working with this camera. This is despite my pointing out all of the people on this thread - including the previous chat with customer support on the topic. (sigh) I'm just going to return the camera today but I thought I'd post my transcript with customer support as well. Here we go:

    Hi, my name is John Michael B(11656). How may I help you?
    Norm: Hi John
    John Michael B(11656): Hi there! how may I help you today?
    Norm: I have just purchased a WVC54G and updated it to 2.11 firmware
    Norm: it will not work with WPA-PSK and my access point
    John Michael B(11656): +Ok
    Norm: works great when connected directly to my switch via wired ethernet
    Norm: but wireless WPA-PSK does not work
    John Michael B(11656): do you already have a WPA PSK option on the interface of the camera?
    Norm: yes, and i configured it as all the other devices on the wireless network are configured, but the camera will not connect
    Norm: i see from doing a little research that this is a known problem with v2.11?
    John Michael B(11656): No, we do not surrently have any issues as far as WPA is concerned
    Norm: hmmm
    Norm: please see the following link:
    John Michael B(11656): Ok
    Norm: http://www.linksysinfo.org/modules.php?name=Forums&file=viewtopic&t=4543
    John Michael B(11656): Can I check your camera settings.
    Norm: it clearly outlines other problems that have been reported to your help desk on this specific issue
    Norm: sure
    John Michael B(11656): That was a forum for the device, can I get your address and port for the camera?
    Norm: sure, you mean the IP address and port?
    John Michael B(11656): Yes
    John Michael B(11656): That is correct sitr
    John Michael B(11656): sir I mean
    Norm: and port 80
    John Michael B(11656): Now, can you tell me the public IP, you were telling me the lan IP a while ago
    Norm: there is no public ip - i'm using this internally only
    John Michael B(11656): Oh
    John Michael B(11656): Ok
    John Michael B(11656): What is your PSK sir?
    Norm: [norm types in his PSK]
    John Michael B(11656): Ok
    Norm: i don't see why you need that sensitive security information from my network
    Norm: that is very disconcerting
    John Michael B(11656): I was checking if it had an invalid character
    Norm: ok, just as a future reference, you might just want to ask the customer if they are using any invalid characters in their key
    John Michael B(11656): Im 10000 miles away sir, that's impossible for me to connect to you wirelessly, Okay sir.
    Norm: what would you like me to check next?
    John Michael B(11656): Now, can you tell me what lights are lit up on the camera?
    Norm: sure. Right now i have it wired, because the wireless doesn't work, so the Ethernet light is on and the ready light is on
    Norm: hello?
    John Michael B(11656): Yes
    John Michael B(11656): Im here, I was checking for current issues about the firmware
    Norm: i just wasn't sure we were still connected -what should I check next?
    Norm: ok
    Norm: thanks
    John Michael B(11656): Okay, sir can you go back to the interface of the camera
    Norm: yep, ready
    John Michael B(11656): Ok, can you tell me what IP you designated for it?
    John Michael B(11656): Ok
    John Michael B(11656): This is static right?
    Norm: yes
    John Michael B(11656): Ok
    John Michael B(11656): Can you tll me your wireless settings?
    Norm: sure
    Norm: SSID: [norm types in his SSID], Netowrk Type: Infrastructure, Security Mode: pre-shared key, Shared Key: you have that above
    John Michael B(11656): Ok
    John Michael B(11656): Can you detatch the ethernet cable now
    Norm: yes
    John Michael B(11656): Ok
    John Michael B(11656): Then unplug the power of the camera
    Norm: ok
    John Michael B(11656): Wait for about 10 secs then plug it back
    John Michael B(11656): Just the power ok?
    Norm: yep
    Norm: it's back up now, without the network cable
    John Michael B(11656): Ok
    John Michael B(11656): Tell me what lights are lit up?
    Norm: the wireless light is on solid, the act/link light is flashing, and the ready light is on solid
    John Michael B(11656): Ok
    John Michael B(11656): Do you see the connection icon on the bottom right corner?
    Norm: nope, nothing in the bottom right corner
    John Michael B(11656): Oh sorry
    John Michael B(11656): Can you try pinging the from this pc?
    Norm: sure, hang on
    Norm: nope, nothing
    Norm: and i can see from the access point that the camera is not connected
    John Michael B(11656): Can you try changing the security to disable and set the same on the camera if it connects that way sir?
    Norm: it connects fine that way
    John Michael B(11656): Ok
    Norm: and it also connects fine using WEP
    Norm: but WPA-PSK does not work
    John Michael B(11656): Please give me a few moments. I am currently doing some research on the issue and will return shortly. I apologize in advance for the delay.
    Norm: no problem
    John Michael B(11656): Sir, currently we do not have any issues arising from the WPA PSK option on the camera, the firmware was tested and intended to work with WPA-PSK, as of now, we do not have any firmwares on BETA testing or released for the camera aside from the version 2.11
    Norm: hm
    Norm: ok, what about the people on this list?
    Norm: http://www.linksysinfo.org/modules.php?name=Forums&file=viewtopic&p=26424#26424
    John Michael B(11656): If you want to, you can have the option of getting that either on WEP or if this is not an option for you, have the device replaced, I've seen the site but it would be your option to it replaced since that function is not working on your current camera, or wait for a firmware release that may fix if this is an issue, we have tested this in the Labs and found these to work. Quite possible that this maybe a device problem.
    Norm: so you're saying that this is a device problem and I should get the device replaced
    Norm: right?
    John Michael B(11656): Yes, when did you buy this sir?>
    Norm: yesterday
    John Michael B(11656): I would suggest you get this returned to the store where you bought that from so you can replace it with a new one, the WPA PSK option is not working on the camera, your rotuer has wireless clients already working so that is not the problem here. Its on the camera
    Norm: ok, well, can you please send me a transcript of this session in e-mail?
    Norm: i may need to show it to the counter clerk
    John Michael B(11656): It will be sent once you logout of the session sir.
    John Michael B(11656): Automatically
    Norm: ok, do you know if the earlier session - before the disconnect - will also be sent?
    John Michael B(11656): That should also be sent in the email that you indicate on each chat session, right now, the one you indicated is norm@laudermilch.com
    Norm: ok, thanks
    Norm: disconnected
    John Michael B(11656): disconnected
  9. merlin25

    merlin25 Network Guru Member

    Strange, I found no evidence in the WWW that someone has successfully connected a WVC54G with WPA-PSK to an AP. The only things you find are people which don't get it up and running and Linksys said that no problems with WPA are known ? Come on.
  10. technologybuilder

    technologybuilder Network Guru Member

    Possible Firmware solution...Untried.

    I've deployed enough linksys products to understand that sometimes BOTH devices have to be on a particular firmware revision in order for communication to succeed. For example, WRT54G routers and WAP54G AP's will not connect unless the WRT54G firmware is at least (this is from memory so don't hold me to this) 2.06. Could this be a similar situation where the camera is not connecting due to incompatible firmware versions? Can someone try different firmware versions to see if a combination works? I'm thinking of purchasing for a bunch of clients so this would be valuable information indeed.

  11. norm911

    norm911 Network Guru Member

    I was eventually able to get mine to work. I upgraded my Netgear access point to the latest version of the firmware and things worked fine. Mind you - the version of firmware that was on my access point at the time DID support WPA-PSK, and there were several devices connected to the access point USING WPA-PSK at the time, so the firmware upgrade should not have been an issue - but it was.

    Anyhoo, everything is working now. The video quality from the camera is not as good as I expected, but it works fine.

  12. technologybuilder

    technologybuilder Network Guru Member

    Good News!

    What type of Netgear AP are you using Norm?

  13. icreate

    icreate Guest

    I just bought this cam today and the first thing I did was upgrade to v2.11 and haven't had any problem with that. I can't seem to get the motion detect and email going though.
  14. Rozak

    Rozak Network Guru Member

    Just received my second camera and it is Firmware: V5.10, Feb 21, 2005
    ... so thought I'd try and update my first camera - only version available for downlaod is 2.11 - and hey presto done that and the motion detection stopped working :)
  15. Rozak

    Rozak Network Guru Member

    ahhh 5.10 is available from the UK linksys site - must be a UK variant - hopefully I can overwrite 2.11 with 5.10 and get my first camera back detecting motion...
  16. Amadan

    Amadan Network Guru Member

    I have searched the .com and .co.uk websites for this 5.10 firmware update for the WVC54G.

    Please put me out of my misery and let me know the URL
  17. merlin25

    merlin25 Network Guru Member

  18. Amadan

    Amadan Network Guru Member

    He does indeed.

    Thanks Merlin - you're a wizard !!

    Let's hope it works for me now. Getting very frustrated with this camera.

  19. kenshell

    kenshell Network Guru Member

    I'm using this camera (2.11) with a WRT54GX (Firmware 1.02.06)
    1-2 times a day i have to reboot the camera.
    it just keeps going out.
    any reason why?

    I'm using wep, share only.
  20. kenshell

    kenshell Network Guru Member

    i changed settings on both the router and camera.
    still have to reboot it for the camera to be seem.
    very frustrating.
  21. chud

    chud Guest

    I am glad no one can get it working with WPA as I just spent half a day unsuccessfully trying, without luck! (Incidently it was with a 2WIRE AP - with latest fiirmware)

    I have found from past experiences with Linksys their policy is to lie about there being any known problems. I have had other products with endless posts in forums about everyone having the same problem, and Linksys deny they ever have heard of such a problem when you contact them. Their first line of approach is to always tell you the unit must be defective and to return it.
  22. Thale

    Thale Network Guru Member

    Firmware 2.13 beta

    Okay folks this thread is about more disfunction - I spent 3 hours with 4 techs in the Phillipines trying to convey that which we all know - The FIRMWARE FOR THE WVC54G V.2.11 DOESN'T WORK! They kindly sent me the new beta version 2.13 and it doesn't work either. Has anyone tried the 5.1 UK version with WPA?
  23. Thale

    Thale Network Guru Member

    ATTN: WVC54g webcam owners RE firmware 2.11

    You guys will want to take note of this!!! I have WVC54G cam ver 1.1 like a lot of you I have had too many people scanning the edge of my WEP network and switched to WPA. My IP cam ver 1.0 failed to work with the firmware 2.11 they sent me the beta 2.13 which also failed.
    Luckily a buddy happens to be the GM of the local Staples and swapped the cam for me to a ver. 1.1 - WPA WORKS WITH THIS CAM!!!
    Tested both my WRT54G ver. 1 router and my new WRT54GX - both are working with the cam after installing the 2.11 firmware. Now be prepared for one freaky thing.

    Notice I did not do a hard reset, and I opened a new browser window to turn on WPA right after completing the update. Saved the WPA setting, and closed the window it popped up, then hit apply again at the bottom of the main window, just to make sure of the settings.

    I pulled the ethernet and power cycled the cam after loading 2.11 and the cam didn't look like it was going to power up at all. I pulled the power and plugged the ethernet back in and it started to power up, soon as I saw the lights I pulled the cable again.

    I enabled DHCP just so I could make sure the cam was communicating. I am up and running!!! Camera 1.1 works!
  24. merlin25

    merlin25 Network Guru Member

    Possible to download beta FW 2.13 somewhere ?

  25. Thale

    Thale Network Guru Member

    firmware 2.13

    No place to get it online, I have a few messages from the beta team and they still seem confused. 2.13 Does NOT work to correct this problem of the WVC54G not making a WPA connection. I made mine work with a new cam Ver1.1 and promptly upgraded to 2.11. I could not make my old ver 1.0 cam work with WPA ever, and neither can Linksys. I suspect the hardware is holding data even on a hard reset and the cam has held some of the WEP key data.

    What's worse is none of the Linksys support people acknowlege there is even an issue. I offered all my data to help find a fix for everyone else.
  26. Photochromatic

    Photochromatic Network Guru Member

    I had a call logged with Linksys about this issue for months.
    They did nothing except send me an email every few weeks saying they were going to close the call.
    Eventually they did close the call, despite my insistance that they fix the problem first!

    All in all, in 20 years in IT, I think Linksys offer the worst customer service I have ever seen.
  27. laguy90019

    laguy90019 Guest

    I was able to get it to work. I upgraded the firmware and then I had to do a reset on the camera to set it back to the factory defaults and then had to completely reconfigure. After that, it would work with WPA TKIP but I could not get it to work with WPA2
  28. hollosi

    hollosi Guest

    WPA works if you use a shorter pass phrase

    I spent hours trying with a long phrase (that works on any other device, btw) and it didn't work, then I tried it with a shorter one and it did work immediately.
  29. tnnuk

    tnnuk Network Guru Member

    I got the WPA to work just now.

    Got a UK unit, was version 5, Feb 2nd 05 - downloaded the new 2.1 March 05.


    It reset itself to default settings again.

    Set it back up to WEP.

    Found that WPA was finally set up.

    Changed to WPA SK.

    Works wirelessly on my netgear AP.

    But alas motion detection is now a waste of time. Booooo.

    PLUS - the unit continues to poweroff (stall, go dead) after a few hours - guess it just overheats and dies.

    Waste of £120 - would have been better off with a dlink I think.
  30. tnnuk

    tnnuk Network Guru Member

    Has anyone got the WPA firmware and email detection to work on this piece of junk yet?
  31. mrt737

    mrt737 Network Guru Member

    I have a WVC54G 1.1 running firmware 2.11 and like everyone else, WPA does not work with either my NetGear or D-Link Wireless Routers.

    However, I found firmware EU 2.12 (dated 26/05/2005) downloadable from here ftp://ftp.linksys.com/international/firmware/WVC54G_EU_2_12.zip

    Applied the firmware and still no ability to use WPA-PSK.

    However, I do notice now that the WVC54G is now able to successfully authenticate using WPA-PSK on my D-Link DI-624 Wireless Router (previously kept trying without success in the DI-624 Logs), but is not able to get an IP Address (DHCP is enabled on the Wireless Router).

    I have tried to upgrade to firmware 5.10 from the Linksys UK site but the stupid WVC54G doesn't seem to want to upgrade to 5.10 at all. Does not accept the firmware.

    Stupid thing...! I've given up trying to get it to work and I don't want to go back to using WEP just for the sake of the use of this piece of cr*p!
  32. svg1

    svg1 Network Guru Member

    Using firmware 2.12eu on a version 1.1 wvc im able to connect wirelessly using wpa-tkip to a wrt54gc .

    I set a static ip for the camera & use a 8 character PSK .

    Email video even works .. :D
  33. mrt737

    mrt737 Network Guru Member

    Actually you are right... once I had set the WVC54G to a Static IP, I was able to connect to it Wirelessly.

    WPA-PSK is finally working!
  34. svg1

    svg1 Network Guru Member

    Glad you got it working . :)

    To get the wvc to email video , enter your mail severs smtp address in numerical form instead of the dns address .

    Example : Enter 209 .112.168.121 instead of smtp.mail.yourisp.net

    Use your regular email address as the FROM: address & a hotmail or yahoo mail account for the TO: address .

    Edit : Also on the same setup page you enter your email info theres a field that asks if your smtp mail server requires authentication .

    I leave this field blank & disabled even though my mail server does in fact require authentication . If i enable that feature & enter my password it wont send but if i leave it blank & disabled it works .

    Dont know if its a problem with my ISP or a bug in the firmware , hence thats why i say use a hotmail or yahoo email as the TO: address . This is the only way i can get it to work . YMMV so playing with those settings a bit if it dont work at first try may be the key.
  35. Mikeg0625

    Mikeg0625 Guest

    I can confirm that WPA only works with V 1.1 of the camera. You can dowmlaod the latest firmware for the camera, but WPA will not work if the camera is V 1.0. I had my unit RMA'd and I rec'd a refurbished 1.1 camera. When I uploaded the new firmware, WPA worked first time
  36. tech_nik

    tech_nik Guest

    I'm UK, and have this morning setup my V1.1 WVC54G camera to connect to my LinkSys WRT54GS (f/w V4.7) via 802.11g using WPA-TKIP.

    Trick for me was to use V2.12 firmware from...


    ...filename: WVC54G_EU_2_12.zip

    Could never get it to work until I got the 2.12 firmware!

    Hope this helps :)
  37. llejoly

    llejoly Guest

    With firmware 2.12, I have same problem...
    PSK_WPA don't work ?
    Have somebody solution ?

Share This Page